Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 271607 - [patch] app-accessibility/speech-tools-1.2.96_beta fails to build with gcc-4.4
Summary: [patch] app-accessibility/speech-tools-1.2.96_beta fails to build with gcc-4.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Jesus Rivero (RETIRED)
URL:
Whiteboard:
Keywords: Inclusion
: 273765 (view as bug list)
Depends on:
Blocks: gcc-4.4 glibc-2.10
  Show dependency tree
 
Reported: 2009-05-29 06:49 UTC by hirakendu
Modified: 2009-07-23 16:48 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for speech-tools to build with gcc-4.4 (speech-tools-1.2.96_beta-gcc44.patch,579 bytes, patch)
2009-05-29 06:49 UTC, hirakendu
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description hirakendu 2009-05-29 06:49:16 UTC
usual type conversion error. 

Reproducible: Always
Comment 1 hirakendu 2009-05-29 06:49:54 UTC
Created attachment 192785 [details, diff]
patch for speech-tools to build with gcc-4.4
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-05 23:49:32 UTC
*** Bug 273765 has been marked as a duplicate of this bug. ***
Comment 3 Samuli Suominen gentoo-dev 2009-07-23 16:48:53 UTC
+  23 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+  speech-tools-1.2.96_beta.ebuild,
+  +files/speech-tools-1.2.96_beta-gcc44.patch:
+  Fix building with glibc-2.10+ wrt #271607, thanks to hirakendu.