Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 271091 - [version bump] net-im/psi-0.13_rc1
Summary: [version bump] net-im/psi-0.13_rc1
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Peter Volkov (RETIRED)
URL: http://forum.psi-im.org/thread/5308
Whiteboard:
Keywords:
: 271089 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-24 17:27 UTC by Dennis Schridde
Modified: 2009-07-13 18:15 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for no avcall dialog bug (avcall_dlg.patch,301 bytes, patch)
2009-06-01 15:09 UTC, Petr Morávek
Details | Diff
psi-0.13_rc1.ebuild.patch (psi-0.13_rc1.ebuild.patch,2.48 KB, patch)
2009-06-02 21:04 UTC, Davide Pesavento
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2009-05-24 17:27:50 UTC
Version 0.13_rc1 of net-im/psi was released recently.
Since voice calls (Jingle RTP) introduce new dependencies (see http://delta.affinix.com/psimedia/), I think it is advisable to test the build process before the final release.

Reproducible: Always
Comment 1 Justin Lecher (RETIRED) gentoo-dev 2009-05-24 17:45:34 UTC
*** Bug 271089 has been marked as a duplicate of this bug. ***
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2009-05-29 09:56:44 UTC
Thank you for report, Dennis. Psi bumped, psimedia added to the tree. Both masked for now but still I'm interested in reports.

And btw, psimedia is not a dependency but plugin.
Comment 3 Petr Morávek 2009-05-31 17:10:54 UTC
I guess it would be better to add new USE flag for psi ebuild (e.g. jingle) that would pull in the psimedia dependency.
Comment 4 Dennis Schridde 2009-05-31 18:04:50 UTC
Another request for a useflag: extra-icons.
I do not need the icons from Psi+, and the doubled sets look confusing in the settings dialogue.
Comment 5 Petr Morávek 2009-05-31 20:14:18 UTC
btw, did anyone got the voice call running? I've got latest psi and psimedia from portage, but the option voice call doesn't do anything.
Comment 6 Dennis Schridde 2009-05-31 20:29:36 UTC
(In reply to comment #5)
> btw, did anyone got the voice call running?
OT: Initiated a call to Kopete 0.70.2, but the other end was not able to take the connection. Heard reports that it worked for someone else, though.
Comment 7 Peter Volkov (RETIRED) gentoo-dev 2009-06-01 08:59:02 UTC
Thank you for reports guys. Personally I failed to get voice chat working, but I don't have setup with real IP address which I suppose is required. At least that's what I was told by guys that had this setup working.

(In reply to comment #3)
> I guess it would be better to add new USE flag for psi ebuild (e.g. jingle)
> that would pull in the psimedia dependency.

I'd better not, since psimedia has nothing to do with XEP-0166 (Jingle). Or... take a look at upstream site: What PsiMedia does not do: * Implement Jingle or anything XMPP.

Probably I better add elog here to tell users about psimedia.

(In reply to comment #4)
> Another request for a useflag: extra-icons.
> I do not need the icons from Psi+, and the doubled sets look confusing in the
> settings dialogue.

The only doubled sets I found are mood icons (slik) and clients icons. I'm going to fix that now, all other sets are different. Or do you see any other doubled sets?
Comment 8 Leonid Evdokimov 2009-06-01 10:25:32 UTC
(In reply to comment #7)
> Personally I failed to get voice chat working, but
> I don't have setup with real IP address which I suppose is required. At least
> that's what I was told by guys that had this setup working.

I'm not sure if it applies to Psi, but I had voice chat working with telepathy when both parties were behind NAT.
Comment 9 Peter Volkov (RETIRED) gentoo-dev 2009-06-01 11:36:39 UTC
(In reply to comment #8)
> I'm not sure if it applies to Psi, but I had voice chat working with telepathy
> when both parties were behind NAT.

Interesting. I'll try to investigate this further then...

Anyway, I've committed some fixes into psi. Please, report if anything else is required.

Comment 10 Petr Morávek 2009-06-01 11:50:19 UTC
(In reply to comment #7)
> I'd better not, since psimedia has nothing to do with XEP-0166 (Jingle). Or...
> take a look at upstream site: What PsiMedia does not do: * Implement Jingle or
> anything XMPP.

OK, then the USE flag could be "voice" or whatever suites better. It makes more sense to me, that the psimedia is in fact (optional) dependency: want Psi with voice calls => need psimedia.


My question about voice calls motivated by unusual bug I ran into - I can see voice call option, but it doesn't do anything - no error, no voice dialog... I'll try to investigate more and let know the upstream.

OT: Voice and NAT - it depends what kind of NAT that is, you need STUN (or better TURN) server to traverse through.
Comment 11 Petr Morávek 2009-06-01 15:09:09 UTC
Created attachment 193152 [details, diff]
Patch for no avcall dialog bug

As I wrote before I ran into a bug, that I didn't get any avcall dialog. I'm not sure what the trigger condition is.
Anyway thanks to textshell in Psi MUC here is working patch.

(Psi devs are aware of this bug and it should be fixed in final version.)
Comment 12 Leonid Evdokimov 2009-06-02 10:29:33 UTC
(In reply to comment #9)
> Anyway, I've committed some fixes into psi. Please, report if anything else is
> required.

You may also lower DEPEND=">=dev-libs/glib-2.20.0 ..." to DEPEND="dev-libs/glib ..."

psimedia builds ok with glib-2.18.4-r1 (current stable) and glib>=2.20.0 dependency is not mentioned at psimedia homepage.
Comment 13 Dennis Schridde 2009-06-02 10:53:05 UTC
(In reply to comment #12)
> You may also lower DEPEND=">=dev-libs/glib-2.20.0" to DEPEND="dev-libs/glib"
> psimedia builds ok with glib-2.18.4-r1 (current stable)
There are also glib-2.16 and glib-1.2 in the tree, so I would recommend DEPEND=">=dev-libs/glib-2.18" unless someone confirmed that it builds and works with the other two.
Comment 14 Peter Volkov (RETIRED) gentoo-dev 2009-06-02 17:08:31 UTC
(In reply to comment #11)
> Created an attachment (id=193152) [edit]
> Patch for no avcall dialog bug

Thank you Petr. Patch was added to the tree.

Leonid, Dennis I've updated dependency. This ebuild was taken from overlay and I thought this dependency was put there for some reason and had not time to check myself. Thank you for checking that it really works.
Comment 15 Davide Pesavento gentoo-dev 2009-06-02 19:31:34 UTC
I agree with Petr. IMHO, you should add a 'jingle' USE flag, which adds a PDEPEND on psimedia. Having a USE with an additional dep does not mean that the dependency implements jingle, but that the additional dep is required to have voice calls (aka jingle) functionality in the software in question (psi).
Comment 16 Davide Pesavento gentoo-dev 2009-06-02 21:04:01 UTC
Created attachment 193322 [details, diff]
psi-0.13_rc1.ebuild.patch

Please consider this patch. It implements the 'jingle' USE flag and moves both qca plugins to PDEPEND, too. Also src_configure is a bit better and it fixes a typo ${get_libdir} -> $(get_libdir).
Comment 17 Dennis Schridde 2009-07-07 10:09:36 UTC
(In reply to comment #16)
> Created an attachment (id=193322) [edit]
> psi-0.13_rc1.ebuild.patch
> 
> Please consider this patch. It implements the 'jingle' USE flag and moves both
> qca plugins to PDEPEND, too. Also src_configure is a bit better and it fixes a
> typo ${get_libdir} -> $(get_libdir).
Has this been incorporated into the official tree yet?

On an additional note: 0.13_rc2 has been released. (psi-0.13_rc1-dialog-show.patch and 420-psi-add-detection-some-os.diff (latter being from psi+) do no longer apply cleanly)
Comment 18 Peter Volkov (RETIRED) gentoo-dev 2009-07-08 10:44:52 UTC
Dennis thank you for your suggestion. I like you code more, so I've included it in psi-0.13_rc2. jingle USE flag was added too.

Guys, please, test, report and enjoy :)
Comment 19 Dennis Schridde 2009-07-09 07:20:06 UTC
net-im/psi-0.13_rc2: !!! Couldn't download 'psi-extra-iconsets-r654.tar.bz2'. Aborting.
Comment 20 Peter Volkov (RETIRED) gentoo-dev 2009-07-09 08:24:05 UTC
(In reply to comment #19)
> net-im/psi-0.13_rc2: !!! Couldn't download 'psi-extra-iconsets-r654.tar.bz2'.
> Aborting.

Hm, try another time, please. Probably I forgot to distribute this file. Thanks.

Comment 21 Dennis Schridde 2009-07-09 21:16:01 UTC
 * Failed Patch: 640-psi-send-button-context-menu.diff !
 *  ( /var/tmp/portage/net-im/psi-0.13_rc2/work/patch/640-psi-send-button-context-menu.diff )

Relevant patch output:
PATCH COMMAND:   patch -p1 -g0 -E --no-backup-if-mismatch < /var/tmp/portage/net-im/psi-0.13_rc2/work/patch/640-psi-send-button-context-menu.diff

=================================================
patching file src/chatdlg.ui                     
Hunk #1 succeeded at 319 with fuzz 2 (offset -10 lines).
patching file src/groupchatdlg.cpp                      
Hunk #5 FAILED at 770.                                  
Hunk #6 succeeded at 1994 (offset -2 lines).            
1 out of 6 hunks FAILED -- saving rejects to file src/groupchatdlg.cpp.rej
patching file src/groupchatdlg.h                                          
patching file src/groupchatdlg.ui                                         
Hunk #1 FAILED at 287.                                                    
1 out of 1 hunk FAILED -- saving rejects to file src/groupchatdlg.ui.rej  
patching file src/psichatdlg.cpp                                          
Hunk #3 FAILED at 219.                                                    
Hunk #4 succeeded at 343 (offset -2 lines).                               
Hunk #5 succeeded at 355 (offset -2 lines).                               
Hunk #6 succeeded at 694 (offset -2 lines).                               
1 out of 6 hunks FAILED -- saving rejects to file src/psichatdlg.cpp.rej  
patching file src/psichatdlg.h                                            
patching file src/sendbuttonmenu.cpp                                      
patching file src/sendbuttonmenu.h                                        
patching file src/sendbuttontemplateseditor.ui                            
patching file src/src.pri                                                 
patching file options/default.xml                                         
Comment 22 Peter Volkov (RETIRED) gentoo-dev 2009-07-10 06:18:49 UTC
Thank you for report Denis. I'm unable to reproduce this problem. Make sure you are using ebuild from the tree and if it's the case, please, open new bug with emerge --info and full build log and output of env command. Closing this bug as it's possible that I miss future updates here.

>>> Emerging (1 of 1) net-im/psi-0.13_rc2
 * psi-extra-iconsets-r654.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                        [ ok ]
 * psi-langs-20090217.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                             [ ok ]
 * psi-0.13-rc2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                   [ ok ]
 * psi-extra-patches-r654.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                         [ ok ]
 * checking ebuild checksums ;-) ...                                                                                      [ ok ]
 * checking auxfile checksums ;-) ...                                                                                     [ ok ]
 * checking miscfile checksums ;-) ...                                                                                    [ ok ]
>>> Unpacking source...
>>> Unpacking psi-extra-iconsets-r654.tar.bz2 to /vt/portage/tmp/portage/net-im/psi-0.13_rc2/work
>>> Unpacking psi-langs-20090217.tar.bz2 to /vt/portage/tmp/portage/net-im/psi-0.13_rc2/work
>>> Unpacking psi-0.13-rc2.tar.bz2 to /vt/portage/tmp/portage/net-im/psi-0.13_rc2/work
>>> Unpacking psi-extra-patches-r654.tar.bz2 to /vt/portage/tmp/portage/net-im/psi-0.13_rc2/work
>>> Source unpacked in /vt/portage/tmp/portage/net-im/psi-0.13_rc2/work
>>> Preparing source in /vt/portage/tmp/portage/net-im/psi-0.13_rc2/work/psi-0.13-rc2 ...
 * You're about to build heavily patched version of Psi called Psi+.
 * It has really nice features but still under heavy development.
 * Take a look at homepage for more info: http://code.google.com/p/psi-dev
 * If you wish to disable some patches just put
 * MY_EPATCH_EXCLUDE="list of patches"
 * into /etc/portage/env/net-im/psi file.
 * Applying various patches (bugfixes/updates) ...
 *   000-about-psi-plus.diff ...                                                                                           [ ok ]
 *   005-psi-win32-pre-patching.diff ...                                                                                   [ ok ]
 *   010-psi-additional-system-iconset.diff ...                                                                            [ ok ]
 *   020-psi-muc-kickban-reasons.diff ...                                                                                  [ ok ]
 *   030-psi-vcard-save.diff ...                                                                                           [ ok ]
 *   040-psi-muc-topic.diff ...                                                                                            [ ok ]
 *   050-psi-quick-disco.diff ...                                                                                          [ ok ]
 *   060-psi-receipts.diff ...                                                                                             [ ok ]
 *   070-psi-muc-user-count.diff ...                                                                                       [ ok ]
 *   080-psi-popup-avatar.diff ...                                                                                         [ ok ]
 *   090-psi-entity-time.diff ...                                                                                          [ ok ]
 *   100-psi-mood-icons.diff ...                                                                                           [ ok ]
 *   110-psi-muc-change-affiliation.diff ...                                                                               [ ok ]
 *   120-psi-muc-nickclick-chat.diff ...                                                                                   [ ok ]
 *   130-psi-send-button-arrow.diff ...                                                                                    [ ok ]
 *   140-psi-bookmark-skip.diff ...                                                                                        [ ok ]
 *   150-psi-muc-notify-highlight.diff ...                                                                                 [ ok ]
 *   160-psi-icon-actions-shortcuts.diff ...                                                                               [ ok ]
 *   170-psi-vcard-clickable-photo.diff ...                                                                                [ ok ]
 *   180-psi-user-activity.diff ...                                                                                        [ ok ]
 *   190-psi-highlighted-color.diff ...                                                                                    [ ok ]
 *   200-psi-tab-status-icon.diff ...                                                                                      [ ok ]
 *   210-psi-typed-history.diff ...                                                                                        [ ok ]
 *   220-psi-roster-disable-scrollbar.diff ...                                                                             [ ok ]
 *   230-psi-status-align-center.diff ...                                                                                  [ ok ]
 *   240-psi-nix-audacious.diff ...                                                                                        [ ok ]
 *   250-psi-roster-avatars.diff ...                                                                                       [ ok ]
 *   260-psi-default-account-settings.diff ...                                                                             [ ok ]
 *   280-psi-roster-settings.diff ...                                                                                      [ ok ]
 *   290-psi-passive-popups-delays.diff ...                                                                                [ ok ]
 *   300-psi-idle-mcmd-command.diff ...                                                                                    [ ok ]
 *   310-psi-muc-minimize-to-roster.diff ...                                                                               [ ok ]
 *   320-psi-altN-key-switch-tab.diff ...                                                                                  [ ok ]
 *   330-psi-tab-close-middle-click.diff ...                                                                               [ ok ]
 *   340-psi-client-icons.diff ...                                                                                         [ ok ]
 *   350-psi-roster-icons.diff ...                                                                                         [ ok ]
 *   360-psi-chat-nick-colors.diff ...                                                                                     [ ok ]
 *   370-psi-win32-options-change-buttons-places.diff ...                                                                  [ ok ]
 *   380-psi-dirty-check.diff ...                                                                                          [ ok ]
 *   390-psi-vcard-smartsize.diff ...                                                                                      [ ok ]
 *   400-psi-send-custom-status.diff ...                                                                                   [ ok ]
 *   410-psi-all-in-one-window.diff ...                                                                                    [ ok ]
 *   420-psi-add-detection-some-os.diff ...                                                                                [ ok ]
 *   430-psi-muc-nick-hash-color.diff ...                                                                                  [ ok ]
 *   440-psi-chatdlg-copypaste-keypress.diff ...                                                                           [ ok ]
 *   450-psi-tabs-button-killer.diff ...                                                                                   [ ok ]
 *   460-psi-optional-confirmation-when-clearing.diff ...                                                                  [ ok ]
 *   470-psi-autojoin-dialog-tab-autofoucus-off.diff ...                                                                   [ ok ]
 *   480-psi-muc-roster-horizontal-scrollbar-disabled.diff ...                                                             [ ok ]
 *   501-psi-plugins-options.diff ...                                                                                      [ ok ]
 *   502-psi-fixed-plugins.diff ...                                                                                        [ ok ]
 *   503-psi-unload-plugins-on-exit.diff ...                                                                               [ ok ]
 *   510-psi-plugins-libdir.diff ...                                                                                       [ ok ]
 *   520-psi-fix-ability-to-modify-events-from-plugins.diff ...                                                            [ ok ]
 *   600-psi-debianize.diff ...                                                                                            [ ok ]
 *   610-psi-contact-manager.diff ...                                                                                      [ ok ]
 *   620-psi-chat-messages-subject-fix.diff ...                                                                            [ ok ]
 *   630-psi-avcalls-addons.diff ...                                                                                       [ ok ]
 *   640-psi-send-button-context-menu.diff ...                                                                             [ ok ]
 *   650-psi-quit-on-close-option.diff ...                                                                                 [ ok ]
 *   660-psi-xmpp-uri-in-chat-mode.diff ...                                                                                [ ok ]
 * Done with patching
>>> Source prepared.
Comment 23 Dennis Schridde 2009-07-13 18:15:31 UTC
0.13_rc3 was released: http://forum.psi-im.org/thread/5324