Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270799 - app-cdr/cdrdao failes to compile
Summary: app-cdr/cdrdao failes to compile
Status: RESOLVED DUPLICATE of bug 270414
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL: http://cygwin.com/ml/cygwin/2006-01/m...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-22 09:30 UTC by Michael B
Modified: 2009-05-22 10:16 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Log of build (build.log,23.70 KB, text/plain)
2009-05-22 09:31 UTC, Michael B
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael B 2009-05-22 09:30:58 UTC
app-cdr/cdrdao fails to compile:
        ==> COMPILING "OBJ/x86-linux-cc/avoffset.o"                                                  
In file included from avoffset.c:36:                                                                 
../include/schily.h:190: error: conflicting types for ‘getline’                                      
/usr/include/stdio.h:651: error: previous declaration of ‘getline’ was here                          
make[4]: *** [OBJ/x86-linux-cc/avoffset.o] Error 1
make[4]: Leaving directory `/var/tmp/portage/app-cdr/cdrdao-1.2.2-r3/work/cdrdao-1.2.2/scsilib/inc'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/var/tmp/portage/app-cdr/cdrdao-1.2.2-r3/work/cdrdao-1.2.2/scsilib/inc'
make[2]: *** [all] Error 255
make[2]: Leaving directory `/var/tmp/portage/app-cdr/cdrdao-1.2.2-r3/work/cdrdao-1.2.2/scsilib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-cdr/cdrdao-1.2.2-r3/work/cdrdao-1.2.2'
make: *** [all] Error 2


Reproducible: Always

Steps to Reproduce:
1.emerge app-cdr/cdrdao




Expected Results:  
installed software

Portage 2.1.6.13 (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29.2-bostwick i686)  
=================================================================                                        
System uname: Linux-2.6.29.2-bostwick-i686-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-gentoo-2.0.0  
Timestamp of tree: Thu, 21 May 2009 22:15:01 +0000                                                       
ccache version 2.4 [disabled]                                                                            
app-shells/bash:     4.0_p24                                                                             
dev-java/java-config: 2.1.7                                                                              
dev-lang/python:     2.6.2                                                                               
dev-python/pycrypto: 2.0.1-r8                                                                            
dev-util/ccache:     2.4-r8                                                                              
dev-util/cmake:      2.6.4                                                                               
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i486-pc-linux-gnu"
CFLAGS="-O2 -mtune=i686 -pipe "
CHOST="i486-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mtune=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo ftp://mirror.iawnet.sandia.gov/pub/gentoo/ http://gentoo.mirrors.pair.com/ http://mirrors.cs.wmich.edu/gentoo http://mirror.usu.edu/mirrors/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 acl acpi alsa apm arts berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups curl dbus dri dvd dvdr dvdread eds embedded emboss encode esd evo fam firefox firefox3 fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg jpg kde ldap libnotify lm_sensors mad midi mikmod mp3 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl php png ppds pppd python pythong qt3 qt3support qt4 quicktime readline reflection rss samba sdl session spell spl ssl startup-notification svg sysfs tcpd thumbnail tiff truetype unicode usb vorbis win32codecs x264 x86 xml xorg xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michael B 2009-05-22 09:31:59 UTC
Created attachment 192092 [details]
Log of build
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-05-22 10:16:30 UTC

*** This bug has been marked as a duplicate of bug 270414 ***