Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270624 - [php-testing overlay] dev-php5/IcePHP-3.2.1 - Cannot find config.m4. Make sure that you run '/usr/lib/php5/bin/phpize' in the top level source directory of the module
Summary: [php-testing overlay] dev-php5/IcePHP-3.2.1 - Cannot find config.m4. Make sur...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: PHP Bugs
Depends on:
Reported: 2009-05-20 19:56 UTC by Christophe PEREZ
Modified: 2010-12-28 12:39 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

Fix phpize error (IcePHP-ebuild-no-phpize.patch,353 bytes, patch)
2010-07-19 08:42 UTC, Peter Fern
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe PEREZ 2009-05-20 19:56:34 UTC
I would be happy to find an ebuild of IcePHP working.
All what I tried, as gave me the same error :
>>> Unpacking source...
>>> Unpacking IcePHP-3.2.1.tar.gz to /var/tmp/portage/dev-php5/IcePHP-3.2.1/work
 * Using dev-lang/php-5.2.9-r2
Cannot find config.m4.
Make sure that you run '/usr/lib/php5/bin/phpize' in the top level source directory of the module

rm: cannot remove `aclocal.m4': No such file or directory
 * Running eautoreconf in '/var/tmp/portage/dev-php5/IcePHP-3.2.1/work/IcePHP-3.2.1' ...
 * Running aclocal ...                                                                                                           [ !! ]

 * Failed Running aclocal !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/dev-php5/IcePHP-3.2.1/temp/aclocal.out

 * ERROR: dev-php5/IcePHP-3.2.1 failed.
 * Call stack:
 *     , line   48:  Called src_unpack
 *             environment, line 3692:  Called php-ext-source-r1_src_unpack
 *             environment, line 2965:  Called php-ext-source-r1_phpize
 *             environment, line 2921:  Called eautoreconf
 *             environment, line  995:  Called eaclocal
 *             environment, line  934:  Called autotools_run_tool 'aclocal'
 *             environment, line  446:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  The die message:
 *   Failed Running aclocal !

# cat /var/tmp/portage/dev-php5/IcePHP-3.2.1/temp/aclocal.out
***** aclocal *****
***** PWD: /var/tmp/portage/dev-php5/IcePHP-3.2.1/work/IcePHP-3.2.1
***** aclocal

aclocal-1.10: `' or `' is required

Reproducible: Always
Comment 1 Phillip Scholz 2009-06-04 22:19:42 UTC
same for me.
Comment 2 El Goretto 2009-07-25 12:54:28 UTC
Same error here (PHP 5.2.10).
Source code set up according to IcePHP ebuild variables compiles fine manually.

IMHO, it's an ebuild/ebuild system related problem, not a PHP or IcePHP related one.
Comment 3 Lucas Hereld 2009-09-17 18:52:56 UTC
I am getting this error also. Looking at the ebuild, it looks like the problem is know:
"# the build system is plain junk, should use phpize instead
 # also tries to set rpath to /opt/ICE-${PV} without the below hacks"
But it isn't actually fixing the phpize problem that is outlines in this bug report.
Comment 4 Peter Fern 2010-07-19 08:42:18 UTC
Created attachment 239345 [details, diff]
Fix phpize error

Contrary to the message, you actually need to avoid running phpize, apply the attached patch to the ebuild to resolve.
Comment 5 Matti Bickel (RETIRED) gentoo-dev 2010-07-29 16:38:00 UTC
Anybody still interested in IcePHP? It's not currently in the overlay and frankly, I don't care right now.

If you do (and I would appreciate it if you do ;), please say so and I'll look into adding it into the overlay. I'm just trying to ease the load on the php herd, maintaining packages nobody uses.

If there's no response in 14 days, I'll close this bug WONTFIX.
Comment 6 Peter Fern 2010-07-30 00:27:01 UTC
The Mumble web interfaces all require it, which is why I submitted a patch to make the ebuild work last week.
Comment 7 Matti Bickel (RETIRED) gentoo-dev 2010-09-07 20:27:13 UTC
Just to get word out: I'm overworked as of right now, but I'll try to put this into the overlay together with the fix.

Thanks, and apologies for letting this sit so long.
Comment 8 Ole Markus With (RETIRED) gentoo-dev 2010-12-28 12:39:15 UTC
Sorry for taking so long with this one.

It seems like the extension is now shipped with Ice itself. The maintainers of dev-libs/Ice already handles python and ruby bindings and there is a todo in their ebuilds regarding the php bindings. Thus the PHP team cannot really fix this bug.

I recommend that you file a new bug asking for the php bindings to be added to dev-libs/Ice. The PHP team will provide any assistance needed.