Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 270474 - dev-tex/luatex-0.30.3 fails to build with glibc-2.10.1
Summary: dev-tex/luatex-0.30.3 fails to build with glibc-2.10.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: TeX project
URL:
Whiteboard:
Keywords:
: 271030 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-05-19 19:10 UTC by Constantin Baranov
Modified: 2009-05-24 07:45 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Rename getline() to _getline() (120_all_getline.patch,3.80 KB, patch)
2009-05-19 19:10 UTC, Constantin Baranov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Constantin Baranov 2009-05-19 19:10:26 UTC
The getline() redefenition problem again.

Reproducible: Always

Steps to Reproduce:
Comment 1 Constantin Baranov 2009-05-19 19:10:51 UTC
Created attachment 191821 [details, diff]
Rename getline() to _getline()
Comment 2 Eric Smith 2009-05-20 20:48:06 UTC
I can confirm that the provided patch fixes the problem here.
Comment 3 Alexis Ballier gentoo-dev 2009-05-23 09:50:49 UTC
applied, thanks
Comment 4 Sebastian Luther (few) 2009-05-24 07:45:34 UTC
*** Bug 271030 has been marked as a duplicate of this bug. ***