Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270230 - Clone of bug 262647. "emerge texlive-latexextra" still fails with error message "[Errno 7] Argument list too long"
Summary: Clone of bug 262647. "emerge texlive-latexextra" still fails with error mes...
Status: RESOLVED DUPLICATE of bug 719202
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: x86 Linux
: High normal with 1 vote (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-17 21:16 UTC by John Burkett
Modified: 2020-04-29 16:43 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Burkett 2009-05-17 21:16:27 UTC
+++ This bug was initially created as a clone of Bug #262647 +++
Using kernel version 2.6.20, I tried doing "emerge texlive-latexextra" but got the following response:
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-texlive/texlive-latexextra-2008-r1
[Errno 7] Argument list too long:
   /bin/bash -c touch "/usr/portage/distfiles/.__portage_test_write__" 2>/dev/null ; rval=$? ; rm -f  "/usr/portage/distfiles/.__portage_test_write__" ; exit $rval
[Errno 7] Argument list too long:
   /bin/bash -c touch "/usr/portage/distfiles/.locks/.__portage_test_write__" 2>/dev/null ; rval=$? ; rm -f  "/usr/portage/distfiles/.locks/.__portage_test_write__" ; exit $rval
 * texlive-module-achemso-2008.tar.lzma RMD160 SHA1 SHA256 size ;-) ...                                                                                                                [ ok ]
>>> Downloading 'http://distfiles.oshean.org/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://distfiles.oshean.org/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'http://open-systems.ufl.edu/mirrors/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://open-systems.ufl.edu/mirrors/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'http://gentoo.mirrors.pair.com/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://gentoo.mirrors.pair.com/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'ftp://ftp.ussg.iu.edu/pub/linux/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma ftp://ftp.ussg.iu.edu/pub/linux/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'http://mirror.ovh.net/gentoo-distfiles/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://mirror.ovh.net/gentoo-distfiles/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'http://gentoo.osuosl.org/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://gentoo.osuosl.org/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'http://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://ftp.snt.utwente.nl/pub/os/linux/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'http://ftp.jaist.ac.jp/pub/Linux/Gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://ftp.jaist.ac.jp/pub/Linux/Gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'ftp://ftp.osuosl.org/pub/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma ftp://ftp.osuosl.org/pub/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'ftp://mirror.bytemark.co.uk/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma ftp://mirror.bytemark.co.uk/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'ftp://ftp.gentoo.mesh-solutions.com/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma ftp://ftp.gentoo.mesh-solutions.com/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'http://mirror.bytemark.co.uk/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://mirror.bytemark.co.uk/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'ftp://ftp.free.fr/mirrors/ftp.gentoo.org/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma ftp://ftp.free.fr/mirrors/ftp.gentoo.org/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
>>> Downloading 'http://mirrors.tds.net/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://mirrors.tds.net/gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
!!! Couldn't download 'texlive-module-mcaption.source-2008.tar.lzma'. Aborting.
 * Fetch failed for 'dev-texlive/texlive-latexextra-2008-r1', Log file:
 *  '/var/tmp/portage/dev-texlive/texlive-latexextra-2008-r1/temp/build.log'

>>> Failed to emerge dev-texlive/texlive-latexextra-2008-r1, Log file:

>>>  '/var/tmp/portage/dev-texlive/texlive-latexextra-2008-r1/temp/build.log'

 * Messages for package dev-texlive/texlive-latexextra-2008-r1:

 * Fetch failed for 'dev-texlive/texlive-latexextra-2008-r1', Log file:
 *  '/var/tmp/portage/dev-texlive/texlive-latexextra-2008-r1/temp/build.log'

Doing "emerge -f texlive-latexextra" produces a similar message, starting with 
Calculating dependencies... done!

>>> Fetching (1 of 1) dev-texlive/texlive-latexextra-2008-r1
[Errno 7] Argument list too long:
   /bin/bash -c touch "/usr/portage/distfiles/.__portage_test_write__" 2>/dev/null ; rval=$? ; rm -f  "/usr/portage/distfiles/.__portage_test_write__" ; exit $rval
[Errno 7] Argument list too long:
   /bin/bash -c touch "/usr/portage/distfiles/.locks/.__portage_test_write__" 2>/dev/null ; rval=$? ; rm -f  "/usr/portage/distfiles/.locks/.__portage_test_write__" ; exit $rval
 * texlive-module-achemso-2008.tar.lzma RMD160 SHA1 SHA256 size ;-) ...                                                                                                                [ ok ]
>>> Downloading 'http://distfiles.oshean.org/distfiles/texlive-module-mcaption.source-2008.tar.lzma'
[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://distfiles.oshean.org/distfiles/texlive-module-mcaption.source-2008.tar.lzma

To see if a manual download would solve the problem, I downloaded  texlive-module-collection-latexextra-2008.tar.lzma from http://ftp.ussg.iu.edu/linux/gentoo/distfiles/?C=N%3BO=D.  After putting this file in /usr/portage/distfiles, I did "emerge texlive-latexextra".  The response stated with

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-texlive/texlive-latexextra-2008-r1
[Errno 7] Argument list too long:
   /bin/bash -c touch "/usr/portage/distfiles/.__portage_test_write__" 2>/dev/null ; rval=$? ; rm -f  "/usr/portage/distfiles/.__portage_test_write__" ; exit $rval
 
and ended with 

[Errno 7] Argument list too long:
   /usr/bin/wget -t 5 -T 60 --passive-ftp -O /usr/portage/distfiles/texlive-module-mcaption.source-2008.tar.lzma http://ftp.jaist.ac.jp/pub/Linux/Gentoo/distfiles/texlive-module-mcaption.source-2008.tar.lzma
!!! Couldn't download 'texlive-module-mcaption.source-2008.tar.lzma'. Aborting.
 * Fetch failed for 'dev-texlive/texlive-latexextra-2008-r1', Log file:
 *  '/var/tmp/portage/dev-texlive/texlive-latexextra-2008-r1/temp/build.log'

>>> Failed to emerge dev-texlive/texlive-latexextra-2008-r1, Log file:

>>>  '/var/tmp/portage/dev-texlive/texlive-latexextra-2008-r1/temp/build.log'

 * Messages for package dev-texlive/texlive-latexextra-2008-r1:

 * Fetch failed for 'dev-texlive/texlive-latexextra-2008-r1', Log file:
 *  '/var/tmp/portage/dev-texlive/texlive-latexextra-2008-r1/temp/build.log'

The results reported above were obtained with portage 2.1.6.13.  Earlier I got similar results from portage versions 2.1.6.11 and 2.1.6.12. 

Doing "emerge --info" yields the following output:

Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.20-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.20-gentoo-r6-i686-Intel-R-_Pentium-R-_D_CPU_2.80GHz-with-glibc2.0
Timestamp of tree: Sat, 16 May 2009 16:45:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O3 -pipe -fomit-frame-pointer -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O3 -pipe -fomit-frame-pointer -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.oshean.org http://open-systems.ufl.edu/mirrors/gentoo"
LANG="en_US.utf-8"
LC_ALL="en_US.utf-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X Xaw3d aac aalib accessibility acl acpi alsa arts artworkextra athena bash-completion berkdb bzip2 cairo cdparanoia cdr cjk cli cracklib crypt cups dbus dga dmi dnd doc dri dts dv dvb dvd dvdr dvdread emacs encode enscript esd fam ffmpeg foomaticdb fortran freewnn gdbm ggi gif gimpprint gphoto2 gpm gtk gtkhtml gzip-el hal hesiod iconv iontruetype ipv6 isdnlog jack java jpeg kde latex leim lesstif libcaca lzo mad midi mmx mmxext mng motif mozcalendar mozilla mudflap mule musepack ncurses neXt nls nptl nptlonly nvidia opengl openmp pam pcre perl png ppds pppd python readline reflection rtc samba scanner sdl session slp sound source speex spell spl sse sse2 ssl svg sysfs tcpd tetex tga theora tiff toolkit-scroll-bars truetype unicode usb v4l v4l2 vorbis win32codecs wmf x264 x265 x86 xanim xface xorg xosd xprint xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

A discussion of this problem on gentoo-amd64@lists.gentoo.org was initiated by me (John P. Burkett) on 05/02/2009.  (The selection of gentoo-amd64 was a based on the fact that bug 262647 was first reported on amd64 hardware. However, my difficulties are occuring on an x86 machine.) The discussion includes numerous insightful comments by Duncan.  The discussion thread on gmane is at http://comments.gmane.org/gmane.linux.gentoo.amd64/14380.

All help in resoling the problem will be much appreciated.
Comment 1 Martini peres 2012-03-01 12:50:47 UTC
This comment has been removed because it contained spam. -- idl0r
Comment 2 Zac Medico gentoo-dev 2012-03-01 13:06:20 UTC
Your portage version is rather old, so don't you try the latest portage? The latest stable is currently 2.1.10.44:

  http://packages.gentoo.org/package/sys-apps/portage
Comment 3 pavel sanda 2012-05-02 16:06:40 UTC
i'm stuck with updating latex as well, the error is cryptic:

>>> Install texlive-latexextra-2011-r2 into /var/tmp/portage/dev-texlive/texlive-latexextra-2011-r2/image/ category dev-texlive
 * Installing texmf-dist/scripts/perltex/perltex.pl as perltex bin wrapper
 * Installing texmf-dist/scripts/pst-pdf/ps4pdf as ps4pdf bin wrapper
 * ERROR: dev-texlive/texlive-latexextra-2011-r2 failed (install phase):
 *   Trying to install a non existing or non executable symlink to /usr/bin: texmf-dist/scripts/pst-pdf/ps4pdf
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_install
 *   environment, line 2015:  Called texlive-module_src_install
 *   environment, line 2658:  Called dobin_texmf_scripts 'texmf-dist/scripts/perltex/perltex.pl' 'texmf-dist/scripts/pst-pdf/ps4pdf' 'texmf-dist/scripts/splitindex/perl/splitindex.pl' 'texmf-dist/scripts/svn-multi/svn-multi.pl' 'texmf-dist/scripts/vpe/vpe.pl' 'texmf-dist/scripts/authorindex/authorindex'
 *   environment, line  429:  Called die
 * The specific snippet of code:
 *           [ -x "${D}/usr/share/${1}" ] || die "Trying to install a non existing or non executable symlink to /usr/bin: ${1}";
 *
 * If you need support, post the output of 'emerge --info =dev-texlive/texlive-latexextra-2011-r2',
 * the complete build log and the output of 'emerge -pqv =dev-texlive/texlive-latexextra-2011-r2'.
 * The complete build log is located at '/var/tmp/portage/dev-texlive/texlive-latexextra-2011-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-texlive/texlive-latexextra-2011-r2/temp/environment'.
 * S: '/var/tmp/portage/dev-texlive/texlive-latexextra-2011-r2/work'



ps4pdf is not in texmf-dist indeed. after while i found more probable cause, which is hidden error within unpacking various modules:
...
>>> Unpacking texlive-module-zwgetfdate-2011.tar.xz to /var/tmp/portage/dev-texlive/texlive-latexextra-2011-r2/work
>>> Unpacking texlive-module-zwpagelayout-2011.tar.xz to /var/tmp/portage/dev-texlive/texlive-latexextra-2011-r2/work
>>> Unpacking texlive-module-collection-latexextra-2011.tar.xz to /var/tmp/portage/dev-texlive/texlive-latexextra-2011-r2/work
/var/tmp/portage/dev-texlive/texlive-latexextra-2011-r2/temp/environment: line 2663: /bin/grep: Argument list too long



Indeed, my kernel on this box is old&patched 2.6.19 and can't be reasonably updated due to hardware issues. 
checking arg_max gives:
$ getconf ARG_MAX
131072
which is pretty standard for these old guys.

Is there any workaround for this issue? Updating kernel is no option for this box...
Comment 4 pavel sanda 2012-05-02 16:08:07 UTC
emerge info:
Portage 2.1.10.49 (default/linux/x86/10.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.19-suspend2-r3 i686)
=================================================================
System uname: Linux-2.6.19-suspend2-r3-i686-Intel-R-_Pentium-R-_M_processor_1.86GHz-with-gentoo-1.12.11.1
Timestamp of tree: Wed, 02 May 2012 14:30:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     1.3.7, 2.1.11-r3
dev-lang/python:          2.5.4-r4, 2.6.5-r2
dev-util/ccache:          2.4-r7::<unknown repository>
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      1.12.11.1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13::<unknown repository>, 2.68
sys-devel/automake:       1.4_p6::<unknown repository>, 1.5::<unknown repository>, 1.6.3::<unknown repository>, 1.7.9-r1::<unknown repository>, 1.8.5-r3::<unknown repository>, 1.9.6-r2::<unknown repository>, 1.10.2, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.1.2
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.23-r3 (virtual/os-headers)
sys-libs/glibc:           2.8_p20080602-r1
Repositories: gentoo rebutia x-portage sunrise
ACCEPT_KEYWORDS="x86"           
ACCEPT_LICENSE="*"              
CBUILD="i686-pc-linux-gnu"      
CFLAGS="-O2 -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"       
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"                               
FFLAGS=""                       
GENTOO_MIRRORS="ftp://ftp.sh.cvut.cz/MIRRORS/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"                  
PKGDIR="/usr/portage/packages"  
PORTAGE_CONFIGROOT="/"          
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"       
PORTDIR="/usr/portage"          
PORTDIR_OVERLAY="/var/lib/layman/rebutia /usr/local/portage /usr/local/portage/layman/sunrise"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gpm gtk iconv ipv6 jpeg latex lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support qt4 readline sdl session spell ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis wxwidgets x264 x86 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon fglrx vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 5 pavel sanda 2012-05-02 16:34:35 UTC
running emerge in debug mode shows that error is in this part of code:
+ grep RELOC tlpkg/tlpobj/2up.tlpobj tlpkg/tlpobj/AkkTeX.tlpobj ..... (looong list)
Comment 6 pavel sanda 2012-05-02 17:10:51 UTC
OK, I fixed my problem by editing the critical line in texlive-module.eclass.

Alexis (you are the maintainer, right?) please consider to rewrite:
grep RELOC tlpkg/tlpobj/* | awk '{print $2}' | sed 's#^RELOC/##' > "${T}/reloclist"

via xargs solution


(i wanted fast solution and used:
(cd tlpkg/tlpobj/; ls * | xargs -n 1 grep RELOC) |cut -f 2 -d ' '| sed 's#^RELOC/##' > "${T}/reloclist"
but it can be rewritten via single find -uglyparams instead of cd,ls,cut, i think ;)
Comment 7 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2020-04-29 16:43:58 UTC

*** This bug has been marked as a duplicate of bug 719202 ***