Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270031 - x11-drivers/xf86-video-intel: pixmap corruption in the font glyph cache
Summary: x11-drivers/xf86-video-intel: pixmap corruption in the font glyph cache
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-16 08:37 UTC by Vytautas
Modified: 2009-05-18 13:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge--info,3.11 KB, text/plain)
2009-05-16 08:38 UTC, Vytautas
Details
screenshot of bug (2009-05-15-185154_1024x768_scrot.png,120.48 KB, image/png)
2009-05-16 08:38 UTC, Vytautas
Details
xorg.conf (xorg.conf,2.37 KB, text/plain)
2009-05-18 05:12 UTC, Vytautas
Details
first try (Xorg.0.log,35.70 KB, text/plain)
2009-05-18 05:13 UTC, Vytautas
Details
first try (2009-05-17-194725_1024x768_scrot.png,93.95 KB, image/png)
2009-05-18 05:14 UTC, Vytautas
Details
second try (more violent) (Xorg.0.log.2,35.70 KB, text/plain)
2009-05-18 05:14 UTC, Vytautas
Details
second try (more violent) (2009-05-17-200318_1024x768_scrot.png,119.80 KB, image/png)
2009-05-18 05:15 UTC, Vytautas
Details
second try (more violent) (2009-05-17-200645_1024x768_scrot.png,97.02 KB, image/png)
2009-05-18 05:15 UTC, Vytautas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vytautas 2009-05-16 08:37:36 UTC
Hard to describe I will attach image.

Reproducible: Sometimes

Steps to Reproduce:
1.Play around with Calc and better with big files lots of graphics etc.
2. Reproduced only 3-4 times one time on screenshot I will attach it.
Actual Results:  
*

Expected Results:  
letters and numbers.

Possibly related to intel Xorg video.
Comment 1 Vytautas 2009-05-16 08:38:11 UTC
Created attachment 191452 [details]
emerge --info
Comment 2 Vytautas 2009-05-16 08:38:34 UTC
Created attachment 191454 [details]
screenshot of bug
Comment 3 Andreas Proschofsky (RETIRED) gentoo-dev 2009-05-17 08:05:51 UTC
Really don't believe this is a OpenOffice.org bug, also that you can't reproduce it reliably points to another source like the video driver. Reassigning
Comment 4 Rémi Cardona gentoo-dev 2009-05-17 09:07:58 UTC
Let me guess: you have an Intel card.

Either way, please attach your full Xorg.0.log and xorg.conf (if any).

Thanks
Comment 5 Vytautas 2009-05-18 05:12:47 UTC
Created attachment 191608 [details]
xorg.conf
Comment 6 Vytautas 2009-05-18 05:13:44 UTC
Created attachment 191610 [details]
first try
Comment 7 Vytautas 2009-05-18 05:14:06 UTC
Created attachment 191611 [details]
first try
Comment 8 Vytautas 2009-05-18 05:14:32 UTC
Created attachment 191613 [details]
second try (more violent)
Comment 9 Vytautas 2009-05-18 05:15:30 UTC
Created attachment 191615 [details]
second try (more violent)
Comment 10 Vytautas 2009-05-18 05:15:53 UTC
Created attachment 191616 [details]
second try (more violent)
Comment 11 Rémi Cardona gentoo-dev 2009-05-18 05:51:22 UTC
Please file a bug in FreeDesktop's bugzilla [1] and please paste the url here so I can keep track of it.

@OOo, this is definitely not an OOo bug, OOo is just an unlucky by-stander. Feel free to remove yourselves if you want.

Thanks

[1] http://intellinuxgraphics.org/how_to_report_bug.html
Comment 13 Rémi Cardona gentoo-dev 2009-05-18 13:02:36 UTC
Thanks, let's track the bug upstream directly then.