Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269913 - "Fixing mo files failed" when emerging media-video/kaffeine-0.8.6
Summary: "Fixing mo files failed" when emerging media-video/kaffeine-0.8.6
Status: VERIFIED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-15 06:27 UTC by Jiri
Modified: 2009-06-06 21:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Emerge log (media-video:kaffeine-0.8.6:20090515-054319.log,134.68 KB, text/plain)
2009-05-15 06:28 UTC, Jiri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri 2009-05-15 06:27:11 UTC
When emerging media-video/kaffeine-0.8.6, "Fixing mo files failed" bug appears. Emerging is not successful.

Reproducible: Always

Steps to Reproduce:
1. emerge kaffeine

Actual Results:  
mv: nelze získat informace o „/var/tmp/portage/portage/media-video/kaffeine-0.8.6/image//usr/share/locale/*/LC_MESSAGES/kaffeine-0.8.6.mo“: není souborem ani adresářem
 *
 * ERROR: media-video/kaffeine-0.8.6 failed.
 * Call stack:
 *               ebuild.sh, line   48:  Called src_install
 *             environment, line 4255:  Called die
 * The specific snippet of code:
 *           mv -f ${mofile} ${mofile/${P}.mo/${PN}.mo} || die "fixing mo files failed";
 *  The die message:
 *   fixing mo files failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/media-video:kaffeine-0.8.6:20090515-054319.log'.
 * The ebuild environment file is located at '/var/tmp/portage/portage/media-video/kaffeine-0.8.6/temp/environment'.
 *
 * QA Notice: Unrecognized configure options:
 *
 *      configure: WARNING: unrecognized options: --with-x, --enable-mitshm, --without-debug
 *      configure: WARNING: unrecognized options: --with-x, --enable-mitshm, --without-debug

Expected Results:  
Kaffeine installed.

comp1 ~ # emerge --info
Portage 2.1.6.11 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-i686-AMD_Athlon-tm-_XP_1800+-with-glibc2.0
Timestamp of tree: Thu, 14 May 2009 07:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.4.4-r13, 2.5.4-r2
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo http://distfiles.gentoo.org"
LANG="cs_CZ.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="cs en fi"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp/portage"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa bash-completion berkdb bluetooth branding bzip2 cairo cddb cdparanoia cdr cli cracklib crypt cups dbus dirac djvu dri dvd dvdr dvdread eds emboss encode esd evo exif fam ffmpeg firefox flac fortran gdbm gif gimp gpm gstreamer gtk hal iconv id3tag imagemagick inkjar isdnlog jabber java javascript jbig jpeg jpeg2k kde ladspa lame ldap libnotify libsamplerate lm_sensors mad matroska midi mikmod mime mmx mmxext mng mp3 mpeg mplayer mudflap musepack ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime raw readline reflection rss schroedinger sdl session soundtouch speex spell spl sse ssl startup-notification svg sysfs tcpd theora tiff truetype twolame unicode usb v4l vmmouse vorbis wavpack win32codecs wmf x264 x86 xml xorg xosd xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs en fi" USERLAND="GNU" VIDEO_CARDS="nv vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

------------
Log will be attached.
Comment 1 Jiri 2009-05-15 06:28:53 UTC
Created attachment 191316 [details]
Emerge log
Comment 2 Tomáš Chvátal (RETIRED) gentoo-dev 2009-05-15 11:36:47 UTC
Already fixed in cvs. Sync your tree.
Comment 3 Jiri 2009-05-22 09:42:16 UTC
After

emerge -uDNv world && emerge kaffeine

the same problem.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-05-22 13:21:01 UTC
Please try media-video/kaffeine-0.8.7-r1

Reopen this bug if you still get the same error.
Comment 5 Jiri 2009-05-22 17:40:41 UTC
media-video/kaffeine-0.8.7-r1 compiles and installs ok.
Comment 6 Aidan Taniane 2009-06-06 21:24:45 UTC
(In reply to comment #5)
> media-video/kaffeine-0.8.7-r1 compiles and installs ok.
> 

Verified; 0.8.6 fails to build as above, 0.8.7-r1 and 0.8.8 successfully install on amd64.  I ran 0.8.8 for a bit, and it also fixes the bug where opening a media file on a samba share for .e.g would fail complaining about missing plugin (can't find the bug #).  I suggest filing a stabilisation request for one of the two.