Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269747 - net-libs/libproxy circular dep
Summary: net-libs/libproxy circular dep
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 272402 (view as bug list)
Depends on:
Blocks: gnome2.26
  Show dependency tree
 
Reported: 2009-05-13 20:17 UTC by Daniel Gryniewicz (RETIRED)
Modified: 2009-09-13 14:48 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Gryniewicz (RETIRED) gentoo-dev 2009-05-13 20:17:02 UTC
'net-libs/libproxy-0.2.3',:
...'net-libs/xulrunner-1.9.0.10',:
......'gnome-base/libgnomeui-2.24.1',:
.........'gnome-base/libbonoboui-2.24.1',:
............'gnome-base/libgnome-2.26.0',:
...............'gnome-base/gvfs-1.2.2',:
..................'net-libs/libsoup-2.26.1',:
.....................Recursion: 'net-libs/libproxy-0.2.3',

This is caused by libproxy with the xulrunner flag, xulrunner with the gnome flag, and libsoup with the gnome flag.  Not sure how to best break it.
Comment 1 Sebastian Luther (few) 2009-05-13 20:23:25 UTC
Temporarily disable xulrunner and/or gnome useflag?
Comment 2 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-05-13 23:17:13 UTC
That's certainly the workaround, yes.  I'd say probably -xulrunner, since that breaks the loop earlier, but it's not a huge deal.

I'm not sure what the correct fix for the problem is, tho.
Comment 3 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-05-14 05:43:08 UTC
libgnome doesn't need gvfs, it needs gio which is in glib -- remove the dep?
Comment 4 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-05-14 11:58:34 UTC
(In reply to comment #3)
> libgnome doesn't need gvfs, it needs gio which is in glib -- remove the dep?
> 

Okay, that can't be done due to bug 266135. I am now out of ideas.
Comment 5 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-05-30 20:39:35 UTC
There's also webkit-gtk -> libsoup[gnome] -> libproxy[webkit] -> webkit-gtk
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-06-03 16:49:50 UTC
*** Bug 272402 has been marked as a duplicate of this bug. ***
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-06-17 22:33:51 UTC
moved gvfs to PDEPEND in libgnome.
Comment 8 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-06-18 05:48:06 UTC
(In reply to comment #7)
> moved gvfs to PDEPEND in libgnome.
> 

That's fixed the xulrunner+gnome problem, but what about the gnome+webkit problem?

[ebuild  N    ] net-libs/libproxy-0.2.3  USE="gnome python webkit -kde -networkmanager -xulrunner" 
[ebuild  N    ]  net-libs/webkit-gtk-1.1.8  USE="gstreamer -coverage -debug -doc -gnome-keyring -pango" 
[ebuild  N    ]   net-libs/libsoup-2.26.2  USE="gnome ssl -debug -doc" 

 * Error: circular dependencies:

('ebuild', '/', 'net-libs/webkit-gtk-1.1.8', 'merge') depends on
  ('ebuild', '/', 'net-libs/libsoup-2.26.2', 'merge') (runtime)
('ebuild', '/', 'net-libs/libsoup-2.26.2', 'merge') depends on
  ('ebuild', '/', 'net-libs/libproxy-0.2.3', 'merge') (runtime)
('ebuild', '/', 'net-libs/libproxy-0.2.3', 'merge') depends on
  ('ebuild', '/', 'net-libs/webkit-gtk-1.1.8', 'merge') (runtime)

-------

I see no way out of this one, especially since webkit-gtk has a hard dep on libsoup
Comment 9 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-06-18 05:51:39 UTC
Mozilla has nothing to do here now.
Comment 10 Romain Perier (RETIRED) gentoo-dev 2009-06-18 06:10:53 UTC
@nirbheek: move libproxy to PDEPEND in libsoup ?
Comment 11 Romain Perier (RETIRED) gentoo-dev 2009-09-13 10:33:44 UTC
Fixed into the main with a revbump for libsoup-2.26.3 (-r3), I added previously a new ebuild libsoup-gnome-2.26.3 which contains the gnome plugin for libsoup, and I Added it into libsoup's PDEPEND.

The problem should be solved, feel free to reopen this bug in case of problem
Comment 12 Julien Enche 2009-09-13 13:39:04 UTC
(In reply to comment #11)
> Fixed into the main with a revbump for libsoup-2.26.3 (-r3), I added previously
> a new ebuild libsoup-gnome-2.26.3 which contains the gnome plugin for libsoup,
> and I Added it into libsoup's PDEPEND.
> 
> The problem should be solved, feel free to reopen this bug in case of problem
> 

There are file collisions between libsoup (with gnome USE) and libsoup-gnome (see bug #284758).
Comment 13 Romain Perier (RETIRED) gentoo-dev 2009-09-13 14:48:18 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > Fixed into the main with a revbump for libsoup-2.26.3 (-r3), I added previously
> > a new ebuild libsoup-gnome-2.26.3 which contains the gnome plugin for libsoup,
> > and I Added it into libsoup's PDEPEND.
> > 
> > The problem should be solved, feel free to reopen this bug in case of problem
> > 
> 
> There are file collisions between libsoup (with gnome USE) and libsoup-gnome
> (see bug #284758).
> 

It should be fixed now