Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 268921 - media-video/totem-2.24-3 faiils to play files in smb shares and is missing plugins
Summary: media-video/totem-2.24-3 faiils to play files in smb shares and is missing pl...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-05-07 10:18 UTC by Ray
Modified: 2009-10-21 23:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ray 2009-05-07 10:18:44 UTC
This bug kinda annoys me: i cant play any videos from smb shares, i get an error that the smb plugin is not installed (i use samba global useflag though).
Plus im missing plugins like youtube for totem.

I guess both are gstreamer issues (the current stable gstreamer plugins are full of bugs too, hope you unmask the testing ones soon)

Reproducible: Always




notepuke bernhard # emerge --info
Portage 2.1.6.11 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-x86_64-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-glibc2.2.5
Timestamp of tree: Thu, 07 May 2009 09:15:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://linux.rudolfinum.sth.ac.at/"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo firefox flac fortran galago gamin gdbm gif glitz gnome gnome-keyring gnutls gpm gstreamer gtk gtkhtml hal iconv ipv6 isdnlog java java6 jpeg lame laptop ldap libnotify mad midi mikmod mmx mp3 mpeg mudflap multilib musicbrainz nautilus ncurses networkmanager nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support quicktime readline reflection samba sdl session spell spl sqlite sse sse2 ssl startup-notification stream subversion svg synaptics sysfs tagwriting tcpd theora threads tiff truetype unicode usb vorbis xcb xml xorg xulrunner xv zlib" ALSA_CARDS="snd-hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Ray 2009-05-07 11:22:05 UTC
Hm, i cant open them with vlc either. This seems to be a gstreamer problem
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-05-14 21:18:20 UTC
youtube plugin has an history of working not so good to not good at all so it's been disable until totem 2.26 that is currently still in overlay. As for playing over samba, what kind of share are you trying to reach, passwordless samba, windows share, protected by a password, in an AD domain, ... ? Without that kind of info we won't be able to reproduce, nor upstream.

Please also paste the output of emerge -pv glib gvfs totem
Comment 3 Ray 2009-05-15 01:47:21 UTC
It's a samba share on an ubuntu server (its not mine :)), which is protected with user and password. The server itself is called "zeus" (if thats what you mean with AD domain) and i can reach him if i write zeus in my url field in firefox.

notepuke bernhard # emerge -pv glib gvfs totem

These are the packages that would be merged, in order:

Calculating dependencies -
... done!
[ebuild   R   ] dev-libs/glib-2.18.4-r1  USE="-debug -doc -fam -hardened (-selinux) -xattr" 4,697 kB
[ebuild   R   ] gnome-base/gvfs-1.0.3-r2  USE="bash-completion bluetooth gnome gnome-keyring hal samba -archive -avahi -cdda -debug -doc -fuse -gphoto2" 900 kB
[ebuild   R   ] media-video/totem-2.24.3  USE="bluetooth galago gnome nautilus nsplugin python -debug -lirc -nvtv -tracker" 2,487 kB

Total: 3 packages (3 reinstalls), Size of downloads: 8,082 kB
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-08-03 20:51:21 UTC
Is this looking like bug #230674.
Otherwise, what does totem print on stdout if started from terminal ?