Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 268681 - x11-terms/evilvte should use savedconfig.eclass for user config handling
Summary: x11-terms/evilvte should use savedconfig.eclass for user config handling
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-05 00:05 UTC by James Rowe
Modified: 2009-08-31 16:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
evilvte-0.4.5_pre2-use_savedconfig.patch (evilvte-0.4.5_pre2-use_savedconfig.patch,1.48 KB, patch)
2009-05-05 00:08 UTC, James Rowe
Details | Diff
evilvte-use_savedconfig-for_older_ebuilds.patch (evilvte-use_savedconfig-for_older_ebuilds.patch,2.84 KB, patch)
2009-05-05 00:09 UTC, James Rowe
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Rowe 2009-05-05 00:05:36 UTC
There is already an in-tree solution for handling user editable config
files -- savedconfig -- and it provides more functionality than the
current evilvte method.

  Personally, I'd like to the change to using savedconfig because it
respects ${PORTAGE_CONFIGROOT} and allows me to keep a different config
per arch.  [I'm abusing the arch difference locally to change host, not
arch, specific settings... but it works with savedconfig ;)]

  I'm not convinced the upgrade path from the current code is as clean
as it could be, but I can't see a better way around it which I think is
another reason why the savedconfig route is better.  I don't think it
should cause problems though.

It used the old /etc/evilvte/config.h file on upgrade to a savedconfig
version, but removal won't happen if the user has edited it because of
$CONFIG_PROTECT which would break the next upgrade unless it is forcibly
removed.  I've been overly careful with the removal, just the file and
then the hopefully empty directory but I'm really interested in comments
how it could be done better.

Thanks,

James


Reproducible: Always
Comment 1 James Rowe 2009-05-05 00:08:11 UTC
Created attachment 190372 [details, diff]
evilvte-0.4.5_pre2-use_savedconfig.patch

I've added a pkg_postinst() notice because all the other packages using 
savedconfig do, but it seems a little redundant because save_config() already 
issues one.  Maybe pkg_postinst() shouldn't?
Comment 2 James Rowe 2009-05-05 00:09:23 UTC
Created attachment 190373 [details, diff]
evilvte-use_savedconfig-for_older_ebuilds.patch

This is just the same set of changes rebased for the 0.4.3 and
0.4.4_pre9 ebuilds, because if the change was made to the older ebuilds
the 0.4.5_pre2 patch needs mangling.
Comment 3 Samuli Suominen gentoo-dev 2009-08-31 16:14:04 UTC
Should be fixed with latest now.