Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 268592 - net-libs/libsoup-2.26.1 fails to build due to missing libsoup-gnome-2.4.la with USE="doc -gnome"
Summary: net-libs/libsoup-2.26.1 fails to build due to missing libsoup-gnome-2.4.la wi...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords: NeedPatch
: 268593 (view as bug list)
Depends on:
Blocks: gnome2.26
  Show dependency tree
 
Reported: 2009-05-04 13:00 UTC by Martin von Gagern
Modified: 2009-09-11 18:00 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin von Gagern 2009-05-04 13:00:23 UTC
Building libsoup fails for me due to a missing file. There is a libsoup-2.4.la in the referenced directory but no libsoup-gnome-2.4.la. The issue can be reproduced with MAKEOPTS=-j1 so it's not a parallel build thing. The relevant USE flags for libsoup: +doc +ssl -debug. It's an up-to-date ~x86 system.

gtk-doc: Compiling scanner
mkdir .libs
 i686-pc-linux-gnu-gcc -march=prescott -O2 -ggdb -Wall -Wstrict-prototypes -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wdeclaration-after-statement -Wformat=2 -Winit-self -Wmissing-include-dirs -Wundef -Waggregate-return -Wmissing-format-attribute -D_REENTRANT -I../.. -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DG_DISABLE_SINGLE_INCLUDES -I/usr/include/libxml2 -march=prescott -O2 -ggdb -Wall -Wstrict-prototypes -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wdeclaration-after-statement -Wformat=2 -Winit-self -Wmissing-include-dirs -Wundef -Waggregate-return -Wmissing-format-attribute -D_REENTRANT -c libsoup-2.4-scan.c  -fPIC -DPIC -o .libs/libsoup-2.4-scan.o
gtk-doc: Linking scanner
libtool: link: cannot find the library `../../libsoup/libsoup-gnome-2.4.la' or unhandled argument `../../libsoup/libsoup-gnome-2.4.la'
Linking of scanner failed: 
make[3]: *** [scan-build.stamp] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-libs/libsoup-2.26.1/work/libsoup-2.26.1/docs/reference'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/net-libs/libsoup-2.26.1/work/libsoup-2.26.1/docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-libs/libsoup-2.26.1/work/libsoup-2.26.1'
make: *** [all] Error 2
 * 
 * ERROR: net-libs/libsoup-2.26.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 1324:  Called gnome2_src_compile
 *             environment, line 1087:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
Comment 1 Martin von Gagern 2009-05-04 13:31:15 UTC
Oh, I forgot to mention, I also have USE=-gnome, which probably is the core of this issue. Remerging with USE=gnome solved the problem.
Comment 2 Serkan Kaba (RETIRED) gentoo-dev 2009-05-04 14:43:26 UTC
*** Bug 268593 has been marked as a duplicate of this bug. ***
Comment 3 Marco Coppola 2009-05-05 20:08:04 UTC
Same thing here on a ~amd64 system
Comment 4 Mike Park 2009-05-06 02:53:24 UTC
Getting this as well. ~amd64, -gnome use flag.
Comment 5 Man Shankar 2009-05-11 08:18:02 UTC
Same thing here on a ~amd64 system with -gnome use flag!
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-05-11 08:33:38 UTC
guys please stop the useless repetitive same kind of comments, we got it since the first post. Didn't have time to fix it because there is more important stuff to do first. Fill free to investigate the issue and attach a patch. Thanks.
Comment 7 Sebastian Luther (few) 2009-05-19 15:50:06 UTC
Try lafilefixer from dev-util/lafilefixer.
Comment 8 Gilles Dartiguelongue gentoo-dev 2009-05-19 16:14:23 UTC
this has nothing to do with it...
The problem is just that gtk-doc integration is badly done and doesn't like the new lib split design.
Comment 9 Mike Park 2009-05-21 19:23:21 UTC
even so, mask this if keyword -gnome is present. it's annoying to see this fail every update for world.
Comment 10 Oschtan 2009-05-21 21:23:56 UTC
(In reply to comment #9)
> even so, mask this if keyword -gnome is present. it's annoying to see this fail
> every update for world.
> 
Hm. USE="-gnome" emerge libsoup:2.4 compile successfull!
Why necessarily add USE="+gnome"? It's not solving this bug!
Comment 11 Terje Bråten 2009-05-26 21:59:17 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > even so, mask this if keyword -gnome is present. it's annoying to see this fail
> > every update for world.
> > 
> Hm. USE="-gnome" emerge libsoup:2.4 compile successfull!
> Why necessarily add USE="+gnome"? It's not solving this bug!
> 
Did you have USE="+doc" as well? Without it the bug will not appear.
Comment 12 georgi 2009-05-28 10:41:44 UTC
Confirming that both the bug and the "-doc" workaround apply to 2.26.2 as well.
Comment 13 Gilles Dartiguelongue gentoo-dev 2009-06-30 11:39:18 UTC
looks like upstream bug has patches
Comment 14 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-09-11 18:00:55 UTC
(In reply to comment #13)
> looks like upstream bug has patches
> 

Upstream bug's patch can only be applied to trunk, not tarball. I've modified it, but now conditional patching has to be used. Patch applied to tree in 2.26.3-r2