Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 268511 - sys-power/nut-2.0.5-r2 and Powercom BNT series - error in udev rules
Summary: sys-power/nut-2.0.5-r2 and Powercom BNT series - error in udev rules
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Robin Johnson
Depends on:
Reported: 2009-05-03 20:14 UTC by NiTr0
Modified: 2009-05-10 21:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description NiTr0 2009-05-03 20:14:59 UTC
When I tried to start BNT-800AP monitoring, I saw a wrong GID of /dev/ttyUSB0, and that UPS DevID/VenID (0d9f/0002) is missed in /etc/udev/rules.d/70-nut-usbups.rules
So I added next line:
SYSFS{idVendor}=="0d9f", SYSFS{idProduct}=="0002", MODE="664", GROUP="nut"
After this - I still have wrong GID for device.
I run udevinfo -a -p $(udevinfo -q path -n /dev/ttyUSB0) - and saw that SUBSYSTEM for device is tty, not usb_device, so I fix next line of udev config:
SUBSYSTEM!="usb_device", GOTO="nut-usbups_rules_end" -> SUBSYSTEM!="tty", GOTO="nut-usbups_rules_end"
After that I get tty that has group nut.

Reproducible: Always
Comment 1 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-05-04 06:20:27 UTC
Your device is in the newer NUT I think, you should upgrade to sys-power/nut-2.4.1 and check.
Comment 2 NiTr0 2009-05-09 15:31:22 UTC
Hmm... After adding nut-2.4.1 to package.keywords and emerge -uDN world I have a next error during compilation:

/bin/sh ../libtool --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include    -I../include -march=k8 -O2 -pipe -msse3 -Wall -Wsign-compare -MT parseconf.lo -MD -MP -MF .deps/parseconf.Tpo -c -o parseconf.lo parseconf.c
mv -f .deps/upsconf.Tpo .deps/upsconf.Po
../libtool: line 845: X--tag=CC: command not found
../libtool: line 878: libtool: ignoring unknown tag : command not found
../libtool: line 845: X--mode=compile: command not found
../libtool: line 1012: *** Warning: inferring the mode of operation is deprecated.: command not found
../libtool: line 1013: *** Future versions of Libtool will require --mode=MODE be specified.: command not found
../libtool: line 1156: Xx86_64-pc-linux-gnu-gcc: command not found
../libtool: line 1156: X-DHAVE_CONFIG_H: command not found
../libtool: line 1156: X-I.: command not found
../libtool: line 1156: X-I../include: No such file or directory
../libtool: line 1156: X-I../include: No such file or directory
../libtool: line 1156: X-march=k8: command not found
../libtool: line 1156: X-O2: command not found
../libtool: line 1156: X-pipe: command not found
../libtool: line 1156: X-msse3: command not found
../libtool: line 1156: X-Wall: command not found
../libtool: line 1156: X-Wsign-compare: command not found
../libtool: line 1156: X-MT: command not found
../libtool: line 1156: Xparseconf.lo: command not found
../libtool: line 1156: X-MD: command not found
../libtool: line 1156: X-MP: command not found
../libtool: line 1156: X-MF: command not found
../libtool: line 1156: X.deps/parseconf.Tpo: No such file or directory
../libtool: line 1156: X-c: command not found
../libtool: line 1209: Xparseconf.lo: command not found
../libtool: line 1214: libtool: compile: cannot determine name of library object from `': command not found
make[1]: *** [parseconf.lo] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-power/nut-2.4.1/work/nut-2.4.1/common'
make: *** [all-recursive] Error 1

#emerge --info
Portage (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r1 x86_64)
System uname: Linux-2.6.29-gentoo-r1-x86_64-AMD_Sempron-tm-_Processor_3000+-with-glibc2.2.5
Timestamp of tree: Sat, 09 May 2009 00:45:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.4-r2
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
CFLAGS="-march=k8 -O2 -pipe -msse3"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -msse3"
FEATURES="distcc distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow X acl acpi alsa amd64 apache2 apm berkdb bzip2 cdr cgi cli cracklib crypt cups dri encode fat fortran gd gdbm gpm hal iconv ipv6 isdnlog jpeg jpeg2k midi mmx mp3 mudflap multilib mysql mysqli ncurses nls nptl nptlonly opengl openmp pam pcre perl php png pppd python qt readline reflection reiser4 reiserfs samba session slang spl sqlite sse sse2 ssl symlink sysfs taglib tcpd theora tiff uicode unicode usb vnc wifi xfce xorg xulrunner zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vesa nv"

P.S. Possibly I need to post this as separate bug?
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-05-09 22:13:06 UTC
looks like you have a broken libtool, search bugzilla for it.
Comment 4 NiTr0 2009-05-10 12:22:51 UTC
But other packages that use libtool (for ex., media-libs/lcms-1.18-r1) are compiled OK... 
Comment 5 NiTr0 2009-05-10 15:38:05 UTC
nut-2.2.2 is also compiled OK... It seems that there is trouble only with nut-2.4.1...
Comment 6 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-05-10 18:38:00 UTC
Add libtool-2.2.6a to your system and retest with it.
Comment 7 NiTr0 2009-05-10 21:34:10 UTC
Yes, with fresh libtool all is OK.
IMHO it'll be good to add in nut-2.4.1 dependency list >=libtool-2.2.6a (or possibly 2.2.4).