Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 268378 - x11-drivers/linuxwacom-0.8.2 fails with monolithic kernel
Summary: x11-drivers/linuxwacom-0.8.2 fails with monolithic kernel
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: X11 External Driver Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-03 02:40 UTC by Christopher Head
Modified: 2009-10-23 04:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Head 2009-05-03 02:40:04 UTC
This was reported years ago for version 0.7.2 as bug #139592 and fixed. It has come back: if I try to install linuxwacom with a monolithic kernel, it immediately whines that I need module support, even though I don't want it to build a module, don't need it to build a module (my tablet PC emulates a serial port which requires only userspace drivers to operate), and have the "module" USE flag turned very definitely OFF.

Reproducible: Always

Steps to Reproduce:
1. Configure a monolithic kernel.
2. Emerge linuxwacom.

Actual Results:  
Complains about lack of module support.

Expected Results:  
Should install anyway, just not building the module.

I can bypass the check by configuring my kernel with modules; it doesn't actually need to be BUILT, just running menuconfig, checking the box, and saving the .config file is enough (and I can just change it back afterwards).
Comment 1 Mike Auty gentoo-dev 2009-05-04 10:24:08 UTC
Hi Chris, can you please provide a build log showing when the failure occurs and just giving us a bit of an idea where to look to fix this?

I've checked the old bug and explicitly added a --without-linux to a version of the ebuild and put it in my overlay (ikelos), which is accessible using layman.  Could you please give it a try and let me know if it solves the problem?
Comment 2 Christopher Head 2009-05-04 23:51:23 UTC
Here's the complete output of emerge from start to failure:

# emerge -1av linuxwacom

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-drivers/linuxwacom-0.8.2  USE="-gtk -module -tcl -tk -usb" 1,068 kB

Total: 1 package (1 reinstall), Size of downloads: 1,068 kB

Would you like to merge these packages? [Yes/No] 

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) x11-drivers/linuxwacom-0.8.2
>>> Downloading 'http://gentoo.chem.wisc.edu/gentoo/distfiles/linuxwacom-0.8.2.tar.bz2'
--2009-05-04 16:50:27--  http://gentoo.chem.wisc.edu/gentoo/distfiles/linuxwacom-0.8.2.tar.bz2
Resolving gentoo.chem.wisc.edu... 128.104.70.13
Connecting to gentoo.chem.wisc.edu|128.104.70.13|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1092825 (1.0M) [application/x-tar]
Saving to: `/usr/portage/distfiles/linuxwacom-0.8.2.tar.bz2'

100%[==============================================================================================================================>] 1,092,825    913K/s   in 1.2s    

2009-05-04 16:50:29 (913 KB/s) - `/usr/portage/distfiles/linuxwacom-0.8.2.tar.bz2' saved [1092825/1092825]

 * linuxwacom-0.8.2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                      [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                             [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                            [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                           [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     2.6.28-hardened-r7
 * These sources do not support loading external modules.
 * to be able to use this module please enable "Loadable modules support"
 * in your kernel, recompile and then try merging this module again.
 * 
 * ERROR: x11-drivers/linuxwacom-0.8.2 failed.
 * Call stack:
 *                 ebuild.sh, line   48:  Called pkg_setup
 *   linuxwacom-0.8.2.ebuild, line   58:  Called linux-mod_pkg_setup
 *          linux-mod.eclass, line  582:  Called check_modules_supported
 *         linux-info.eclass, line  493:  Called die
 * The specific snippet of code:
 *   		die "No support for external modules in ${KV_FULL} config"
 *  The die message:
 *   No support for external modules in 2.6.28-hardened-r7 config
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/usr/portage/tmp/portage/x11-drivers/linuxwacom-0.8.2/temp/build.log'.
 * The ebuild environment file is located at '/usr/portage/tmp/portage/x11-drivers/linuxwacom-0.8.2/temp/die.env'.
 * 
Comment 3 Christopher Head 2009-05-04 23:52:33 UTC
Also, by your description, I suspect your overlay ebuild won't help: it's not that we need --without-linux added to the configure line (though that might be necessary as well), it's that the build process never *gets* to even the configure stage: the ebuild itself complains and dies.
Comment 4 Mike Auty gentoo-dev 2009-05-05 08:19:45 UTC
Ok, it seems that's an error message the linux-mod eclass gives out now based on global variables that are set.  There's a new version of the ebuild in my overlay which doesn't called linux-mod_pkg_setup unless use module is actually true.  Please give that a go and let me know if it solves your problem...
Comment 5 Christopher Head 2009-05-10 21:30:17 UTC
linuxwacom-0.8.3_p4 (I assume that's the one you wanted me to test) still fails in exactly the same way.
Comment 6 Mike Auty gentoo-dev 2009-05-10 22:01:33 UTC
No, sorry, I was hoping you'd test linuxwacom-0.8.2, the version you reported the problem about.  0.8.3_p4 is a testing version and, as it turns out, has other problems...  Please try 0.8.2 from my overlay and let me know if that helps...
Comment 7 Christopher Head 2009-05-10 23:08:18 UTC
Oh, OK. Yes, that ebuild installs perfectly, thanks!
Comment 8 Mike Auty gentoo-dev 2009-05-10 23:26:01 UTC
Thanks, just committed the changes to the tree.  Feel free to reopen this if the problem hasn't gone away...  5:)
Comment 9 Christopher Head 2009-10-22 08:13:52 UTC
The latest stable in Portage is now 0.8.4_p1, and this came back.
Comment 10 Mike Auty gentoo-dev 2009-10-22 12:31:09 UTC
Thanks very much for the notice.  This is now FIXED again, please wait a few hours, resync your tree, then try re-emerging linuxwacom-0.8.4_p1 again please...
Comment 11 Christopher Head 2009-10-23 04:41:29 UTC
Fixed again. Oh, and there's a typo in the post-compile message: "Please remove any HAL .FDI files you may previously have installed ***fr*** linuxwacom.".


I'll reopen this if the module issue comes back again.