Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 268305 - mail-filter/spamassassin-3.2.1-r1 failed failed to emerge
Summary: mail-filter/spamassassin-3.2.1-r1 failed failed to emerge
Status: RESOLVED DUPLICATE of bug 230991
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-02 15:44 UTC by christian heidingsfelder
Modified: 2009-09-09 23:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description christian heidingsfelder 2009-05-02 15:44:09 UTC
Writing /var/tmp/portage/mail-filter/spamassassin-3.2.1-r1/image//usr/lib/perl5/vendor_perl/5.8.8/i686-linux/auto/Mail/SpamAssassin/.packlist
/usr/bin/perl build/preprocessor  -Mvars -DVERSION="3.002001" -DPREFIX="/usr" -DDEF_RULES_DIR="/usr/share/spamassassin" -DLOCAL_RULES_DIR="/etc/mail/spamassassin" -DLOCAL_STATE_DIR="/var/lib/spamassassin" -DINSTALLSITELIB="/usr/lib/perl5/vendor_perl/5.8.8" -DCONTACT_ADDRESS="the administrator of that system" -Msharpbang -Mconditional -DPERL_BIN="/usr/bin/perl" -DPERL_WARN="" -DPERL_TAINT="no" -m755 -isa-update.raw -osa-update
Cannot open /usr/share/spamassassin/10_default_prefs.cf: No such file or directory at build/preprocessor line 127.
make: *** [data__install] Error 2
make: *** Waiting for unfinished jobs....
 * 
 * ERROR: mail-filter/spamassassin-3.2.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 2523:  Called perl-module_src_install
 *             environment, line 2199:  Called die
 * The specific snippet of code:
 *               emake ${myinst} ${mytargets} || die "emake ${myinst} ${mytargets} failed";
 *  The die message:
 *   emake  install failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/mail-filter/spamassassin-3.2.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/mail-filter/spamassassin-3.2.1-r1/temp/environment'.
 * 
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-27003.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: mkdir
S: deny
P: /usr/share/spamassassin
A: /usr/share/spamassassin
R: /usr/share/spamassassin
C: /usr/bin/perl5.8.8 -MExtUtils::Command -e mkpath /usr/share/spamassassin 
--------------------------------------------------------------------------------
 * QA Notice: make jobserver unavailable:
 * 
 * 	make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.

>>> Failed to emerge mail-filter/spamassassin-3.2.1-r1, Log file:

>>>  '/var/tmp/portage/mail-filter/spamassassin-3.2.1-r1/temp/build.log'

 * Messages for package mail-filter/spamassassin-3.2.1-r1:

 * 
 * ERROR: mail-filter/spamassassin-3.2.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 2523:  Called perl-module_src_install
 *             environment, line 2199:  Called die
 * The specific snippet of code:
 *               emake ${myinst} ${mytargets} || die "emake ${myinst} ${mytargets} failed";
 *  The die message:
 *   emake  install failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/mail-filter/spamassassin-3.2.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/mail-filter/spamassassin-3.2.1-r1/temp/environment'.
 * 



Reproducible: Always




# emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r7-i686-Dual-Core_AMD_Opteron-tm-_Processor_1214_HE-with-glibc2.0
Timestamp of tree: Fri, 01 May 2009 16:45:02 +0000
distcc 3.0 i686-pc-linux-gnu [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=opteron -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=opteron -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/webapps-experimental"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X acl animgif apache2 automount bacula-clientonly berkdb bzip2 cgi charconv clamav cli contentcache courier cracklib crypt ctype cups curl dbus dkim dri dynamicplugin ermt examples filter flexresp2 fontconfig fortran ftp gd gdbm geoip gif gpm gradient gre iconv imagemagick imap inline ipf-transparent isdnlog java jpeg jpgraph libwww linux-smp-stats maildir math midi milter mudflap mysql mysqli ncurses nls nptl nptlonly opengl openmp pam pam-mysql paranoidmsg pcre perfprofiling perl php png pppd prelude python qt3 qt3support qt4 razor react readline reflection reminders samba sasl session sguil signatures snmp snortsam sockets spamassassin spl ssl subversion swat sysfs syslog tcpd timestats tools truetype unicode vhosts winbind x86 xml xorg xpm zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default status rewrite auth_digest authn_dbd authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta charset_lite dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires ext_filter file_cache filter headers ident imagemap include info log_config log_forensic logio mem_cache mime mime_magic negotiation rewrite setenvif speling status substitute unique_id userdir usertrack version vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeff Mitchell 2009-09-09 23:33:43 UTC
I also get this. Have to emerge with FEATURES="-sandbox".
Comment 2 David Abbott (RETIRED) gentoo-dev 2009-09-09 23:54:34 UTC

*** This bug has been marked as a duplicate of bug 230991 ***