Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 268051 - dev-lang/python-2.{4,5,6}*: test_largefile fails with sandbox-1.6 enabled
Summary: dev-lang/python-2.{4,5,6}*: test_largefile fails with sandbox-1.6 enabled
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
: 307293 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-01 01:03 UTC by Joshua Pettett
Modified: 2010-10-27 10:31 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log for python-2.6.5-r2 (dev-lang:python-2.6.5-r2:20100604-104034.log,148.37 KB, text/plain)
2010-06-04 10:57 UTC, Paweł Hajdan, Jr. (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua Pettett 2009-05-01 01:03:18 UTC
Using

FEATURES="test" emerge -1 python

produces the following error:

1 test failed:
    test_largefile
36 tests skipped:
    test_aepack test_al test_applesingle test_bsddb185 test_bsddb3
    test_cd test_cl test_codecmaps_cn test_codecmaps_hk
    test_codecmaps_jp test_codecmaps_kr test_codecmaps_tw test_curses
    test_gl test_imageop test_imgfile test_linuxaudiodev test_macfs
    test_macostools test_nis test_normalization test_ossaudiodev
    test_pep277 test_plistlib test_scriptpackages test_socket_ssl
    test_socketserver test_startfile test_sunaudiodev test_timeout
    test_unicode_file test_urllib2net test_urllibnet test_winreg
    test_winsound test_zipfile64
2 skips unexpected on linux2:
    test_urllib2net test_imageop
Re-running failed tests in verbose mode
Re-running test 'test_largefile' in verbose mode
create large file via seek (may be sparse file) ...
check file size with os.fstat
2500000001L =?= 2500000001L ... yes
check file size with os.stat
2500000001L =?= 2500000001L ... yes
play around with seek() and read() with the built largefile
test test_largefile crashed -- <type 'exceptions.IOError'>: [Errno 75] Value too large for defined data type: '@test'
Traceback (most recent call last):
  File "./Lib/test/regrtest.py", line 549, in runtest_inner
    the_package = __import__(abstest, globals(), locals(), [])
  File "/var/tmp/portage/dev-lang/python-2.5.4-r2/work/Python-2.5.4/Lib/test/test_largefile.py", line 89, in <module>
    f = open(name, 'rb')
IOError: [Errno 75] Value too large for defined data type: '@test'
'test_largefile' left behind file '@test'
make: *** [test] Error 1



Portage 2.1.6.11 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r7forjosh i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r7forjosh-i686-Intel-R-_Pentium-R-_4_CPU_2.80GHz-with-glibc2.0
Timestamp of tree: Thu, 30 Apr 2009 09:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch prelink protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://open-systems.ufl.edu/mirrors/gentoo http://mirrors.acm.cs.rpi.edu/gentoo/ http://mirror.datapipe.net/gentoo http://gentoo.chem.wisc.edu/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://netserver/gentoo-portage"
USE="X a52 aac acl acpi adns aim alsa arts audiofile avi bash-completion berkdb bitmap-fonts bluetooth branding bzip2 cairo caps cdr cli cracklib crypt cscope cups curl dbus dbx doc dri dvd dvdr dvdread emboss encode evo exif expat fam ffmpeg firefox flac flash flatfile fortran ftp gd gdbm gif gmp gnutls gpm gstreamer gtk hal iconv idn imagemagick imap imlib innodb ipv6 isdnlog jabber java joystick jpeg kde lcms ldap libnotify mad mhash midi mikmod mime ming mmx mng motif mozilla mp3 mpeg mudflap mysql mysqli ncurses nis nls nptl nptlonly nsplugin odbc ogg opengl openmp oscar pam pcntl pcre pda pdf perl php pic pie png posix ppds pppd prelude python qt3 qt3support qt4 quicktime readline reflection samba sasl sdl session shared sharedmem simplexml soap sockets speex spell spl sqlite sse sse2 ssl startup-notification svg sysfs sysvipc tcltk tcpd threads tidy tiff tk tokenizer truetype truetype-fonts unicode usb vhosts videos vim-syntax vorbis win32codecs wmf x86 xine xinerama xml xmlrpc xorg xosd xulrunner xv xvid yahoo zlib" ALSA_CARDS="emu10k1 emu10k1x intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Joshua Pettett 2009-05-01 17:17:35 UTC
This test passes when sandbox is disabled.
Comment 2 Jerome Potts 2009-08-19 05:44:15 UTC
Same problem for me with dev-lang/python-2.4.6
I am glad the workaround is documented here: i removed "sandbox" from FEATURES, but that was not enough, i had to remove "usersandbox" too, then the install did complete.
Comment 3 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-09-27 14:15:29 UTC
Got it with 2.6.2-r1.
Comment 4 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-02-27 08:01:59 UTC
Happens with 2.6.4-r1, x86 stable.
Comment 5 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-01 17:56:27 UTC
*** Bug 307293 has been marked as a duplicate of this bug. ***
Comment 6 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-01 17:59:53 UTC
Sandbox maintainers: Could you review this bug?
Comment 7 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-06-04 10:57:17 UTC
Created attachment 234105 [details]
build.log for python-2.6.5-r2
Comment 8 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-06-04 13:36:33 UTC
When running the test in isolation (sandbox python2.6 -m test.test_largefile) it fails with sys-apps/sandbox-1.6-r2, but works with sys-apps/sandbox-2.2.
Comment 9 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-06-04 14:36:42 UTC
(In reply to comment #8)
> When running the test in isolation (sandbox python2.6 -m test.test_largefile)
> it fails with sys-apps/sandbox-1.6-r2, but works with sys-apps/sandbox-2.2.

This is also true when emerging entire dev-lang/python-2.6.5-r2: with sandbox-2.2 it works fine.
Comment 10 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-06-22 13:57:18 UTC
Sandbox maintainers: Can sys-apps/sandbox-2.2 be stabilized?
Comment 11 SpanKY gentoo-dev 2010-08-15 19:16:35 UTC
no, but sandbox-2.3 will be on a stable track
Comment 12 Dirkjan Ochtman gentoo-dev 2010-10-27 09:30:11 UTC
Presumably this works with the currently stable sandbox-2.3?
Comment 13 Dirkjan Ochtman gentoo-dev 2010-10-27 10:31:11 UTC
Works fine for me, closing as FIXED.