Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267784 - dev-lisp/clisp-2.47.r1 fails to compile with sys-devel/gcc-4.4
Summary: dev-lisp/clisp-2.47.r1 fails to compile with sys-devel/gcc-4.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Common Lisp Bugs
URL:
Whiteboard:
Keywords: Inclusion
Depends on: 322599
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-04-28 14:04 UTC by J.Benoist Leger
Modified: 2010-06-26 14:19 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The build.log file (build.log,60.34 KB, text/plain)
2009-04-28 14:06 UTC, J.Benoist Leger
Details
My solution, and it compiles fine (2.47-gcc4.4.patch,360 bytes, patch)
2009-04-28 14:07 UTC, J.Benoist Leger
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description J.Benoist Leger 2009-04-28 14:04:21 UTC
It happens in the compilation.

Reproducible: Always

Steps to Reproduce:
1. gcc-config to gcc4.4
2. emerge -1 =dev-lisp/clisp-2.47-r1
Actual Results:  
It fails in compilation

Expected Results:  
Compiles fine.

Portage 2.1.6.11 (default/linux/x86/2008.0, gcc-4.4.1-pre9999, glibc-2.9_p20081201-r2, 2.6.28-gentoo i686)
=================================================================
System uname: Linux-2.6.28-gentoo-i686-Mobile_Intel-R-_Pentium-R-_4_CPU_3.20GHz-with-gentoo-2.0.0
Timestamp of tree: Sat, 25 Apr 2009 09:00:01 +0000
app-shells/bash:     4.0_p17-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2
dev-util/cmake:      2.6.3-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -floop-block -floop-interchange -floop-strip-mine -fgraphite "
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -floop-block -floop-interchange -floop-strip-mine -fgraphite "
DISTDIR="/usr/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ http://distfiles.gentoo.org/"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr fr_FR en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/ion-overlay /usr/local/portage/layman/sunrise /usr/local/portage/layman/science /usr/local/portage/layman/timharder-overlay /usr/local/portage/layman/gcc-porting"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa berkdb bzip2 cdr cli cracklib crypt cups custom-cflags cxx dri dvd fftw fortran gdbm gpm graphite gtk iconv ipv6 isdnlog jpeg midi mudflap ncurses nls nptlonly openmp pam pcre perl png pppd python readline reflection ruby session skey spl sse sse2 ssl sysfs tcl tcpd threads tk unicode utf8 x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR en en_US" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 J.Benoist Leger 2009-04-28 14:06:20 UTC
Created attachment 189713 [details]
The build.log file
Comment 2 J.Benoist Leger 2009-04-28 14:07:29 UTC
Created attachment 189715 [details, diff]
My solution, and it compiles fine
Comment 3 Marijn Schouten (RETIRED) gentoo-dev 2009-05-02 11:22:14 UTC
reported upstream
Comment 4 hirakendu 2009-05-29 06:29:24 UTC
Patch works fine.
Comment 5 Marijn Schouten (RETIRED) gentoo-dev 2009-07-29 11:33:37 UTC
This should be fixed in 2.48
Comment 6 Łukasz Michalik 2010-05-27 17:32:27 UTC
Yes, but stable is 2.47, and gcc-4.4 has just gone stable too.  Please, reopen.
Comment 7 Sebastian Luther (few) 2010-05-30 05:25:03 UTC
(In reply to comment #6)
> Yes, but stable is 2.47, and gcc-4.4 has just gone stable too.  Please, reopen.
> 

Hit that too, reopening.
Comment 8 Israel G. Lugo 2010-05-31 05:54:30 UTC
Confirmed. I have just upgraded to GCC 4.4 stable and dev-lisp/clisp-2.47-r1 fails to compile. For search purposes, I quote the exact error message:

gcc -Igllib -O2 -march=native -msse3 -mfpmath=sse -pipe -W -Wswitch -Wcomment -Wpointer-arith -Wimplicit -Wreturn-type -Wmissing-declarations -Wno-sign-compare -O -falign-functions=4 -DUNICODE -DDYNAMIC_FFI -DDYNAMIC_MODULES -I. -c time.c
../src/time.d:305:19: error: token "=" is not valid in preprocessor expressions
make: *** [time.o] Error 1
 * ERROR: dev-lisp/clisp-2.47-r1 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line  54:  Called src_compile
 *   environment, line 2736:  Called die
 * The specific snippet of code:
 *       emake -j1 || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =dev-lisp/clisp-2.47-r1',
 * the complete build log and the output of 'emerge -pqv =dev-lisp/clisp-2.47-r1'.
 * The complete build log is located at '/var/tmp/portage/dev-lisp/clisp-2.47-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lisp/clisp-2.47-r1/temp/environment'.
 * S: '/var/tmp/portage/dev-lisp/clisp-2.47-r1/work/clisp-2.47'

The problem is an incorrect preprocessor expression in the src/time.d file, line 305, as indicated by GCC. There's a simple typo, a = that should be a ==. GCC 4.1 was kind enough to let it slip, but GCC 4.4 is strict and complains about the error.

J. Benoist Leger's patch is correct and fixes the problem. It is a trivial patch for a trivial problem caused by a typo. Please apply this patch ASAP since as it stands now, dev-lisp/clisp stable won't compile with sys-devel/gcc stable.
Comment 9 Samuli Suominen gentoo-dev 2010-06-26 12:07:45 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Yes, but stable is 2.47, and gcc-4.4 has just gone stable too.  Please, reopen.
> > 
> 
> Hit that too, reopening.
> 

don't do that, open stablereq's if needed...
Comment 10 Israel G. Lugo 2010-06-26 14:16:53 UTC
I think this should really be RESOLVED WONTFIX... This bug is specifically about dev-lisp/clisp-2.47-r1, and the decision was to not fix that version because 2.48 is out.

I understand that there may not be much interest in fixing 2.47-r1 since 2.48 is already stable, but at the very least, dev-lisp/2.47-r1 should be keyworded... right now dev-lisp/2.47-r1 is marked stable, and it does *not* compile with stable gcc! That is a very big no no.

(In reply to comment #9)
> 
> don't do that, open stablereq's if needed...
> 

Comment 11 Israel G. Lugo 2010-06-26 14:19:06 UTC
(In reply to comment #10)
> I think this should really be RESOLVED WONTFIX... This bug is specifically
> about dev-lisp/clisp-2.47-r1, and the decision was to not fix that version
> because 2.48 is out.
> 
> I understand that there may not be much interest in fixing 2.47-r1 since 2.48
> is already stable, but at the very least, dev-lisp/2.47-r1 should be
> keyworded... right now dev-lisp/2.47-r1 is marked stable, and it does *not*
> compile with stable gcc! That is a very big no no.

Erm, I obviously meant dev-lisp/clisp-2.47-1 in my previous comment; sorry.