Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267686 - app-portage/layman please document "nocheck : yes" better
Summary: app-portage/layman please document "nocheck : yes" better
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Sebastian Pipping
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-27 19:48 UTC by Erik Quaeghebeur
Modified: 2010-11-07 00:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---
sping: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Quaeghebeur 2009-04-27 19:48:49 UTC
Layman doesn't show overlay types when appropriate version-control system is not installed.

I was looking for the haskell overlay, but it seems it only appears when darcs is installed. All overlays should ideally be shown, and a pointer given when trying to add an overlay that requires an uninstalled version control system.

Reproducible: Always
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-27 22:10:07 UTC
Please post your "emerge --info" and tell which layman-version you have tried.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-28 21:24:08 UTC
Heh, now I know why I wasn't able to reproduce this problem. It's actually no bug but a "hidden" feature :)

Try to set

  nocheck  : yes

in your layman.cfg and try again :)
Comment 3 Erik Quaeghebeur 2009-04-28 21:52:27 UTC
(In reply to comment #2)
> Heh, now I know why I wasn't able to reproduce this problem. It's actually no
> bug but a "hidden" feature :)
> 
> Try to set
> 
>   nocheck  : yes
> 
> in your layman.cfg and try again :)

Indeed, that does the trick. Documenting this in the cfg file would be a good idea; perhaps changing the default as well.
 

Comment 4 Sebastian Pipping gentoo-dev 2010-11-07 00:01:40 UTC
Both the man page and the comments in layman.cfg have been extended to address this issue.  The next release of layman will feature these changes.

http://layman.git.sourceforge.net/git/gitweb.cgi?p=layman/layman;a=commitdiff;h=46fb83877a68c5ddc1841e93695248772c500168

Closing, please re-open as necessary.