Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 26741 - lots of crashes
Summary: lots of crashes
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: PPC Porters
Depends on:
Reported: 2003-08-16 12:12 UTC by Felipe Gasper
Modified: 2006-02-04 06:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Felipe Gasper 2003-08-16 12:12:22 UTC
I'm sorry for the overly general summary, but I'm trying to load Gentoo/PPC onto
a Powerbook G3 ("bronze" keyboard) and am getting crashes left and right. First,
I've noticed that emerge sync crashes at the end of its course - it'll
apparently download and leave all of the files in /usr/portage that it should,
but it crashes nonetheless.

Next, I try doing "emerge system" (since I already have a stage 1 CD). This
works for a few small ports, but when I get to bzip2, this is the output:

Calculating dependencies  ...done!
>>> emerge (1 of 1) sys-apps/bzip2-1.0.2-r2 to /
>>> md5 src_uri ;-) bzip2-1.0.2.tar.gz
>>> Unpacking source...
>>> Unpacking bzip2-1.0.2.tar.gz to /var/tmp/portage/bzip2-1.0.2-r2/work
>>> Source unpacked.
gcc -fpic -fPIC -Wall -Winline -O3 -pipe -mcpu=750 -fomit-frame-pointer
-fno-strength-reduce -D_FILE_OFFSET_BITS=64 -c blocksort.c
gcc -fpic -fPIC -Wall -Winline -O3 -pipe -mcpu=750 -fomit-frame-pointer
-fno-strength-reduce -D_FILE_OFFSET_BITS=64 -c huffman.c
gcc -fpic -fPIC -Wall -Winline -O3 -pipe -mcpu=750 -fomit-frame-pointer
-fno-strength-reduce -D_FILE_OFFSET_BITS=64 -c crctable.c
gcc -fpic -fPIC -Wall -Winline -O3 -pipe -mcpu=750 -fomit-frame-pointer
-fno-strength-reduce -D_FILE_OFFSET_BITS=64 -c randtable.c
gcc -fpic -fPIC -Wall -Winline -O3 -pipe -mcpu=750 -fomit-frame-pointer
-fno-strength-reduce -D_FILE_OFFSET_BITS=64 -c compress.c
gcc -fpic -fPIC -Wall -Winline -O3 -pipe -mcpu=750 -fomit-frame-pointer
-fno-strength-reduce -D_FILE_OFFSET_BITS=64 -c decompress.c
gcc: Internal error: Terminated (program cc1)
Please submit a full bug report.
See <URL:> for instructions.
make: *** [compress.o] Error 1
make: *** Waiting for unfinished jobs....
!!! ERROR: sys-apps/bzip2-1.0.2-r2 failed.
!!! Function src_compile, Line 35, Exitcode 2
!!! Make failed

With this package, though, I am able to unzip the tarball manually and compile
it myself. Weird, since I can't find much that's different in the ebuild than a
simple compile.

Anyway, so I tried next "emerge man". Again, it brought in a few smaller
packages then started on groff. Again, a similar crash. I tried compiling groff
manually like I had done w/ bzip2, but this time even manual compilation
produced the error.

I'm not ruling out the possibility of the hardware being responsible, but this
machine was happily running OS X before I decided I wanted a "real" UNIX on
there. (I first tried NetBSD....plegh! Gentoo's install is WAY better!) It's
worth noting that the NetBSD installer also did crash while it was running, but
that's a quirky installer anyway in my (admittedly limited) experience.
Comment 1 Pieter Van den Abeele (RETIRED) gentoo-dev 2003-10-11 05:05:20 UTC
My first guess would be that your memory is faulty. Could that be possible?
Comment 2 Lars Weiler (RETIRED) gentoo-dev 2003-12-05 21:08:51 UTC
Is this bug still valid?  Do you still have troubles with your RAM?
Comment 3 Lars Weiler (RETIRED) gentoo-dev 2004-02-15 15:04:07 UTC
No answer.  Closing.