Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267309 - app-emulation/virtualbox-bin-2.1.4 (and 2.2.0) cannot access sound card properly
Summary: app-emulation/virtualbox-bin-2.1.4 (and 2.2.0) cannot access sound card properly
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Markus Ullmann (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-24 09:13 UTC by Francesco Lamonica
Modified: 2011-05-29 21:49 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francesco Lamonica 2009-04-24 09:13:55 UTC
Whenever i try to start a virtual machine i get the startup error: HostAudioNotResponding
this happens if i choose ALSA as audio driver in the vm settings
if i choose pulseaudio instead, i get audio working on the guest vm but then host's sounds are muted. Also after closing a vm (using pulseaudio) sometimes restarting the vm gives the dreaded HostAudioNotResponding error, and nothing short of a host reboot will fix that.

Reproducible: Always

Actual Results:  
either guest vm does not have sound (using alsa) or host has no sound when guest is running (using pulseaudio)

Expected Results:  
both guests and host should have access to sound card.

more info can be read on the forum thread: http://forums.gentoo.org/viewtopic-t-739568-highlight-virtualbox.html

emerge --info
Portage 2.1.6.7 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r4-x86_64-AMD_Phenom-tm-_9750_Quad-Core_Processor-with-glibc2.2.5
Timestamp of tree: Fri, 24 Apr 2009 08:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userprov usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en it"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl acpi aften akode alsa amazon amd64 amr amrnb amrwb animgif audiofile berkdb bluetooth branding bzip2 cairo ccache cdr cleartype cli cracklib crypt cscope cups curl cxx dbus dri dvd dvdr dvdread eds encode esd fam ffmpeg firefox foomaticdb gcrypt gd gdbm gif gimp gkrellm gpm gsm gstreamer gtk hardened iconv imagemagick ipod java java6 jpeg kde lame libgcrypt libssh2 logrotate loop-aes mad matroska midi mmx mmxext mng mp3 mp4 mpeg mpeg2 mplayer mudflap multilib musepack musicbrainz ncurses nls nptl nptlonly nsplugin ogg opengl openmp openssl opensslcrypt pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session smp sndfile speex spell spl sqlite3 sse sse2 sse3 sse4.1 sse4.2 sse4a sse5 ssl startup-notification subversion svg svnserve swat sysfs syslog tcpd theora tiff truetype unicode usb v4l v4l2 vorbis webkit x264 xcomposite xinerama xml xorg xscreensaver xulrunner xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en it" USERLAND="GNU" VIDEO_CARDS="vesa nv nvidia vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Alessio Cassibba (X-Drum) 2009-04-29 09:01:43 UTC
Hi,

seems that you have issues with your soundcard/sound setup,
in short this can happen when your soundcard lacks the "hardware mixing"
feature (please report some infos about your audio card and setup).
In this case you can solve this problem with ALSA softmixing (aka DMIX):
http://alsa.opensrc.org/home/w/org/opensrc/alsa/index.php?title=DmixPlugin

To use pulseaudio you obviously you need a working pulseaudio setup, if your are
experiencing problems you can choose the "NULL" audio backend instead until
the problem with the ALSA setup is not solved.
Comment 2 Francesco Lamonica 2009-04-29 10:00:41 UTC
Hi Alessio, my ALSA host config sounds pretty good... mixing works flawlessly on the host (using snd-hda-intel module: integrated soundchip of NVIDIA chipset nforce) As for PulseAudio... it works with multiple vbox guest but only if i use the system-wide (/etc/init.d/pulseaudio start) since as user i am unable to start it (my user is part of pulse and pulse-access group though)
Comment 3 Kevin Parent 2009-05-08 22:51:19 UTC
This has been an issue for me since vb 2.0.6!!!  It wasn't caused by a vb upgrade either, something else is the problem.  It worked fine before.  I started a thread about this issue back in February.  See the thread for details.  Here's the link:

http://forums.gentoo.org/viewtopic-t-739568-highlight-.html

As you can see from the thread, there are several users experiencing the same issue - VB-bin used to work with sound, and now it doesn't.

# emerge --info
Portage 2.1.6.11 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r3 i686)
=================================================================
System uname: Linux-2.6.29-gentoo-r3-i686-AMD_Turion_Dual-Core_RM-70-with-glibc2.0
Timestamp of tree: Fri, 08 May 2009 15:15:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_US en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/lcd-filtering /usr/portage/local/layman/berkano /usr/portage/local/layman/webapps-experimental /usr/portage/local/layman/desktop-effects /usr/local/portage"
SYNC="rsync://rsync21.us.gentoo.org/gentoo-portage"
USE="3dnowext X aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli cracklib crypt cups dbus dri dts dvd dvdr dvdread eds emboss encode esd evo exif fam ffmpeg firefox flac fortran fuse gdbm gif glib gnome gnome-keyring gpm gstreamer gtk hal iconv id3tag isdnlog jpeg laptop ldap libnotify mad midi mikmod mmx mmxext mp3 mpeg mudflap nautilus ncurses network-cron nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session spell spl sse2 ssl startup-notification suexec svg swat sysfs tcpd threads tiff truetype unicode usb vorbis win32codecs x86 xml xorg xulrunner xv xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Filipe Dios 2009-05-09 00:18:56 UTC
Also have the same problem. It worked fine in 2.0something (sorry, can't remember exactly what release) but stopped working all of a sudden. I guess it was after some update. Also have hda-intel for sound, could this be related at all? Not sure. It doesn't seem to be related to mixing as I can hear amarok plus other linux audio (java, pidgin, vlc, etc) at the same time with plain alsa. 

emerge --info:
Portage 2.1.6.13 (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.27-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-i686-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5600+-with-glibc2.0
Timestamp of tree: Fri, 08 May 2009 06:15:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r13, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon64 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.localhost.net.ar/ http://www.las.ic.unicamp.br/pub/gentoo/ "
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en pt_BR"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://lily/gentoo-portage"
USE="3dnow 3dnowext X Xaw3d aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cdr cli cpudetection cracklib crypt ctrlmenu cups dbus dc1394 dri dts dv dvb dvd dvdr dvdread eds emboss emerald encode esd evo exif fam ffmpeg firefox flac fluidsynth fontconfig fortran gdbm gif gimp gnome gpm gstreamer gtk hal hddtemp iconv imagemagick ipod isdnlog java jpeg jpeg2k ldap libnotify live lm_sensors lzo mad matroska midi mikmod mjpeg mmx mmxext moznopango mp3 mpeg mudflap mysql ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime rar raw readline reflection schroedinger sdl session skins speex spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora tiff tk truetype unicode usb v4l2 vim-with-x vorbis win32codecs x86 xcb xcomposite xforms xml xorg xscreenserver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en pt_BR" USERLAND="GNU" VIDEO_CARDS="fglrx vesa vga radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Andreas Brinkmann 2009-05-09 15:08:17 UTC
I had exactly the same problem using virtualbox-bin-2.2.2. Re-emerging libsdl without the esd useflag solved the problem:

[ebuild   R   ] media-libs/libsdl-1.2.13-r1  USE="X alsa arts audio joystick nas opengl video xv -aalib -custom-cflags -dga -directfb -esd -fbcon -ggi -libcaca -oss -pulseaudio -svga -xinerama" 0 kB

/Andreas
Comment 6 Filipe Dios 2009-05-09 15:15:43 UTC
Confirm disabling esd on libsnd solved the problem. Maybe patch virtualbox-bin ebuild to detect that and warn users?
Comment 7 Kevin Parent 2009-05-09 15:39:49 UTC
Disabling esd in libsdl worked here as well.  Does the esd flag actually serve a purpose besides breaking the sound?
Comment 8 Alessio Cassibba (X-Drum) 2009-09-10 16:10:23 UTC
This bug should be closed since this release is 
not available in portage (see bug #260331).


There are still issues with the esd USE flag and virtualbox-bin 3.x?
if any i will add a check to the ebuilds as stated in comment #6
Comment 9 Michael F. 2009-10-03 16:35:44 UTC
(In reply to comment #8)
> There are still issues with the esd USE flag and virtualbox-bin 3.x?
> if any i will add a check to the ebuilds as stated in comment #6

Yes. Here is the same problem in 3.0.6-r52128 and it got solved by removing the esd useflag of libsdl.
Comment 10 Michael F. 2009-10-03 16:44:45 UTC
(In reply to comment #9)
> Yes. Here is the same problem in 3.0.6-r52128 and it got solved by removing the
> esd useflag of libsdl.

Sorry, VirtualBox says that the version is 3.0.6 r52128. Gentoo says it is virtualbox-bin-3.0.6-r1.
Comment 11 Silvio 2010-04-27 11:59:25 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > There are still issues with the esd USE flag and virtualbox-bin 3.x?
> > if any i will add a check to the ebuilds as stated in comment #6
> 
> Yes. Here is the same problem in 3.0.6-r52128 and it got solved by removing the
> esd useflag of libsdl.
> 

I have the same problem and it is impossible to compile libsdl with -esd USE, because more recent version of libsdl-1.2.14-r2 hasn't that use.

:-(

how can I fix it? With Pulseaudio it works but I don't want Pulsaudio server running on my system (it create problem at startup notification with phonon who says: no analog device found).

Since version 2.0xxx it works well with alsa settings.
Comment 12 Jonathan Adamczewski 2010-06-18 01:23:25 UTC
This is still an issue with virtualbox-bin-3.2.4 - with >libsdl-1.2.13-r1, ALSA sound does not function correctly.
Comment 13 Francesco Lamonica 2010-06-18 08:33:26 UTC
Actually i can confirm that virtualbox-bin-3.x works perfectly with latest alsa (> 1.20) and latest libsdl (which has no more the aforementioned esd USE flag)
Comment 14 Andreas Sturmlechner gentoo-dev 2010-06-30 17:40:51 UTC
(In reply to comment #13)
> Actually i can confirm that virtualbox-bin-3.x works perfectly with latest alsa
> (> 1.20) and latest libsdl (which has no more the aforementioned esd USE flag)
> 

Would you be so kind to tell us your libsdl USE-flags? ;)
Comment 15 Francesco Lamonica 2010-07-01 08:24:23 UTC
here you are:

equery uses libsdl
[ Searching for packages matching libsdl... ]
[ Colour Code : set unset ]
[ Legend : Left column  (U) - USE flags from make.conf              ]
[        : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for media-libs/libsdl-1.2.13-r1 ]
 U I
 + + X             : Adds support for X11
 - - aalib         : Adds support for media-libs/aalib (ASCII-Graphics Library)
 + + alsa          : Adds support for media-libs/alsa-lib (Advanced Linux Sound Architecture)
 - + audio         : Control audio support (disable at your own risk)
 - - custom-cflags : Build with user-specified CFLAGS (unsupported)
 - - dga           : Adds DGA (Direct Graphic Access) support for X
 - - directfb      : Adds support for DirectFB layer (library for FB devices)
 - - esd           : Adds support for media-sound/esound (Enlightened Sound Daemon)
 - - fbcon         : Adds framebuffer support for the console, via the kernel
 - - ggi           : Adds support for media-libs/libggi (non-X video api/drivers)
 - + joystick      : Add support for joysticks in all packages
 - - libcaca       : Add support for colored ASCII-art graphics
 - - nas           : Adds support for network audio sound
 + + opengl        : Adds support for OpenGL (3D graphics)
 - - oss           : Adds support for OSS (Open Sound System)
 - - pulseaudio    : Adds support for PulseAudio sound server
 - - svga          : Adds support for SVGAlib (graphics library)
 - - tslib         : Build with tslib support for touchscreen devices
 - + video         : Control video support (disable at your own risk)
 + + xinerama      : Add support for the xinerama X11 extension, which allows you to stretch your display across multiple monitors
 + + xv            : Adds in optional support for the Xvideo extension (an X API for video playback)
Comment 16 Andreas Sturmlechner gentoo-dev 2010-07-01 17:13:46 UTC
thanks a lot. except for xinerama and dga which shouldn't have an obvious connection to audio issues, our USE-flags are the same.

libdsl version however isn't. latest is actually libsdl-1.2.14-r2, so maybe that is the problem.
Comment 17 Andreas Sturmlechner gentoo-dev 2010-07-01 17:25:25 UTC
Yes, downgrading to libsdl-1.2.13-r1 definitely solves the problem.
Comment 18 liva 2010-07-24 23:29:24 UTC
(In reply to comment #17)
> Yes, downgrading to libsdl-1.2.13-r1 definitely solves the problem.
> 
http://forums.gentoo.org/viewtopic-p-6298753-highlight-+disable+alsa+shared.html#6298753
" ... for newest ebuild of libsdl. 
In the ebuild the option --disable-alsa-shared is on. Then by removing it, it works now."
Comment 19 meyerm 2011-02-02 15:32:23 UTC
For further discussion (and why it won't be fixed) please see #310793 .
Comment 20 Nick 2011-02-09 10:22:06 UTC
app-emulation/virtualbox-bin-3.2.12-r1
media-libs/libsdl-1.2.13-r1

Removing "esd" use flag fixed the problem for me, thanks!