Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 26720 - invisible usb devices
Summary: invisible usb devices
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2003-08-16 08:19 UTC by Artur Brodowski
Modified: 2003-10-15 12:18 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Artur Brodowski 2003-08-16 08:19:59 UTC
this might be same problem as in #23313, but since i did not get any info 
from the reporter, i'm gonna open new bugreport.

i have two usb devices connected to my box, but the system does not see them.
support for usb is compiled into the kernel, modules for usb printer and usb 
scanner are loaded fine at boottime (or it seems this way):

# dmesg
usb.c: registered new driver usblp
printer.c: v0.11: USB Printer Device Class driver
usb.c: registered new driver usbscanner
scanner.c: 0.4.12:USB Scanner Driver

devices show up in /proc/bus/usb/devices, but they are not appearing under
/dev/usb tree. also lsmod gives unusual output:
scanner                10488   0  (unused)
printer                 7744   0  (unused)

i had the same problem as in #23313 (lots of "modprobe: Can't locate module
/dev/usb..." messages), but i don't use portmap. also, after upgrading gentoo
sources to 2.4.20-r6 the messages disappeared, unfortunately with usb devices
in /dev.

i suspect this has something to do with module-init-tools, because it happened
after i installed 2.6.0beta, though it could be also devfs related.
the printer used to work before.

# emerge info
Portage 2.0.48-r7 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r1)
System uname: 2.4.20-gentoo-r6 i686 Pentium III (Coppermine)
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss 3dnow apm avi crypt encode foomaticdb gif jpeg libg++ libwww mad
mikmod mmx mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms xv
zlib gdbm berkdb slang readline svga java guile sdl gpm tcpd pam ssl perl python
esd imlib oggvorbis gtk motif opengl mozilla scanner X gtk2 gnome alsa cups dvd
usb moznomail moznocompose moznoirc -arts -qt -kde"
CFLAGS="-mcpu=pentium3 -march=pentium3 -O3 -pipe"
CXXFLAGS="-mcpu=pentium3 -march=pentium3 -O3 -pipe"
FEATURES="sandbox ccache buildpkg"
Comment 1 Artur Brodowski 2003-08-16 15:08:14 UTC
i did unmerge module-init-tools and remerge modutils as someone suggested, 
but it did not fix the problem.
Comment 2 Genady Okrain 2003-08-16 23:32:25 UTC

Try to enable it or

In the kernel
Comment 3 Artur Brodowski 2003-08-17 05:04:33 UTC
support for usb is already compiled in and used to work (uhci) - 
somehow it broke after installing development-sources and module-init-tools.
dmesg shows usblp and usbscanner, but these are 2.5.x drivers and 
running kernel is a stable one (2.4.20-r6).
as stated before, removing module-init-tools did not help :(
Comment 4 Tim Yamin (RETIRED) gentoo-dev 2003-09-02 09:00:57 UTC
A) Please try the latest baselayout []
B) Try a vanilla kernel
C) Remerge any kernel sources and run "make mrproper" in your kernel tree [ You'll need to reconfigure your kernel though ]
Comment 5 Artur Brodowski 2003-09-04 14:22:34 UTC
A. i've tried baselayout and (masked), no results
B/C. neither vanilla sources nor make mrproper helps - i still get
messages about development series kernel drivers being installed
(usblp and usbscanner), though i've unmerged development sources
along with module-init-tools.

what's more interesting, devices seems to be recognized by the kernel
$ /usr/sbin/lsusb
Bus 002 Device 001: ID 0000:0000
Bus 002 Device 002: ID 058f:9254 Alcor Micro Corp. Hub
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 002: ID 07b3:0413 Plustek, Inc.
$ uname -a
Linux tool 2.4.22 #1 czw wrz 4 22:48:32 CEST 2003 i686 Pentium III (Coppermine) GenuineIntel GNU/Linux
yet still:
$ cat /proc/bus/usb/drivers
  0- 15: usblp
 48- 63: usbscanner
Comment 6 Artur Brodowski 2003-09-23 02:43:54 UTC
more info in this:
i have just installed fresh new gentoo and it's acting the same way -
there are no usb devices in /dev.
also looks like usblp and usbscanner are valid drivers for 2.4 kernel.
i used latest stable gentoo-sources 2.4.20-r7 and dmesg gives the same
output as above. i've also tried compiling printer and scanner support
into the kernel and in the modules - both failed.
i was wondering if it could be some interrupr conflict, as two usb
devices are pluuged-in? i'll keep digging :)
Comment 7 Artur Brodowski 2003-09-26 08:15:01 UTC
ok, you may close this one. 
most probably this is not gentoo specific bug, but as suspected - interrupt

conflict. i'll do some more testing and send a report to kernel people.
Comment 8 Martin Holzer (RETIRED) gentoo-dev 2003-10-15 12:18:44 UTC
need upstream fix