Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 266788 - sys-devel/gcc-4.1.2 cannot be built with gcc-4.3.2 due unsupported CFLAGS by gcc-4.1
Summary: sys-devel/gcc-4.1.2 cannot be built with gcc-4.3.2 due unsupported CFLAGS by ...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-19 16:47 UTC by Pacho Ramos
Modified: 2009-04-23 06:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,394.87 KB, text/plain)
2009-04-19 16:47 UTC, Pacho Ramos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2009-04-19 16:47:27 UTC
I am running emerge -e world on a machine after updating to gcc-4.3 and I am using -march=native, the problem is that this causes gcc-4.1 rebuild to fails because old gcc doesn't suport it:
sys-devel/gcc-4.1.2/work/build/gcc/../ld -E -dM - | \
	  sed -n -e 's/^#define \([^_][a-zA-Z0-9_]*\).*/\1/p' \
		-e 's/^#define \(_[^_A-Z][a-zA-Z0-9_]*\).*/\1/p' | \
	  sort -u > tmp-macro_list
./xgcc -B./ -B/usr/i686-pc-linux-gnu/bin/ -isystem /usr/i686-pc-linux-gnu/include -isystem /usr/i686-pc-linux-gnu/sys-include -L/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/gcc/../ld -O2  -O2 -O2 -march=native -pipe  -DIN_GCC    -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition  -isystem ./include  -fPIC -g -DHAVE_GTHR_DEFAULT -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED  -msse -c \
		/var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/config/i386/crtfastmath.c \
		-o crtfastmath.o
/var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/config/i386/crtfastmath.c:1: error: valor erróneo (native) para el interruptor -march=
/var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/config/i386/crtfastmath.c:1: error: valor erróneo (native) para el interruptor -mtune=
/bin/sh /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/../move-if-change tmp-macro_list macro_list
make[2]: *** [crtfastmath.o] Error 1
make[2]: *** Se espera a que terminen otras tareas....
echo timestamp > s-macro_list
rm gfortran.pod
make[2]: se sale del directorio `/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: se sale del directorio `/var/tmp/portage/sys-devel/gcc-4.1.2/work/build/gcc'
make: *** [bootstrap-lean] Error 2
 [31;01m*[0m 
 [31;01m*[0m ERROR: sys-devel/gcc-4.1.2 failed.
 [31;01m*[0m Call stack:
 [31;01m*[0m               ebuild.sh, line   49:  Called src_compile
 [31;01m*[0m             environment, line 4747:  Called toolchain_src_compile
 [31;01m*[0m             environment, line 5269:  Called gcc_src_compile
 [31;01m*[0m             environment, line 3041:  Called gcc_do_make
 [31;01m*[0m             environment, line 2832:  Called die
 [31;01m*[0m The specific snippet of code:
 [31;01m*[0m       emake LDFLAGS="${LDFLAGS}" STAGE1_CFLAGS="${STAGE1_CFLAGS}" LIBPATH="${LIBPATH}" BOOT_CFLAGS="${BOOT_CFLAGS}" ${GCC_MAKE_TARGET} || die "emake failed with ${GCC_MAKE_TARGET}";
 [31;01m*[0m  The die message:
 [31;01m*[0m   emake failed with bootstrap-lean
 [31;01m*[0m 
 [31;01m*[0m If you need support, post the topmost build error, and the call stack if relevant.
 [31;01m*[0m A complete build log is located at '/var/tmp/portage/sys-devel/gcc-4.1.2/temp/build.log'.
 [31;01m*[0m The ebuild environment file is located at '/var/tmp/portage/sys-devel/gcc-4.1.2/temp/environment'.
 [31;01m*[0m 

Portage 2.1.6.7 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r1-first i686)
=================================================================
System uname: Linux-2.6.29-gentoo-r1-first-i686-Intel-R-_Pentium-R-_4_CPU_3.06GHz-with-glibc2.0
Timestamp of tree: Fri, 17 Apr 2009 10:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -msse2 -mfpmath=sse -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -msse2 -mfpmath=sse -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa apache2 avahi bash-completion berkdb branding bzip2 cairo cdda cddb cdr cleartype cli consolekit cracklib crypt css cups dbus djvu dri dts dvd dvdr dvdread dvi emboss encode evo exif fam ffmpeg firefox flac foomaticdb fortran gdbm gif gimp glitz gmail gnome gnome-keyring gpm gstreamer gtk hal iconv imap ipod ipv6 isdnlog java jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kpathsea latex libnotify lzma mad mbox midi mikmod mmx mmxext mono mp3 mpeg mudflap musepack musicbrainz nautilus ncurses network network-cron nls nptl nptlonly ogg opengl openmp pam pch pcre pdf perl png pop ppds pppd python qt3 qt3support qt4 quicktime raw readline reflection sdl session smp spell spl sse sse2 ssl startup-notification svg sysfs t1lib tcpd theora tiff truetype unicode usb vcd vorbis win32codecs x86 xcomposite xml xmp xorg xulrunner xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2009-04-19 16:47:46 UTC
Created attachment 188895 [details]
build.log
Comment 2 Pacho Ramos gentoo-dev 2009-04-19 16:51:21 UTC
Previous emerge --info is wrong ( I don't know where is getting that info when I run "emerge --info" as "pacho" instead of "root" user):
Portage 2.1.6.7 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r1-first i686)
=================================================================
System uname: Linux-2.6.29-gentoo-r1-first-i686-Intel-R-_Pentium-R-_4_CPU_3.06GHz-with-glibc2.0
Timestamp of tree: Fri, 17 Apr 2009 10:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa apache2 avahi bash-completion berkdb branding bzip2 cairo cdda cddb cdr cleartype cli consolekit cracklib crypt css cups dbus djvu dri dts dvd dvdr dvdread dvi emboss encode evo exif fam ffmpeg firefox flac foomaticdb fortran gdbm gif gimp glitz gmail gnome gnome-keyring gpm gstreamer gtk hal iconv imap ipod ipv6 isdnlog java jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kpathsea latex libnotify lzma mad mbox midi mikmod mmx mmxext mono mp3 mpeg mudflap musepack musicbrainz nautilus ncurses network network-cron nls nptl nptlonly ogg opengl openmp pam pch pcre pdf perl png pop ppds pppd python qt3 qt3support qt4 quicktime raw readline reflection sdl session smp spell spl sse sse2 ssl startup-notification svg sysfs t1lib tcpd theora tiff truetype unicode usb vcd vorbis win32codecs x86 xcomposite xml xmp xorg xulrunner xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 3 Sebastian Luther (few) 2009-04-19 21:07:34 UTC
When you emerge gcc-4.1 then gcc-4.1 gets first compiled by gcc-4.3. When this is done gcc-4.1 gets compiled again, but this time by the gcc-4.1 compiled in the first step. Since gcc-4.1 does not support -march=native it breaks. There is not much that can be done about that, except filtering -march=native out of CFLAGS in the gcc-4.1 ebuild.
Comment 4 Göktürk Yüksek gentoo-dev 2009-04-20 12:11:38 UTC
Well, you cannot do this because those flags differ between versions of gcc. As you can see you get the error when gcc-4.1.2/work/build/gcc/../ld, i mean "ld" of gcc-4.1.2 is called. Please try to set your -march and -mtune as "i686" before you emerge and you will be fine.
Comment 5 Pacho Ramos gentoo-dev 2009-04-20 16:55:52 UTC
Yes, I know that it seems to be due gcc-4.1 being used for compiling itself, but I thought there would be a "possible" solution, but, if not, feel free to close this as CANTFIX of course
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-22 21:58:29 UTC
It's up to you to choose C(XX)FLAGS which work with the compiler you are trying to install/use. So there really isn't much we can do on the ebuild side. 
Imagine we would try to filter out any newer *FLAGS in older gcc-ebuilds which they don't know of. That would become a real PITA to maintain.
Comment 7 Pacho Ramos gentoo-dev 2009-04-23 06:07:50 UTC
OK