Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 26650 - genkernel - "Kernel panic: Attempted to kill init!" after USB probing
Summary: genkernel - "Kernel panic: Attempted to kill init!" after USB probing
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: Daniel Robbins (RETIRED)
Depends on:
Reported: 2003-08-14 17:50 UTC by Emil Flink
Modified: 2004-01-18 13:39 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

/etc/kernels/config-2.4.22-gentoo-test-r0 (config-2.4.22-gentoo-test-r0,27.32 KB, text/plain)
2003-10-15 13:46 UTC, Mikael A

Note You need to log in before you can comment on or make changes to this bug.
Description Emil Flink 2003-08-14 17:50:03 UTC
When I try to boot after the install I get this error "Kernel panic: Attempted 
to kill init" This error occurs at the end of the USB check/install/whatever at 
the first boot after the install..

Ignore the line below..


Reproducible: Always
Steps to Reproduce:



Expected Results:  
Worked fine (letting me into Gentoo)
Comment 1 SpanKY gentoo-dev 2003-08-15 14:34:28 UTC
what kernel did you use ? we cant debug your problem w/out any information 
Comment 2 Emil Flink 2003-08-16 11:30:42 UTC
I use the gentoo kernel.
Comment 3 David Goodlad 2003-08-16 11:52:12 UTC
I have encountered the same issue.  Using genkernel 1.4 to build gentoo-sources (kernel-2.4.20-gentoo-r5), it builds perfectly.  I then add the image to LILO using the procedure described both in the install.html and genkernel's README file.  Upon a reboot, it finishes the usb-detection with finding usb storage hardware, then gives the "Kernel panic: attempted to kill init!" with my caps and scroll lock lights blinking on the kb.

My system is a Shuttle SN41G2; shuttle nforce2-based mobo, using the on-board video/audio/net etc.
Comment 4 Emil Flink 2003-08-16 14:04:25 UTC
That is exactly the same situation as I get!

Though I dont got nForce mobo..
Would be great if someone could come up with an solution..
Comment 5 David Goodlad 2003-08-17 15:11:55 UTC
See for more info; I have not tried this myself to verify that it fixes this problem.  I was able to get around it by removing the append= and initrd= lines from lilo.conf completely.
Comment 6 bob 2003-09-01 09:50:25 UTC
Same problem here.  Architecture athlon.  Followed install guide exactly, did emerge of hotplug, genkernel on gentoo-sources.  Plugged provided names into lilo.  On reboot - ended up with kernel panic "attempted to kill init" and flashing numlock and capslock lights.   There are large numbers of people reporting this problem, which seems to have something to do with the append = line in lilo.conf. Changing the initrd to /dev/hdax  rather than /dev/ram0 seems to help some people, but kind of defeats the whole purpose of using an initrd and doing hotplug detection, doesn't it?
Comment 7 Robert Moss (RETIRED) gentoo-dev 2003-09-04 15:17:24 UTC
Can you please post your /usr/src/linux/.config ? Things tend to get fixed much faster if we can see that.
Comment 8 Adam Comerford 2003-09-04 17:19:53 UTC
I also run Gentoo 1.4 on a Shuttle SN41G2 and I was getting the Kernel Panic following the USB detect section also.

I removed the root=/dev/ram0 part of the append line in lilo.conf and it booted without an issue - seems the RAM problems listed in the docs with GRUB may be coming into play here on the nForce 2 chipset.

I'll post the .config as soon as I get the system up on its feet :)
Comment 9 Daniel Robbins (RETIRED) gentoo-dev 2003-09-04 18:20:42 UTC
Sven, have we resolved this?
Comment 10 Robert Moss (RETIRED) gentoo-dev 2003-09-04 18:25:34 UTC
I know I'm not Sven, but - we have a workaround rather than a fix. The USB autodetection causes a kernel panic when you use a RAM disk, although quite why we aren't sure. Using the gs-sources appears to fix this too. I'm toying with the idea of putting an entire Gentoo Linux installation on one of those USB key thingies, so this could well be an issue for me (which is why I'm particularly interested...!).
Comment 11 Daniel Robbins (RETIRED) gentoo-dev 2003-09-04 19:24:20 UTC
OK, this sounds like another "Gentoo-sources is out of date and our users are suffering" issue. Assigning to pfeifer.
Comment 12 Sergey Starosek 2003-09-06 05:36:18 UTC
the same for me. failed to boot with kernel generated by genkernel on gentoo-sources using lilo. installing kernel by hands (make menuconfig, ..., make bzImage and copying it to /boot worked fine). System is Intel Celeron 1.7 GHz with 845 chipset.
Comment 13 Mikael A 2003-10-15 13:45:05 UTC
I'm not sure if it's related to usb autodetection. I've tried running with
nousb as kernel argument and i still get this error.

I've tried with gentoo-2.4.20-r7 and gentoo-test-2.4.22-r0.

If somebody is interested in solving this bug I'll try to be of as good help
as possible. I'll attach my .config below.
Comment 14 Mikael A 2003-10-15 13:46:34 UTC
Created attachment 19274 [details]

This is my config file as it was saved by genkernel.
Comment 15 David Henderson 2003-11-24 16:37:07 UTC

This happens on the amd64 beta liveCD (kernel 2.6).
and on ALL gentoo-dev-sources built with that config.
(and modified configs with ps2 keyboard/mouse drivers excluded).

Workaround was to DISABLE "legacy" USB support
side effect : cant use USB keyboard to nagigate grub menu
Comment 16 Tim Yamin (RETIRED) gentoo-dev 2003-12-12 15:15:10 UTC
I've seen similar errors when using ck-sources for example, when generated with genkernel, and it would work with a hand compile, thus I don't see this as a kernel bug: I can confirm that using a hand-compiled kernel seems to work and comment #12 does as well. Can other folks confirm this?

Reassigning to Daniel as this seems to be something with the initrd voodoo going bad.
Comment 17 Brad House 2004-01-18 13:39:12 UTC
use genkernel 3.x closing