Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 266071 - media-sound/amarok-2.0.2-r1 doesn't find any music (empty collection)
Summary: media-sound/amarok-2.0.2-r1 doesn't find any music (empty collection)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major with 3 votes (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-14 05:20 UTC by Mark Nowiasz
Modified: 2009-04-23 11:43 UTC (History)
29 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emergeinfo,3.79 KB, text/plain)
2009-04-16 15:02 UTC, Vasco Figueira
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Nowiasz 2009-04-14 05:20:57 UTC
After updating to amarok-2.0.2-r1 (from 1.4; 2.0.2-r1 seems to be unmasked for amd64 now) amarok 2 now starts, but doesn't do any good:

None of my local collection is being displayed, rescanning the collection (or importing it from 1.4) doesn't do any good - I've got still an empty collection. Apparently, amarok 2 is still not working on amd64 and should be masked again.

Reproducible: Always

Steps to Reproduce:
1. update to 2.0.2-r1
2.
3.

Actual Results:  
No music found.


spectre ~ # emerge --info
Portage 2.2_rc30 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r1 x86_64)                                                                 
=================================================================                    
System uname: Linux-2.6.29-gentoo-r1-x86_64-AMD_Phenom-tm-_9950_Quad-Core_Processor-with-gentoo-2.0.0                                                                     
Timestamp of tree: Tue, 14 Apr 2009 04:15:01 +0000                                   
ccache version 2.4 [enabled]                                                         
app-shells/bash:     4.0_p17-r1                                                      
dev-java/java-config: 1.3.7-r1, 2.1.7                                                
dev-lang/python:     2.5.4-r2, 2.6.1-r1                                              
dev-util/ccache:     2.4-r8                                                          
dev-util/cmake:      2.6.3-r1                                                        
sys-apps/baselayout: 2.0.0                                                           
sys-apps/openrc:     0.4.3-r1                                                        
sys-apps/sandbox:    1.9                                                             
sys-devel/autoconf:  2.13, 2.63-r1                                                   
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                       
sys-devel/binutils:  2.19.1-r1                                                       
sys-devel/gcc-config: 1.4.1                                                          
sys-devel/libtool:   2.2.6a                                                          
virtual/os-headers:  2.6.28-r1                                                       
ACCEPT_KEYWORDS="amd64 ~amd64"                                                       
CBUILD="x86_64-pc-linux-gnu"                                                         
CFLAGS="-march=amdfam10 -O2 -pipe"                                                   
CHOST="x86_64-pc-linux-gnu"                                                          
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"                                                  
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                       
CXXFLAGS="-O2 -pipe"                                                                 
DISTDIR="/usr/portage/distfiles"                                                     
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                       
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gentoo.mneisen.org/ http://de-mirror.org/distro/gentoo/ ftp://de-mirror.org/distro/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://mirror.jamit.de/gentoo/ http://mirror.netcologne.de/gentoo/ ftp://mirror.netcologne.de/gentoo/ "                                                                        
LANG="de_DE.utf8"                                                                    
LDFLAGS="-Wl,-O1"                                                                    
LINGUAS="de"                                                                         
MAKEOPTS="-j5"                                                                       
PKGDIR="/usr/portage/packages"                                                       
PORTAGE_CONFIGROOT="/"                                                               
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                 
PORTAGE_TMPDIR="/var/tmp"                                                            
PORTDIR="/usr/portage"                                                               
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"                                
USE="3dnow X a52 aac aalib acl acpi aim alsa amd64 apache2 audiofile bash-completion bcmath bluetooth branding bzip2 cairo calendar cddb cdparanoia cdr cli cracklib crypt cscope css ctype cups curl cxx dbus djvu dri dts dv dvb dvd dvdr dvdread encode enscript exif expat fam ffmpeg fftw firefox flac fontconfig foomaticdb fortran ftp gd gdbm geoip gif gimp glib glut gmp gnuplot gnutls gpg gphoto2 gpm gps graphviz gsl gtk gzip hal hddtemp htmlhandbook iconv icq icu idn imagemagick imap imlib innodb isdnlog jabber java java6 javascript jbig jingle jpeg jpeg2k kde kontact kpathsea lame lash latex lcms ldap libcaca libnotify libsamplerate libwww lm_sensors lua lzo mad maildir mailwrapper matroska mhash midi mime mmap mmx mng modplug mp2 mp3 mp4 mpeg mpi mplayer msn mudflap multilib musepack musicbrainz mysql mysqli ncurses netcdf nls nntp nptlnptlonly nsplugin nvram offensive ofx ogg openal openexr opengl openmp oscar pam pcntl pcre pda pdf perl php plasma png posix postgres ppds pppd python qt3 qt4 quicktimeraw rdesktop readline recode reflection rss samba sasl sdl session sharedext sharedmem shorten slang smp sndfile snmp soap sockets sox speex spell spl sse sse2 ssl startup-notification subversion suid svg sysfs syslog sysvipc szip taglib tcpd theora threads tidy tiff timidity tokenizer truetype unicode usb v4l2 vcd videos vim-syntax vnc vorbis wavpack webdav webkit wlm wmf x264 xattr xface xft xine xml xorg xpm xscreensaver xsl xulrunner xv xvid xvmc yahoo yaz zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Pierrot Rey 2009-04-14 06:46:43 UTC
The same bug for me, if I compile with kdeprefix it works.
Comment 2 Mikko C. 2009-04-14 16:45:00 UTC
Have you updated mysql recently?
If so, try downgrading. It solves the issue for me.
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-04-15 06:20:17 UTC
Please make sure you have the tree (and if you use it the overlay) synced and try emerging again mysql-5.0.76-r1 or mysql-community-5.0.77-r1 and then amarok-2.0.2-r1
Comment 4 shade 2009-04-15 06:40:00 UTC
For me helped changing ldflags, like advised on irc. Collection started to work and inporting it.
Comment 5 Tobias Leupold 2009-04-15 11:02:06 UTC
Same problem with Amarok 2.0.90. amarok --debug prints out hundreds of errors saying

amarok:                  [ERROR!] GREPME MySQLe query failed! No database selected  on ...


Putting the following in /etc/portage/package.ldflags

~dev-db/mysql-5.0.76 -as-needed

(as proposed by shade) did not change anything.


Here's my emerge --info:

Portage 2.2_rc28 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28.7 x86_64)
=================================================================                                        
System uname: Linux-2.6.28.7-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-glibc2.2.5           
Timestamp of tree: Wed, 15 Apr 2009 07:30:01 +0000                                                       
app-shells/bash:     3.2_p39                                                                             
dev-java/java-config: 2.1.7                                                                              
dev-lang/python:     2.5.2-r7, 3.0-r1                                                                    
dev-util/cmake:      2.6.2-r1                                                                            
sys-apps/baselayout: 2.0.0                                                                               
sys-apps/openrc:     0.4.3-r1                                                                            
sys-apps/sandbox:    1.3.4                                                                               
sys-devel/autoconf:  2.13, 2.63                                                                          
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                                
sys-devel/binutils:  2.18-r3                                                                             
sys-devel/gcc-config: 1.4.0-r4                                                                           
sys-devel/libtool:   1.5.26                                                                              
virtual/os-headers:  2.6.27-r2                                                                           
ACCEPT_KEYWORDS="amd64"                                                                                  
CBUILD="x86_64-pc-linux-gnu"                                                                             
CFLAGS="-march=core2 -O2 -pipe -msse4.1"                                                                 
CHOST="x86_64-pc-linux-gnu"                                                                              
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config" 
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                                                                                                              
CXXFLAGS="-march=core2 -O2 -pipe -msse4.1"                                                                                
DISTDIR="/usr/src/distfiles"                                                                                              
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="        http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/      http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ "
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage/tree"
PORTDIR_OVERLAY="/var/portage/layman/x11 /var/portage/layman/kde-testing /var/portage/local /var/portage/experimental"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dridvd dvdr dvdread eds emboss encode esd evo fam firefox flac fortran gdbm gif gpm gtk hal iconv ipv6 isdnlog jpeg kde ldaplibnotify lm_sensors mad midi mikmod mmx mng mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl semantic-desktop session spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd theora tiff truetype unicode usb vim-syntax vorbis wmf xine xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbmauthn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 6 Tobias Leupold 2009-04-15 11:12:00 UTC
Ps: compiling Amarok itself with the --as-needed flag (I think this was what shade proposed) also does not solve the problem.
Comment 7 Rick Harris 2009-04-15 11:29:27 UTC
Can also confirm Mikko C.'s findings for amarok-2.0.90...

mysql-5.0.70-r1 works with amarok-2.0.90
mysql-5.0.76 fails with amarok-2.0.90 resulting in an empty music collection and the message that amarok is 'Counting'.

Not tested with mysql-5.0.72.
Comment 8 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-04-15 12:11:35 UTC
(In reply to comment #7)
> Can also confirm Mikko C.'s findings for amarok-2.0.90...
> 
> mysql-5.0.70-r1 works with amarok-2.0.90
> mysql-5.0.76 fails with amarok-2.0.90 resulting in an empty music collection
> and the message that amarok is 'Counting'.
> 
> Not tested with mysql-5.0.72.

As I've stated in my comment above, mysql-5.0.76-r1 or mysql-community-5.0.77-r1 are *required* for amarok on amd64. I've adjusted the deps in amarok-2.0.2-r1.
Comment 9 Matt Whitlock 2009-04-15 12:15:21 UTC
(In reply to comment #8)
> As I've stated in my comment above, mysql-5.0.76-r1 or
> mysql-community-5.0.77-r1 are *required* for amarok on amd64.

amarok-2.0.2-r1 still has the same problems even with mysql-5.0.76-r1.
Comment 10 Julen Landa 2009-04-15 13:15:00 UTC
Same problem with amarok-9999 from kde-testing. I fixed the problem downgrading mysql to 5.0.76 and editing amarok-9999.ebuild to change dependency from 5.0.76-r1 to 5.0.76.

mysql-community-5.0.77-r1 has the same problem, I haven't test with 5.0.77
Comment 11 Mikko C. 2009-04-15 13:20:41 UTC
(In reply to comment #8)
> 
> As I've stated in my comment above, mysql-5.0.76-r1 or
> mysql-community-5.0.77-r1 are *required* for amarok on amd64. I've adjusted the
> deps in amarok-2.0.2-r1.
> 

The problem is that for some of us, those specific versions have collateral effects. They make amarok compile on amd64 without the -fPIC hack, but they also make amarok unusable. The downgrade is just a workaround.
And fyi, I did upgrade to x11-misc/xdg-utils-1.0.2-r3, recompile kdelibs, kdebase-startkde, amarok --as-needed... Still no go :( 
Comment 12 Gustavo Henrique Nihei 2009-04-15 13:45:48 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Can also confirm Mikko C.'s findings for amarok-2.0.90...
> > 
> > mysql-5.0.70-r1 works with amarok-2.0.90
> > mysql-5.0.76 fails with amarok-2.0.90 resulting in an empty music collection
> > and the message that amarok is 'Counting'.
> > 
> > Not tested with mysql-5.0.72.
> 
> As I've stated in my comment above, mysql-5.0.76-r1 or
> mysql-community-5.0.77-r1 are *required* for amarok on amd64. I've adjusted the
> deps in amarok-2.0.2-r1.
> 

I unmerged amarok, and tried to reemerge it, but now portage reports the following error:

Calculating dependencies /

!!! Invalid or corrupt dependency specification:

invalid atom: '>=dev-db/mysql-5.0-76-r1[embedded,-minimal]'

('ebuild', '/', 'media-sound/amarok-2.0.2-r1', 'merge')

!media-sound/amarok:0 >=app-misc/strigi-0.5.7 || ( >=dev-db/mysql-5.0-76-r1[embedded,-minimal] >=dev-db/mysql-community-5.0.77-r1[embedded,-minimal] ) >=media-libs/taglib-1.5 >=kde-base/kdelibs-4.2[opengl?,semantic-desktop?] >=kde-base/phonon-kde-4.2 >=kde-base/plasma-workspace-4.2 x11-libs/qtscriptgenerator cdaudio? ( >=kde-base/libkcompactdisc-4.2 >=kde-base/libkcddb-4.2 ) ifp? ( media-libs/libifp ) ipod? ( >=media-libs/libgpod-0.7.0 ) mp3tunes? ( dev-libs/libxml2 dev-libs/openssl net-libs/loudmouth net-misc/curl ) mp4? ( media-libs/libmp4v2 ) mtp? ( >=media-libs/libmtp-0.3.0 ) njb? ( >=media-libs/libnjb-2.2.4 ) >=dev-util/cmake-2.6.2-r1 userland_GNU? ( >=sys-apps/findutils-4.4.0 ) >=dev-util/cmake-2.6.2 dev-util/pkgconfig >=sys-apps/sandbox-1.3.2 opengl? ( x11-libs/qt-opengl:4 ) dev-lang/perl x11-libs/libXext x11-libs/libXt x11-libs/libXxf86vm x11-libs/qt-core:4[qt3support,ssl] x11-libs/qt-gui:4[accessibility,dbus] x11-libs/qt-qt3support:4[accessibility] x11-libs/qt-script:4 x11-libs/qt-sql:4[qt3support] x11-libs/qt-svg:4 x11-libs/qt-test:4 >=kde-base/kdelibs-4.2

This package can not be installed. Please notify the 'media-
sound/amarok-2.0.2-r1' package maintainer about this problem.
... done!

dev-db/mysql-5.0.76-r1 is already installed with the "embedded" USE flag and without the "minimal" flag.
Comment 13 Mark Nowiasz 2009-04-15 14:47:38 UTC
(In reply to comment #12)

> Calculating dependencies /
> 
> !!! Invalid or corrupt dependency specification:
> 
> invalid atom: '>=dev-db/mysql-5.0-76-r1[embedded,-minimal]'

I've got a similar problem:

emerge -up --deep @world @system                

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=dev-db/mysql-5.0-76-r1[embedded,-minimal]".                                                                          
(dependency required by "media-sound/amarok-2.0.2-r1" [installed])              
(dependency required by "@world" [argument])                  

BTW @jmb (#8), I've got mysql 5.0.76-r1 installed (in fact, it was updated  before amarok), with the required flags:

pectre ~ # equery uses mysql
[ Searching for packages matching mysql... ]
[ Colour Code : set unset ]                 
[ Legend : Left column  (U) - USE flags from make.conf              ]
[        : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for dev-db/mysql-5.0.76-r1 ]             
 U I                                                                 
 - - berkdb      : Adds support for sys-libs/db (Berkeley DB for MySQL)
 - - big-tables  : Make tables contain up to 1.844E+19 rows            
 - - cluster     : Add support for NDB clustering                      
 - - debug       : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml                                                                    
 + + embedded    : Build embedded server (libmysqld)                            
 - - extraengine : Add support for alternative storage engines                  
 - - latin1      : Use LATIN1 encoding instead of UTF8                          
 - - max-idx-128 : Raise the max index per table limit from 64 to 128           
 - - minimal     : Install a very minimal build (disables, for example, plugins, fonts, most drivers, non-critical features)                                    
 + + perl        : Adds support/bindings for the Perl language                  
 - - selinux     : !!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur                        
 + + ssl         : Adds support for Secure Socket Layer connections             
 - - static      : !!do not set this during bootstrap!! Causes binaries to be statically linked instead of dynamically                                        

But it doesn't work (at stated in my initial bug report) at all.
Comment 14 Rafał Mużyło 2009-04-15 15:30:48 UTC
As it would shortly shortly be stated,
there was a typo in the ebuild:
>=dev-db/mysql-5.0-76-r1[embedded,-minimal]
should have been:
>=dev-db/mysql-5.0.76-r1[embedded,-minimal]
Resync (or fix typo, fix manifest).
Comment 15 Mark Nowiasz 2009-04-15 15:55:53 UTC
(In reply to comment #14)
> Resync (or fix typo, fix manifest).

Very well: after emerge --sync plus emerge -1 mysql amarok, amarok still shows the same symptoms.

amarok -debug shows:

[..]
amarok: BEGIN: void CollectionManager::checkCollectionChanges()
amarok: BEGIN: void ScanManager::startIncrementalScan()
amarok: BEGIN: QStringList ScanManager::getDirsToScan() const
amarok:        [ERROR!] GREPME MySQLe query failed! No database selected  on  "SELECT id, deviceid, dir, changedate FROM directories WHERE deviceid IN (-1);"
amarok: END__: QStringList ScanManager::getDirsToScan() const - Took 0.00016s
amarok:      GOING TO SCAN:
amarok:      Scanning nothing, return.
[..]

Right now, amarok 2 is next to useless on amd64 - well, true, it can play radiostreams, but the collection just doesn't work.

Comment 16 Rick Harris 2009-04-15 18:51:18 UTC
So if amarok needs mysql-5.0.76 to compile on amd64, but amarok's collection is then rendered unuseable by this, then shouldn't amarok be masked for amd64 for the time being until a proper fix can be implemented.

Either that or at the very least have the ebuild check for the ~arch being used and only depend on the unstable mysql if using amd64 as the dependency on mysql-5.0.76 also has the effect of breaking amarok's collection for x86.
Comment 17 Berend Dekens 2009-04-16 00:28:56 UTC
(In reply to comment #16)
> So if amarok needs mysql-5.0.76 to compile on amd64, but amarok's collection is
> then rendered unuseable by this, then shouldn't amarok be masked for amd64 for
> the time being until a proper fix can be implemented.

After downgrading mysql to 5.0.70, the library starts working again. This looks like a compatibility problem.

Also, I am using amd64 with Amarok 2 for months now, no problems whatsoever.

I've tested my plugins, library and shoutcast - everything is working again with 2.0.2-r1, the qt4.5 patch and on amd64.
Comment 18 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-04-16 00:45:30 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > So if amarok needs mysql-5.0.76 to compile on amd64, but amarok's collection is
> > then rendered unuseable by this, then shouldn't amarok be masked for amd64 for
> > the time being until a proper fix can be implemented.
> 
> After downgrading mysql to 5.0.70, the library starts working again. This looks
> like a compatibility problem.
> 
> Also, I am using amd64 with Amarok 2 for months now, no problems whatsoever.
> 
> I've tested my plugins, library and shoutcast - everything is working again
> with 2.0.2-r1, the qt4.5 patch and on amd64.

The only way you may have been able to use amarok-2 with amd64 (after the mysqle hard dep) was if you were using the -fPIC hack. If you still have that, please remove it.
Comment 19 Kevin Bowling 2009-04-16 01:46:58 UTC
Broken collection, same as others describe, with mysql-5.0.76-r1 no -fpic or with.  Rebuild amarok and amarok-utils each time.

Works fine with 5.0.70 -fpic.
Comment 20 Marijn Schouten (RETIRED) gentoo-dev 2009-04-16 09:31:04 UTC
No collection for me either:

[I] media-sound/amarok
     Available versions:
        (0)     1.4.10-r2 (~)1.4.10-r3 (~)1.4.10_p20090130-r1
        (2)     ~*2.0.1.1 (~)2.0.2-r1
        {amazon cdaudio daap debug elibc_FreeBSD ifp ipod kde linguas_af linguas_ar linguas_az linguas_be linguas_bg linguas_bn linguas_br linguas_ca linguas_cs linguas_csb linguas_cy linguas_da linguas_de linguas_el linguas_en_GB linguas_eo linguas_es linguas_et linguas_eu linguas_fa linguas_fi linguas_fr linguas_ga linguas_gl linguas_he linguas_hi linguas_hu linguas_id linguas_is linguas_it linguas_ja linguas_km linguas_ko linguas_ku linguas_lo linguas_lt linguas_lv linguas_mk linguas_ms linguas_nb linguas_nds linguas_ne linguas_nl linguas_nn linguas_oc linguas_pa linguas_pl linguas_pt linguas_pt_BR linguas_ro linguas_ru linguas_rw linguas_se linguas_si linguas_sk linguas_sl linguas_sq linguas_sr linguas_sr@Latn linguas_ss linguas_sv linguas_ta linguas_tg linguas_th linguas_tr linguas_uk linguas_uz linguas_zh_CN linguas_zh_TW mp3tunes mp4 mtp musicbrainz mysql njb opengl postgres python real semantic-desktop visualization xinerama}
     Installed versions:  2.0.2-r1(2)(18:17:31 15-04-09)(linguas_nl opengl semantic-desktop -cdaudio -daap -debug -ifp -ipod -linguas_ar -linguas_be -linguas_bg -linguas_ca -linguas_cs -linguas_csb -linguas_da -linguas_de -linguas_el -linguas_eo -linguas_es -linguas_et -linguas_eu -linguas_fi -linguas_fr -linguas_ga -linguas_gl -linguas_he -linguas_is -linguas_it -linguas_ja -linguas_km -linguas_ko -linguas_ku -linguas_lt -linguas_lv -linguas_nb -linguas_nds -linguas_ne -linguas_nn -linguas_oc -linguas_pa -linguas_pl -linguas_pt -linguas_pt_BR -linguas_ro -linguas_ru -linguas_se -linguas_si -linguas_sk -linguas_sl -linguas_sv -linguas_th -linguas_tr -linguas_uk -linguas_zh_CN -linguas_zh_TW -mp3tunes -mp4 -mtp -njb)
     Homepage:            http://amarok.kde.org/
     Description:         Advanced audio player based on KDE framework.

* media-sound/amarokfs
     Available versions:  0.5
     Homepage:            http://www.kde-apps.org/content/show.php?content=52641
     Description:         A full screen frontend for Amarok.

Found 5 matches.
marijn@hakbak ~ $ eix -e mysql
[I] dev-db/mysql
     Available versions:  [M]*3.23.58-r1 4.0.27-r1 4.1.22-r1 5.0.26-r2 (~)5.0.32 (~)5.0.34 5.0.38 5.0.40 5.0.42 (~)5.0.44 5.0.44-r1 5.0.44-r2 5.0.54 (~)5.0.56 (~)5.0.60 5.0.60-r1 5.0.70 5.0.70-r1 (~)5.0.72 (~)5.0.72-r1 (~)5.0.76 (~)5.0.76-r1 {berkdb big-tables cluster debug embedded extraengine innodb latin1 max-idx-128 minimal perl raid readline selinux ssl static tcpd}
     Installed versions:  5.0.76-r1(13:43:47 14-04-09)(berkdb embedded perl ssl -big-tables -cluster -debug -extraengine -latin1 -max-idx-128 -minimal -selinux -static)
     Homepage:            http://www.mysql.com/
     Description:         A fast, multi-threaded, multi-user SQL database server.

[I] virtual/mysql
     Available versions:  4.0 4.1 5.0 [M](~)5.1
     Installed versions:  5.0(13:02:15 13-08-07)
     Homepage:            http://dev.mysql.com
     Description:         Virtual for MySQL client or database

Found 2 matches.

Portage 2.1.6.11 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.26-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.26-gentoo-r1-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.0.0
Timestamp of tree: Wed, 15 Apr 2009 12:00:05 +0000
app-shells/bash:     3.2_p48-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.1-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.3-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect cvs distlocks fixpackages parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en nl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/nouveau /home/marijn/git/gentoo-lisp-overlay /home/marijn/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dts dvd dvdr dvdread eds emacs emboss encode esd evo fam firefox flac fortran gdbm gif gmp gpm gstreamer gtk hal history iconv ipv6 isdnlog jpeg kde kpathsea ldap libnotify lm_sensors mad metric midi mikmod mmx mng mp3 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nvidia offensive ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sasl sdl session smp speex spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora threads tiff truetype unicode usb vorbis webkit xineramaxml xorg xpm xulrunner xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc"INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en nl" USERLAND="GNU" VIDEO_CARDS="fbdev nouveau nv nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 21 Metin Akat 2009-04-16 09:50:38 UTC
(In reply to comment #19)
> Broken collection, same as others describe, with mysql-5.0.76-r1 no -fpic or
> with.  Rebuild amarok and amarok-utils each time.
> 
> Works fine with 5.0.70 -fpic.
> 

Absolutely the same here
Comment 22 Mikko C. 2009-04-16 11:13:42 UTC
Compiling mysql-community with debug provides one more line before the crash:

InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
090416 13:10:52  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
amarok:              Connected to MySQL server 5.0.77-embedded-debug
amarok:              Initialized thread, count== 1
safe_mutex: Trying to lock unitialized mutex at mi_open.c, line 107
<unknown program name>(25231)/: Communication problem with  "amarok" , it probably crashed.

Some other times the line is slightly:
safe_mutex: Trying to lock unitialized mutex at hp_open.c, line 31

googling that didn't really help.
Comment 23 Vasco Figueira 2009-04-16 15:02:23 UTC
Created attachment 188584 [details]
emerge --info
Comment 24 Vasco Figueira 2009-04-16 15:03:33 UTC
I have exact same symptoms on i686. Doesn't look like amd64 specific.

Collection appears with
mysql-5.0.70-r1 (x86)
amarok-2.0.1.1  (~x86 but not latest).

Collection not visible with
mysql-5.0.76-r1 and amarok-2.0.2-r1 (both ~x86).
Comment 25 Guillaume Castagnino 2009-04-16 17:10:01 UTC
Here I have on ~x86 :

Collection not visible with
mysql-5.0.76-r1 and amarok-2.0.2-r1 compiled against mysql-5.0.76-r1

Collection visible with
mysql-5.0.76 and amarok-2.0.2-r1 recompiled against mysql-5.0.76


Seems that the problem is the heavy patch introduced in 5.0.76-r1
Comment 26 Rob 2009-04-16 20:12:36 UTC
2.0.90 in the kde-testing overlay has the same issue as well, so it's not getting fixed just by going to the next release (it has also been stated 9999 has this issue though).
Comment 27 David Carlos Manuelda 2009-04-17 15:14:58 UTC
I prefer doing the -fPIC hack rather than dropping keyword *while* a proper fix is being finding...
Amarok is not useless anyway, you can still charge playlists, and music by hand, but yes, indeed it's missing its main function: manage music collection.
So I suggest removing the deb-db/mysql-5.0.76-r1 dep for now, and continue with the dirty -fPIC workarround, since, despite dirty, it works :)
Comment 28 Tobias Leupold 2009-04-17 16:11:08 UTC
(In reply to comment #27)

Could you please explain that dirty -fPIC hack so that I can get Amarok working?
Comment 29 David Carlos Manuelda 2009-04-17 16:16:09 UTC
It consists basicly in compiling mysql with -DPIC -fPIC in CFLAGS, but only this package (not any dep nor amarok itself) and it is not guaranteed to function well either but at least is another option for now..
Comment 30 Tobias Leupold 2009-04-17 19:20:52 UTC
Putting "dev-db/mysql -DPIC -fPIC" in /etc/portage/package.cflags and recompiling mysql did not change anything here. Still the same behaviour and the same "No database selected" errors from amarok --debug. Seems not to be a workaround, at least for amarok 2.0.90 ...
Comment 31 Mark Nowiasz 2009-04-17 19:28:16 UTC
(In reply to comment #29)
> It consists basicly in compiling mysql with -DPIC -fPIC in CFLAGS, but only
> this package (not any dep nor amarok itself) and it is not guaranteed to
> function well either but at least is another option for now..

But doing this might break mysql (or at least other packages depending on mysql). So it's not very safe to do so.

I suggest masking amarok again until the bug has been identified - I myself will locally mask amarok 2 again and revert back to 1.4 - at least this version is working perfectly well. 
Comment 32 Gen2 2009-04-17 20:22:56 UTC
(In reply to comment #30)
> Putting "dev-db/mysql -DPIC -fPIC" in /etc/portage/package.cflags and
> recompiling mysql did not change anything here. Still the same behaviour and
> the same "No database selected" errors from amarok --debug. Seems not to be a
> workaround, at least for amarok 2.0.90 ...
> 

I guess you tried to use mysql-5.0.76-r1, which is known not to work (just look at the other replies of this bugreport). It works perfectly here with mysql-5.0.70-r1 and-DPIC -fPIC though. Again this is just a workaround and should not be used but at the moment this seems the only way to get amarok-2 to work on amd64

Comment 33 Denis Pesotsky 2009-04-21 05:18:55 UTC
Same with live rebuild from kde-testing overlay
Comment 34 Mark Nowiasz 2009-04-22 05:17:54 UTC
Today, I've updtated to Amarok 2.0.2-r2, and it works fine :-) The collection is now working perfectly.

JMB, thank you very much for fixing this - finally I'm able to use Amarok2 on amd64 :-)

(Should this be closed now?)
Comment 35 Metin Akat 2009-04-22 08:03:06 UTC
r2 works for me too. Thanks
Comment 36 Arne Babenhauserheide 2009-04-22 08:19:28 UTC
-r2 works for me, too. 

Thank you very, very much! 

No more custom scripty mpd playlist playing - at last I have Amarok back! 
Comment 37 Raphaël Vinot 2009-04-22 08:44:06 UTC
it works with -9999 from kde-testing too ! Thanks !
Comment 38 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-04-23 11:43:45 UTC
I'm closing the amarok-2.0.2 bug reports as it seems to be finally working.
The 2.0.2 bump bug will stay open until I test the patch for lastfm.