Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 266068 - =gnome-base/gnome-settings-daemon-2.24.1-r1 crashing on startup
Summary: =gnome-base/gnome-settings-daemon-2.24.1-r1 crashing on startup
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-04-14 03:39 UTC by Josh Sled
Modified: 2010-03-28 19:32 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
g-s-d crash backtraces (gnome-settings-daemon-bugreport.txt,14.35 KB, text/plain)
2009-04-14 03:40 UTC, Josh Sled
Details
g-s-d crash backtrace, updated (gnome-settings-daemon-bugreport.txt,23.84 KB, text/plain)
2009-04-29 04:12 UTC, Josh Sled
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Sled 2009-04-14 03:39:48 UTC
Clean gentoo install into a VM, from stage3-i686-20090401.tar.bz2, and rebuilt through the xorg-server-1.5 and gnome-2.24 upgrades.

Starting gnome (via "exec gnome-session" in .xinitrc / `startx` results in a nearly-immediate dialog that "[gnome-settings-daemon] restarted too many times."  As per Bug#256016 and being on xorg-server-1.5, I've tried upgrading libxklavier to 3.8, with no change in behavior.

"Dynamic linking on [my] system is consistent."

When running gnome-settings-daemon from a terminal after clearing the aforementioned dialog, as such:

    # /usr/libexec/gnome-settings-daemon --debug --no-daemon

I get:

    ** (gnome-settings-daemon:30310): WARNING **: Failed to acquire org.gnome.SettingsDaemon

    ** (gnome-settings-daemon:30310): WARNING **: Could not acquire name
    ** (gnome-settings-daemon:30310): DEBUG: SettingsDaemon finished

After looking through some other google hits on this message, I can confirm my loopback interface is configured correctly.  Changing my ~/.xinitrc to be:

    exec dbus-launch gnome-session

prevents the crash from occurring immediately after `startx`, but leads to another crash a few seconds later, with backtraces as per the attached file.

Portage 2.1.6.7 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-i686-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4400+-with-glibc2.0
Timestamp of tree: Tue, 14 Apr 2009 01:45:03 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon64 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://91.121.125.139/gentoo-distfiles/ http://ftp.gentoo.bg/ ftp://trumpetti.atm.tut.fi/gentoo/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="3dnow X acl acpi alsa ao avahi bash-completion berkdb bzip2 cairo cli cracklib crypt cscope cups curl dbus debug dri emacs fam fortran gdbm gnome gpm gstreamer gtk gzip hal hddtemp iconv idn ipv6 isdnlog jabber jpeg lame midi mmx mudflap ncurses nls nptl nptlonly offensive openmp pam pcre perl png pppd python readline reflection session spell spl sqlite3 sse sse2 ssl sysfs syslog tcpd unicode usb x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Josh Sled 2009-04-14 03:40:14 UTC
Created attachment 188281 [details]
g-s-d crash backtraces
Comment 2 Josh Sled 2009-04-14 03:49:23 UTC
Also as per Bug#256016, here are the versions of maybe-relevant libs:

[I] gnome-base/gnome-settings-daemon (2.24.1-r1@04/13/09): Gnome Settings Daemon
[I] x11-libs/libXi (1.2.1@04/09/09): X.Org Xi library
[I] x11-libs/libxklavier (3.8@04/13/09): High level XKB library
[I] x11-proto/inputproto (1.5.0@04/08/09): X.Org Input protocol headers

Generating this, I noticed libxklavier was at 3.8, not 3.6 as I thought, so I downgraded; unfortunately, this had no effect on behavior.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-04-14 17:12:08 UTC
unfortunately it seems like your backtrace is missing a lot of symbols. Could you try with libxklavier 3.9 btw, changelog mentionned fixing crasher bugs.
Comment 4 walt 2009-04-18 20:28:11 UTC
I suffered Bug#256016 also, but no longer.  The big change, of course, was xorg-server-1.5.3, but I also (finally!) got evdev working at the same time and got completely rid of the 'mouse' and 'keyboard' drivers from my xorg.conf.

I just tried libxklavier-3.8 and 3.9 and everything works perfectly now on my x86 machine.

I see that your INPUT_DEVICES="evdev" but are you sure that your X server is not
still using the 'keyboard' driver by default?
Comment 5 Oleh Kravchenko 2009-04-23 13:48:57 UTC
I have the same bug :(
Comment 6 Oleh Kravchenko 2009-04-23 13:51:36 UTC
If help

gnome-base/gnome-2.24.1
x11-base/xorg-server-1.5.3-r5
x11-drivers/xf86-input-evdev-1.1.5-r1
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-04-23 14:01:43 UTC
please get back to us with informations from comment #3 & comment #4
Comment 8 Oleh Kravchenko 2009-04-23 14:54:45 UTC
(In reply to comment #4)
> I suffered Bug#256016 also, but no longer.  The big change, of course, was
> xorg-server-1.5.3, but I also (finally!) got evdev working at the same time and
> got completely rid of the 'mouse' and 'keyboard' drivers from my xorg.conf.
> 
> I just tried libxklavier-3.8 and 3.9 and everything works perfectly now on my
> x86 machine.
> 
> I see that your INPUT_DEVICES="evdev" but are you sure that your X server is
> not
> still using the 'keyboard' driver by default?
> 

$ ll /usr/lib/xorg/modules/input/
total 28K
-rwxr-xr-x 1 root root 28K Apr 14 17:55 evdev_drv.so
Comment 9 Rémi Cardona gentoo-dev 2009-04-27 12:18:19 UTC
You're using an old version of xf86-input-evdev. Please upgrade.

Thanks
Comment 10 Oleh Kravchenko 2009-04-28 15:29:40 UTC
(In reply to comment #9)
> You're using an old version of xf86-input-evdev. Please upgrade.
> 
> Thanks
> 

I am install =x11-drivers/xf86-input-evdev-2.1.3 USE="hal -debug"

bug still present :(
Comment 11 Josh Sled 2009-04-29 04:11:57 UTC
I'm seeing the same behavior with:
- x11-libs/libxklavier-3.9
- machine current through today (tree sync as of approx 2009-04-30T03:00:00-00:00)
- x11-drviers/xf86-input-evdev up to ~2.2.1

- root account with .xinitrc: "exec dbus-launch gnome-session":
  - no g-s-d crash on startup;
  - volume-control applet crashes on Log Out

- user account with .xinitrc: "exec gnome-session" or "exec dbus-launch gnome-session":
  - `startx` one:
    - indicated g-s-d crashing too much on startup.
    - volume-control applet crash on shutdown
  - `startx` two:
    - bug-buddy-trapped g-s-d crash on startup; report attached
Comment 12 Josh Sled 2009-04-29 04:12:30 UTC
Created attachment 189793 [details]
g-s-d crash backtrace, updated
Comment 13 Euler Taveira de Oliveira 2009-05-15 04:53:02 UTC
I had the same problem. It started to happen after I upgraded some gstreamer plugins. I solved the problem after downgrading gst-plugins-lame from 0.10.11 to 0.10.8.

Some packages:

gnome-base/gnome-2.24.1
gnome-base/gnome-settings-daemon-2.24.1-r1
media-plugins/gst-plugins-lame-0.10.8
Comment 14 Oleh Kravchenko 2009-05-15 07:00:33 UTC
(In reply to comment #13)
> I had the same problem. It started to happen after I upgraded some gstreamer
> plugins. I solved the problem after downgrading gst-plugins-lame from 0.10.11
> to 0.10.8.
> 
> Some packages:
> 
> gnome-base/gnome-2.24.1
> gnome-base/gnome-settings-daemon-2.24.1-r1
> media-plugins/gst-plugins-lame-0.10.8
> 

Very strange =) I don't have any version of media-plugins/gst-plugins-lame installed.

a@kravchenko ~ $ emerge media-plugins/gst-plugins-lame -p

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] media-plugins/gst-plugins-lame-0.10.11


Comment 15 Peter Waller 2009-05-24 17:18:26 UTC
I am experiencing the same bug, I think.

xklavier-3.6, evdev-2.1.3

Nothing unmasked.

I'm starting my gnome session with GDM, how would I go about finding why gnome-settings-daemon crashed? Do I have to make an xinitrc?
Comment 16 Noah Sheppard 2009-06-26 13:13:37 UTC
We've been having the same/similar problems at our university.

Those of you who are getting the "Failed to acquire org.gnome.SettingsDaemon" message when you run g-s-d with --no-daemon and --debug, have you checked to see that g-s-d is not already running?  From our testing, it appears that even though we get the dialog box about g-s-d restarting too many times, g-s-d is actually running.  Therefore, running it again "[fails] to acquire org.gnome.SettingsDaemon" because some other process (an alread-running g-s-d) has already acquired org.gnome.SettingsDaemon.  It's as if one thing in the whole X session startup process already has started g-s-d, but then something else is trying to start it again, and failing, because it can't get the org.gnome.SettingsDaemon resource (or whatever the correct term is).

We are unsure where to go from here in debugging.  Does anyone have any idea what starts g-s-d in the first place?

Thanks.
Comment 17 Noah Sheppard 2009-06-26 15:46:59 UTC
I retract my previous theory that gnome-session is trying to start g-s-d twice. At least, I think.

From comment #31 on bug #256016, older gnome-sessions (e.g. =gnome-session-2.22.1-r3, which is the stable one currently) do not start dbus properly.  We upgraded to =gnome-session-2.26.1, which fixes the problem, for us.  We are at stable versions (on amd64) of all other relevant packages (e.g., this is not the libxklavier problem of bug #256016; we are at =libxklavier-3.6).
Comment 18 Horst Prote 2009-10-13 13:25:13 UTC
(In reply to comment #17)
> From comment #31 on bug #256016, older gnome-sessions (e.g.
> =gnome-session-2.22.1-r3, which is the stable one currently) do not start dbus
> properly.
And in bug #256016 comment #31 walt writes
> So yes, it's a bug in gnome-session but the proper solution for gentoo is to
> change the startup scripts so apps like gnome-session don't *need* to do it.
We have kdm as display manager, most users use KDE sessions but some users with GNOME sessions. To start a special daemon (lbussd) needed for usb access on our thin clients I changed /usr/share/xsessions/gnome.desktop from 
  Exec=gnome-session
  TryExec=gnome-session
to (analogous to /usr/share/xsessions/kde-3.5.desktop)
  Exec=/etc/X11/Sessions/Gnome
  TryExec=/etc/X11/Sessions/Gnome
because /etc/X11/Sessions/Gnome (like /etc/X11/Sessions/kde-3.5) runs all system xinitrc shell scripts in /etc/X11/xinit/xinitrc.d/ where I placed the lbussd startup script. And as a side effect the error message of the GNOME Settings Daemon was gone: probably caused by /etc/X11/xinit/xinitrc.d/30-dbus.

So this seems to be at least another workaround. But I think all *.desktop files in /usr/share/xsessions/ should exec a script in /etc/X11/Sessions/ instead of some binary so one can easily add site-specific things in session startup.
Comment 19 Pacho Ramos gentoo-dev 2010-03-27 09:46:46 UTC
I don't suffer this problem at all with 2.26 and stable x11-libs/libxklavier-4.0
Comment 20 Gilles Dartiguelongue gentoo-dev 2010-03-28 19:32:21 UTC
please reopen if you can reproduce with current stable release. thanks.