Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 265188 - dev-java/antlr-2.7.7[mono]: jobserver unavailable
Summary: dev-java/antlr-2.7.7[mono]: jobserver unavailable
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Java team
Keywords: NeedPatch
Depends on:
Blocks: parallel-make
  Show dependency tree
Reported: 2009-04-06 23:02 UTC by Pacho Ramos
Modified: 2016-01-14 22:34 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,50.41 KB, text/plain)
2009-04-06 23:18 UTC, Peter Alfredsen (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2009-04-06 23:02:00 UTC
I get:
        make[4]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.

My emerge --info:
Portage (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.28-tuxonice-r9 x86_64)
System uname: Linux-2.6.28-tuxonice-r9-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-glibc2.2.5
Timestamp of tree: Mon, 06 Apr 2009 18:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=native"
FEATURES="autoaddcvs ccache collision-protect cvs distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms strict test test-fail-continue unmerge-orphans userfetch"
LINGUAS="es es_ES en_US"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/wschlich-testing /usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 applet avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cddb cdinstall cdr cleartype cli consolekit cracklib crypt css cups daap dbus dell djvu dri dts dvd dvdr dvdread dvi eds emboss encode evo exif fam fat ffmpeg firefox flac fortran fuse gdbm gif git glitz gnome gnome-keyring gpm gstreamer gtk hal iconv ieee1394 imagemagick isdnlog java jpeg jpeg2k kdeenablefinal kdehiddenvisibility kpathsea laptop latex libnotify lm_sensors lyx lzma mad midi mikmod mmx mmxext mono mp3 mpeg mudflap multilib musicbrainz nautilus ncurses network network-cron networkmanager nls nptl nptlonly ntfs nvidia ogg opengl openmp pam pango pch pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection reiserfs scanner sdl session spell spl sse sse2 ssl ssse3 startup-notification subversion svg sysfs t1lib tcpd threads tiff truetype unicode usb v4l2 vcd vorbis webkit xattr xcb xinetd xml xmp xorg xpm xulrunner xv xvid zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv"

Reproducible: Always
Comment 1 Petteri Räty (RETIRED) gentoo-dev 2009-04-06 23:11:10 UTC
We already supposedly fixed this:
  29 Mar 2009; Serkan Kaba <> +files/2.7.7-makefixes.patch,
  Fix bug #256880. Thanks to Diego E. Pettenò <> for
Comment 2 Petteri Räty (RETIRED) gentoo-dev 2009-04-06 23:12:09 UTC
Please post the full build.log and make sure your ebuild comes from the main tree and not an outdated copy in a local overlay for example. Then reopen if not workin.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2009-04-06 23:18:53 UTC
Created attachment 187507 [details]

pa@loki ~/loki_overlay/app-text/poppler $ emerge -pv antlr

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-java/antlr-2.7.7  USE="cxx java mono python -debug -doc -examples -script -source" 0 kB
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2009-04-06 23:19:20 UTC
I get it too. See attached build.log.
Comment 5 Serkan Kaba (RETIRED) gentoo-dev 2009-04-07 03:47:18 UTC
(In reply to comment #4)
> I get it too. See attached build.log.

I haven't touched nor fixed mono/c# part of the build system. Feel free to attach a patch for that as well.
Comment 6 Patrice Clement gentoo-dev 2015-12-28 12:12:23 UTC
Pacho are you still interested in getting C# support for antlr-2.7.7? I know Chewi worked on this ebuild a couple of weeks ago and knows it like the back of his hand now.
Comment 7 James Le Cuirot gentoo-dev 2015-12-28 13:43:36 UTC
(In reply to Patrice Clement from comment #6)
> Pacho are you still interested in getting C# support for antlr-2.7.7? I know
> Chewi worked on this ebuild a couple of weeks ago and knows it like the back
> of his hand now.

You think I was unaware of this bug? :P The old ebuild already had Mono support but I stripped it out in the newer revision and I will close this when that goes stable.
Comment 8 Pacho Ramos gentoo-dev 2015-12-29 10:44:55 UTC
I didn't remember about this bug report, feel free to solve it when you are able to ;)
Comment 9 James Le Cuirot gentoo-dev 2016-01-14 22:34:19 UTC
Mono support now gone.