Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 26518 - libxml2-2.5.9 fails with distcc
Summary: libxml2-2.5.9 fails with distcc
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Lisa Seelye (RETIRED)
: 31152 41031 (view as bug list)
Depends on:
Reported: 2003-08-12 20:51 UTC by Kirtis Bakalarczyk
Modified: 2004-02-10 00:03 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

Emerge info (,1.69 KB, text/plain)
2003-08-12 20:56 UTC, Kirtis Bakalarczyk
Emerge info (,1.69 KB, application/octet-stream)
2003-08-12 20:57 UTC, Kirtis Bakalarczyk
Emerge info (,1.69 KB, text/plain)
2003-08-12 20:57 UTC, Kirtis Bakalarczyk
Emerge info (,1.69 KB, text/plain)
2003-08-12 20:57 UTC, Kirtis Bakalarczyk
Emerge info (,1.69 KB, text/plain)
2003-08-12 20:59 UTC, Kirtis Bakalarczyk

Note You need to log in before you can comment on or make changes to this bug.
Description Kirtis Bakalarczyk 2003-08-12 20:51:33 UTC
libxml fails when distcc is set in FEATURES, but works fine without distcc.

Reproducible: Always
Steps to Reproduce:
1.include distcc in FEATURES
2.emerge libxml2 (with ARCH=~x86) it fail..

Actual Results:  
it fails..

Expected Results:  
Compile fine.

I haven't installed distcc on the computers listed in /etc/distcc/hosts yet.
Comment 1 Kirtis Bakalarczyk 2003-08-12 20:56:54 UTC
Created attachment 16011 [details]
Emerge info
Comment 2 Kirtis Bakalarczyk 2003-08-12 20:57:03 UTC
Created attachment 16012 [details]
Emerge info
Comment 3 Kirtis Bakalarczyk 2003-08-12 20:57:33 UTC
Created attachment 16013 [details]
Emerge info
Comment 4 Kirtis Bakalarczyk 2003-08-12 20:57:47 UTC
Created attachment 16014 [details]
Emerge info
Comment 5 Kirtis Bakalarczyk 2003-08-12 20:59:48 UTC
Created attachment 16015 [details]
Emerge info
Comment 6 Kirtis Bakalarczyk 2003-08-12 21:01:33 UTC
I can't seem to add the output from emerge info so i'll include it here:

Portage 2.0.48-r7 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r1)
System uname: 2.6.0-test3 i686 Intel(R) Pentium(R) 4 CPU 2.00GHz
GENTOO_MIRRORS="                                                               gentoo ftp://csociety-ftp.ecn.pur                                                      ftp://ftp.ussg.iu                                                               .edu/pub/linux/gentoo http://gentoo                                                                                                                                                                "
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/share                                                               /config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss 3dnow apm crypt cups encode foomaticdb gif jpeg libg++ mad mikmod m                                                               mx mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms zlib gtkhtml g                                                               dbm berkdb slang readline bonobo tcltk java guile mysql tcpd pam libwww perl pyt                                                               hon imlib gtk motif opengl mozilla cdr aalib directfb fbcon gpm svga xv -avi sen                                                               dmail samba X ssl apache2 dvd sdl oggvorbis gtk2 gnome -alsa -qt -arts -esd -kde                                                               "
CFLAGS="-O2 -march=pentium4 -mmmx -msse2 -pipe"
CXXFLAGS="-O2 -march=pentium4 -mmmx -msse2 -pipe"
FEATURES="ccache sandbox distcc"

Also, I tried it with and without sandbox and nothing changed.
Comment 7 Lisa Seelye (RETIRED) gentoo-dev 2003-08-12 21:03:43 UTC
Your attachments were successful (all of them)
Comment 8 Kirtis Bakalarczyk 2003-08-12 21:10:14 UTC
Oops.  It gave me an error each time.. I assumed they didn't get through.

Comment 9 Lisa Seelye (RETIRED) gentoo-dev 2003-08-12 21:11:15 UTC
see also
Comment 10 Brian Jackson (RETIRED) gentoo-dev 2003-08-13 16:36:35 UTC
kirtis, can you try to emerge it without -mmmx in your CFLAGS, I had the same 
problem here, and it worked when I took that out 
Comment 11 Kirtis Bakalarczyk 2003-08-15 05:32:05 UTC
I tried emerging without -mmmx and it still failed on me.. Only removing distcc from FEATURES 
has worked so far.  
Comment 12 duebel 2003-08-17 08:43:20 UTC
I can confirm this bug on my Pentium3-M notebook. When I use FEATURES="distcc" and do not define hosts for distcc then the build process stops at the same place and with the same message as on Kirtis' system. It builds fine when I omit distcc in FEATURES.
Comment 13 Lisa Seelye (RETIRED) gentoo-dev 2003-09-11 13:00:13 UTC
Is this still failing with libxml2-2.5.11?  It worked for me with an athlon.
Comment 14 Kirtis Bakalarczyk 2003-09-11 13:12:17 UTC
Yup, different error though:

make[2]: *** [nanohttp.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
distcc[18787] (dcc_build_somewhere) Warning: failed to distribute, running locally instead
nanoftp.c: In function `xmlNanoFTPGetConnection':
nanoftp.c:1499: error: `dataAddrLen' undeclared (first use in this function)
nanoftp.c:1499: error: (Each undeclared identifier is reported only once
nanoftp.c:1499: error: for each function it appears in.)
distcc[18787] ERROR: compile on localhost failed
make[2]: *** [nanoftp.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/libxml2-2.5.11/work/libxml2-2.5.11'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libxml2-2.5.11/work/libxml2-2.5.11'
make: *** [all] Error 2

!!! ERROR: dev-libs/libxml2-2.5.11 failed.
!!! Function src_compile, Line 31, Exitcode 2
!!! (no error message)

Still works without distcc in features.

Comment 15 Lisa Seelye (RETIRED) gentoo-dev 2003-09-11 13:20:55 UTC
Can you paste `emerge info` please for each machine you're compiling on?
Comment 16 Kirtis Bakalarczyk 2003-09-11 13:27:24 UTC
Portage 2.0.49-r3 (default-x86-1.4, gcc-3.3.1, glibc-2.3.2-r1, 2.6.0-test4-bk3)
System uname: 2.6.0-test4-bk3 i686 Intel(R) Pentium(R) 4 CPU 2.00GHz
distcc 2.10 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.2 [enabled]
CFLAGS="-O2 -march=pentium4 -msse2 -pipe"
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/share/config /
usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -msse2 -pipe"
FEATURES="autoaddcvs sandbox ccache"
GENTOO_MIRRORS=" http:// http://
USE="x86 apm crypt cups encode foomaticdb gif jpeg libg++ mad mikmod mmx mpeg ncurses 
nls pdflib png quicktime spell truetype xml2 xmms xv zlib directfb gtkhtml gdbm berkdb slang 
readline aalib bonobo svga tcltk java guile gpm tcpd pam libwww ssl perl python imlib gtk motif 
opengl mozilla cdr samba X apache2 dvd sdl oggvorbis gtk2 gnome oss -avi -alsa -qt -arts -esd -
Comment 17 Lisa Seelye (RETIRED) gentoo-dev 2003-09-11 14:16:36 UTC
I asked a user with a P4 to try compiling this with your CFLAGS and his attempt was successful.

So this leads me to believe that you're missing a library of some sort.

    SOCKLEN_T dataAddrLen;  <-- Line 1499
Comment 18 Martin Pool 2003-09-11 18:32:00 UTC
There is some kind of persistent flakiness on libxml's autoconf scripts.  I'm sure   I've seen an error to do with failing to detect SOCKLEN_T on some other system.
Comment 19 Lisa Seelye (RETIRED) gentoo-dev 2003-09-14 22:03:39 UTC
As Martin suggests, this is an upstream problem. Report it to  Do you gnome@ guys care to report it?
Comment 20 Martin Pool 2003-09-14 22:42:09 UTC
Somebody who can reproduce this problem needs to get the following debug information:

 the config.log

 how SOCKLEN_T is getting defined

 why isn't it getting set to the right type (presumably socklen_t)
Five copies of the ebuild file is not sufficient. :-)
Comment 21 Alastair Tse (RETIRED) gentoo-dev 2003-09-15 02:22:15 UTC
as a last ditch effort, can you try MAKEOPTS="-j1" emerge libxml2 2>&1 | tee /tmp/libxml2.log 

Comment 22 Lisa Seelye (RETIRED) gentoo-dev 2003-09-26 09:03:47 UTC
zilla reopened this.

did you report this upstream?
Comment 23 Lisa Seelye (RETIRED) gentoo-dev 2003-10-17 13:29:33 UTC
*** Bug 31152 has been marked as a duplicate of this bug. ***
Comment 24 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2003-10-17 14:15:49 UTC
could you please look at bug 30701 and see if some old headers are causing
your problem?
Comment 25 Wolfram Schlich (RETIRED) gentoo-dev 2003-10-19 13:59:06 UTC
Well, regarding Bug 31152, I could make it work by removing "distcc" and
"ccache" from the FEATURES in make.conf, although I'm not sure which one
solved it.
Comment 26 Lisa Seelye (RETIRED) gentoo-dev 2004-02-10 00:03:26 UTC
*** Bug 41031 has been marked as a duplicate of this bug. ***