Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264900 - gnome-extra/evolution-data-server-2.24.5-r2: emerge failed after upgrading to sys-libs/db-4.7.25_p3
Summary: gnome-extra/evolution-data-server-2.24.5-r2: emerge failed after upgrading to...
Status: RESOLVED DUPLICATE of bug 298560
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-04-04 17:06 UTC by Krzysztof Magusiak
Modified: 2010-08-25 08:26 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Krzysztof Magusiak 2009-04-04 17:06:50 UTC
After updating libdb from 4.6 to 4.7.25_p3, evolution-data-server cannot be recompiled by revdep-rebuild.

Reproducible: Always

Steps to Reproduce:
1. Install libdb-4.6 and evolution-data-server
2. Update libdb to version 4.7
3. Unmerge the old version and run revdep-rebuild

Actual Results:  
The compilation fails:
/var/tmp/portage/gnome-extra/evolution-data-server-2.24.5-r2/work/evolution-data-server-2.24.5/docs/reference/addressbook/libedata-book/.libs/libedata-book-scan: error while loading shared libraries: libdb-4.6.so: cannot open shared object file: No such file or directory
Scan failed: 
make[5]: *** [scan-build.stamp] Error 127
make[5]: Leaving directory `/var/tmp/portage/gnome-extra/evolution-data-server-2.24.5-r2/work/evolution-data-server-2.24.5/docs/reference/addressbook/libedata-book'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/gnome-extra/evolution-data-server-2.24.5-r2/work/evolution-data-server-2.24.5/docs/reference/addressbook'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/gnome-extra/evolution-data-server-2.24.5-r2/work/evolution-data-server-2.24.5/docs/reference'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-extra/evolution-data-server-2.24.5-r2/work/evolution-data-server-2.24.5/docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-extra/evolution-data-server-2.24.5-r2/work/evolution-data-server-2.24.5'
make: *** [all] Error 2


Expected Results:  
evolution-data-server should use the new version of libdb.
Comment 1 Krzysztof Magusiak 2009-04-08 13:39:45 UTC
I have solved the problem by:
- reemerging gtk-doc
- emerging evolution-data-server without the doc useflag
(I'm not sure which one solved the problem)
Comment 2 Ian Abbott 2009-04-26 10:01:54 UTC
I have the same problem. Re-emerging gtk-doc doesn't fix it but I'm pretty sure building evolution-data-server with USE="-doc" would work.

Can someone reopen this bug?
Comment 3 Ian Abbott 2009-04-26 10:44:27 UTC
I solved the problem by unemerging the current installation of evolution-data-server (with emerge -C) before emerging it again. It seems that the libedata-book-scan program that failed to load libdb-4.6 was linked to already installed versions of its own libraries from a previous install, but those libs were broken by removal of libdb-4.6.so.
Comment 4 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-04-26 17:25:54 UTC
Woot.  Yet another "evo linked against installed version" bug.  Unfortunately, evo is a maze of twisty linker statements, all the same.  Fortunately, upstream is splitting it up into smaller, more self-contained segments over time.
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-10-29 08:07:30 UTC
Actually I think this is the same bug as the gnome-keyring issue where gtk-doc tries to make the libs load stuff from outsite the sandbox to generate the doc. Hence the workaround described by Krzysztof. I checked the Makefile.ams and there is no obvious linking problem that would make it look for system libs.
Comment 6 Lindsay Haisley 2009-12-13 21:19:07 UTC
Same problem here with evolution-2.26.3

"libebook-scan: error while loading shared libraries: libplds4.so.7: cannot open shared object file: No such file or directory"

removing the installed version of evolution-data-server solved the problem.

Perhaps, if the evo dependencies are so convoluted, it would be a good idea to put this suggestion in a messages emitted if the build fails
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-12-13 21:57:00 UTC
Please read comment #5 again. It's not an eds bug in itself, just gtk-doc doing weird things.
Comment 8 Gilles Dartiguelongue gentoo-dev 2010-08-25 08:26:08 UTC

*** This bug has been marked as a duplicate of bug 298560 ***