Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264416 - gnome-base/nautilus-2.24.2: lost of a file during a copy to replace its parent folder
Summary: gnome-base/nautilus-2.24.2: lost of a file during a copy to replace its paren...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-03-31 17:15 UTC by Christophe
Modified: 2009-10-22 20:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe 2009-03-31 17:15:55 UTC
Nautilus-2.24.2

In a folder named "test", you have a file with same name "test". If you cut the file and paste it one level above to replace the folder (its own parent), ask to replace, the operation failed and you loose both the folder and the file.

Although the operation is a bit stupid but you should never loose a file in a cut and paste operation.

I assumed that the "Cut" operation had the file placed in "buffer" and therefore I could replace the now empty folder with that file. 


Reproducible: Always

Steps to Reproduce:
1. create a folder "test"
2. in that folder create a file "test"
3. cut the file (ctrl-X)
4. go up one level
5. paste the file (ctrl-V)
6. confirm the replacement


Actual Results:  
The operation to replace folder by file failed, both the folder and the file are lost.

Expected Results:  
If the operation failed, the file/folder should not be destroyed.
or
The operation succeed and the file replace the folder

Portage 2.1.6.7 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.26-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.26-gentoo-r4-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-glibc2.2.5
Timestamp of tree: Tue, 31 Mar 2009 04:20:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirrors.tera-byte.com/pub/gentoo http://gentoo.osuosl.org/ http://www.gtlib.gatech.edu/pub/gentoo "
LANG="C"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/local/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/layman/sabayon /usr/local/layman/hollow /usr/local/layman/vmware /usr/local/overlays/portage /usr/local/overlays/edma"
SYNC="rsync://192.168.10.140/gentoo-portage"
USE="X a52 acpi alsa amd64 apache2 applet audacious automount avahi bash-completion berkdb blas branding bzip2 cairo caps cdparanoia cdr cli cracklib cups daap dbus divx dri dvd dvdr dvdread dvi emboss emerald encode evo fam fbcondecor ffmpeg fftw firefox flac font-server foomaticdb fortran gdbm gif gimp glitz glut gmedia gnome gpm gsf gstreamer gtk hal hddtemp iconv isdnlog jpeg lapack libburn libnotify lm_sensors mad matroska midi mikmod mmkeys mmx mng mono mp3 mpeg mudflap multilib mysql nautilus ncurses network nfs nonfsv4 nptl nptlonly nsplugin nvidia ogg ole openal opengl openmp pam pcre pdf perl plotutils png ppds pppd pygrub python qt4 quicktime readline realmedia reflection samba screen sdl sensord server session skins slang smp sourceview spell spl sse sse2 ssl startup-notification stream svg sysfs syslog tcpd theora threads thunderbird tiff totem truetype unicode usb v4l v4l2 vnc vorbis wma wmp wxwindows x264 xine xml xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-05-14 22:43:14 UTC
this doesn't sound like a gentoo specific problem. Could you report this upstream and paste the URL here, thanks.
Comment 2 Christophe 2009-10-22 19:40:58 UTC
Was fixed at some point... nautilus-2.26.4 does not allow the operation and both file and folder are now kept.

Comment 3 Gilles Dartiguelongue gentoo-dev 2009-10-22 20:09:03 UTC
since 2.26.4 is now stable, I think we can close this fixed then. Thanks for reporting.