Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 264114 - dev-util/intltool-0.40.6 is badly broken
Summary: dev-util/intltool-0.40.6 is badly broken
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-28 22:28 UTC by Gilles Dartiguelongue
Modified: 2020-06-06 09:11 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gilles Dartiguelongue gentoo-dev 2009-03-28 22:28:56 UTC
Every package we are currently eautoreconfiguring gets broken by intltool-0.40.6. I'm about to pmask it until upstream help us figure out what's wrong. I believe this is the root cause of most of the "package x is half translated" we've seen recently.
Comment 1 niogic 2009-03-29 16:00:59 UTC
Thanks! I was going to post this bug, even if I didn't know it was intltool's fault.

But now I have to rebuild packages that was built when intltool-0.40.6 was installed.
Can revdep-rebuild or some portage script tell me what are those packages or I need to manually rebuild what I find is in the wrong language?
Comment 2 niogic 2009-03-29 16:23:31 UTC
Ah, I also get lots of
"/bin/sh: warning: setlocale: LC_ALL: cannot change locale (it_IT.UTF-8)"
messages when I boot (I have a testing system and use OpenRC, if it matters).

Don't know if it's because of this same bug and don't know how to get rid of them!
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-04-23 22:40:59 UTC
upstream fixed this issue apparently, it'd be nice to test so we can eventually fix ebuilds without doing a full blown eautoreconf.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-05-07 14:49:31 UTC
Here's the direct link to upstream's fix:

http://bazaar.launchpad.net/~intltool/intltool/trunk/revision/690
Comment 5 Romain Perier (RETIRED) gentoo-dev 2009-08-22 09:38:12 UTC
Lars: This exactly the same fix that's we actually use, except we use a sed expression.
Comment 6 Xake 2009-08-22 09:47:43 UTC
Is this fixed in intltool-0.41.0? Or is that some kind of dev-version?

(https://edge.launchpad.net/intltool/+download)
Comment 7 Xake 2009-08-22 11:24:38 UTC
Also: should we patch this version or just keep it masked and hope intltool-0.41.0 works and could be the next stable-candidate (after it has hit portage, grown there for some time and so on...) and noone will miss this broken version?
Comment 8 Gilles Dartiguelongue gentoo-dev 2009-08-22 17:44:12 UTC
the only interesting fix in 0.40.6 is the one thing that actually breaks it. intltool 0.40.6 is absolutely not interesting to users since it's only used when building packages that do an eautoreconf and 0.40.5 does the job just fine with our current workaround (which doesn't need an eautoreconf btw). 0.41 branch is a dev branch as can be seen on the upstream page at launchpad.

So to sum up, nothing will be done here until there is a new stable release to use.
Comment 9 Gilles Dartiguelongue gentoo-dev 2009-08-23 21:11:00 UTC
diego commited 0.40.6-r1 with the patch, closing.
Comment 10 SunLiu 2020-06-06 09:11:42 UTC
(In reply to Gilles Dartiguelongue from comment #9)
> diego commited 0.40.6-r1 with the patch, closing.

I used emerge to add this below.

emerge dev-util/intltool
/usr/lib64/python3.6/site-packages/portage/package/ebuild/_config/KeywordsManager.py:70: UserWarning: /etc/portage/package.keywords is deprecated, use /etc/portage/package.accept_keywords instead
  UserWarning)

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
>>> Emerging binary (1 of 1) dev-util/intltool-0.51.0-r2::gentoo
>>> Installing (1 of 1) dev-util/intltool-0.51.0-r2::gentoo
>>> Recording dev-util/intltool in "world" favorites file...
>>> Jobs: 1 of 1 complete                           Load avg: 1.18, 0.79, 0.43
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-libs/boost-1.73.0
 *  - /usr/lib64/libboost_chrono.so.1.72.0
 *  - /usr/lib64/libboost_date_time.so.1.72.0
 *      used by /usr/lib64/libreoffice/program/libdbahsqllo.so (app-office/libreoffice-6.4.2.2)
 *  - /usr/lib64/libboost_locale.so.1.72.0
 *      used by /usr/lib64/libreoffice/program/libmergedlo.so (app-office/libreoffice-6.4.2.2)
 *  - /usr/lib64/libboost_system.so.1.72.0
 *  - /usr/lib64/libboost_thread.so.1.72.0
>>> package: dev-libs/icu-67.1
 *  - /usr/lib64/libicudata.so.65
 *  - /usr/lib64/libicudata.so.65.1
 *  - /usr/lib64/libicudata.so.66
 *  - /usr/lib64/libicudata.so.66.1
 *      used by /usr/lib64/libboost_locale.so.1.72.0 (preserved)
 *  - /usr/lib64/libicui18n.so.65
 *  - /usr/lib64/libicui18n.so.65.1
 *      used by /usr/bin/js52 (dev-lang/spidermonkey-52.9.1_pre1-r1)
 *      used by /usr/lib64/libmozjs-52.so (dev-lang/spidermonkey-52.9.1_pre1-r1)
 *  - /usr/lib64/libicui18n.so.66
 *  - /usr/lib64/libicui18n.so.66.1
 *      used by /usr/lib64/libQt5WebKit.so.5.212.0 (dev-qt/qtwebkit-5.212.0_pre20200309)
 *      used by /usr/lib64/libreoffice/program/libfrmlo.so (app-office/libreoffice-6.4.2.2)
 *      used by /usr/lib64/libreoffice/program/libi18nsearchlo.so (app-office/libreoffice-6.4.2.2)
 *      used by 4 other files
 *  - /usr/lib64/libicuuc.so.65
 *  - /usr/lib64/libicuuc.so.65.1
 *      used by /usr/bin/js52 (dev-lang/spidermonkey-52.9.1_pre1-r1)
 *      used by /usr/lib64/libmozjs-52.so (dev-lang/spidermonkey-52.9.1_pre1-r1)
 *  - /usr/lib64/libicuuc.so.66
 *  - /usr/lib64/libicuuc.so.66.1
 *      used by /usr/lib64/libQt5WebKit.so.5.212.0 (dev-qt/qtwebkit-5.212.0_pre20200309)
 *      used by /usr/lib64/libreoffice/program/libcuilo.so (app-office/libreoffice-6.4.2.2)
 *      used by /usr/lib64/libreoffice/program/libfrmlo.so (app-office/libreoffice-6.4.2.2)
 *      used by 8 other files
>>> package: dev-libs/json-c-0.14-r3
 *  - /usr/lib64/libjson-c.so.4
 *  - /usr/lib64/libjson-c.so.4.0.0
 *      used by /usr/lib64/libmypaint-1.4.so.0.0.0 (media-libs/libmypaint-1.4.0-r1)
>>> package: dev-libs/nettle-3.6-r2
 *  - /usr/lib64/libnettle.so.7
 *  - /usr/lib64/libnettle.so.7.0
 *      used by /usr/bin/claws-mail (mail-client/claws-mail-3.17.5-r1)
>>> package: media-libs/libdvdread-6.1.1
 *  - /usr/lib64/libdvdread.so.7
 *  - /usr/lib64/libdvdread.so.7.0.0
 *      used by /usr/bin/gnome-disks (sys-apps/gnome-disk-utility-3.34.5)
Use emerge @preserved-rebuild to rebuild packages using these libraries
pi64 /home/demouser #