Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264065 - www-client/opera 10.00_pre4214 keyboard does not work in save dialog
Summary: www-client/opera 10.00_pre4214 keyboard does not work in save dialog
Status: VERIFIED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Jeroen Roovers (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-28 13:59 UTC by Tiger!P
Modified: 2009-04-06 20:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tiger!P 2009-03-28 13:59:47 UTC
In the save dialog it is not possible to use the keyboard.


Reproducible: Always

Steps to Reproduce:
1. Open an webpage
2. Use the file->Save As menu option
3. try to change the name of the file, this will fail (also changing the name of a new created directory is not possible).

Actual Results:  
It is not possible to change the name

Expected Results:  
I would expect to be able to change the name by using my keyboard
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-28 21:03:49 UTC
Please post your "emerge --info".
Comment 2 Tiger!P 2009-03-29 12:32:44 UTC
Portage 2.1.6.11 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-glibc2.2.5
Timestamp of tree: Sat, 28 Mar 2009 18:45:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p10-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.6
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/mnt/data1/gentoo-distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://mirror.switch.ch/mirror/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_GB nl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/data1/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/jokey /usr/local/portage/layman/sunrise /usr/local/portage /home/stefan/test/ebuilds"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acl acpi alsa amd64 apache2 arts audiofile bash-completion berkdb bluetooth branding bzip2 cairo cdr cjk cli cracklib crypt cups dbus dga dri dvd dvdr dvdread eds emboss emul-linux-x86 encode esd evo exif ffmpeg firefox flac fortran ftp gd gdbm gif gnome gnutls gphoto2 gstreamer gtk hal iconv ipv6 isdnlog jabber jpeg jpeg2k kde libnotify lm_sensors mad maildir midi mikmod mime mmx mng mp3 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin ogg openal opengl openmp osc oss pam pcre pdf perl php png posix ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl seamonkey session spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora tiff truetype unicode usb utempter vhosts vorbis wmf xml xorg xpm xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse void evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB nl" USERLAND="GNU" VIDEO_CARDS="radeon dummy vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
 
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2009-03-30 15:26:37 UTC
Opera is closed source, so we cannot possibly solve this ourselves. Report this at [1] instead.

[1] https://bugs.opera.com/wizard/
Comment 4 Tiger!P 2009-03-30 20:26:31 UTC
Does this mean that I should not report any opera bugs to this bugzilla anymore?
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2009-03-31 16:19:21 UTC
(In reply to comment #4)
> Does this mean that I should not report any opera bugs to this bugzilla
> anymore?

No, please keep doing so. Especially when it's hard to determine whether either Opera or Gentoo is doing something wrong, it's useful to have a bug report about it here. 

In this particular case, the bug is about a beta build (and an Opera labs release at that) that depends on a locally installed Qt3 (you appear to have USE="qt3 -qt-static" which denotes a Qt3 shared build). I'm seeing several "keyboard shortcut" related problems myself here, and I am quite sure these depend on Opera and not on whatever Qt you have (since it exhibits the same types of problems regardless of USE flags here).
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2009-03-31 16:21:39 UTC
Oh, and when you do report this problem upstream, please record their bug tracker number in this bug report.
Comment 7 Tiger!P 2009-03-31 19:54:00 UTC
I've reported this bug to opera as bug DSK-250242.
Comment 8 Tiger!P 2009-04-06 20:46:43 UTC
This bug has been fixed in opera 10.00_pre4268.