Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263851 - sys-apps/baselayout-1: ESSID setting in /etc/conf.d/net ignored
Summary: sys-apps/baselayout-1: ESSID setting in /etc/conf.d/net ignored
Status: VERIFIED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-26 10:52 UTC by Vaidas Kascėnas
Modified: 2010-02-03 10:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vaidas Kascėnas 2009-03-26 10:52:36 UTC
This is the content of my /etc/conf.d/net:
essid_wlan0="smth"
mode_wlan0="ad-hoc"
config_wlan0=( "192.168.2.254 netmask 255.255.255.0" )

When i run /etc/init.d/net.wlan0 (re)start this is what I get:
* Starting wlan0
*   Configuring wireless network for wlan0
*     wlan0 connected to ESSID ""
*     in managed mode on channel 3 (WEP disabled)
*   Bringing up wlan0
*     192.168.2.254

It looks like the essid setting gets ignored. Also if I use config_smth, the script says configuration is missing and assumes dhcp.

Reproducible: Always

Steps to Reproduce:
1. Set ESSID in /etc/conf.d/net.
2. Run /etc/init.d/net.<interface> start.
3. Watch output.

Actual Results:  
I can't start an ad-hoc network.
Comment 1 Markos Chandras (RETIRED) gentoo-dev 2009-03-26 21:12:06 UTC
Try using

preferred_aps=("smth"), instead of 

essid_wlan0="smth"
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-27 05:47:20 UTC
Please try Markos' suggestion. Reopen this bug if it still doesn't work.
Comment 3 Vaidas Kascėnas 2009-03-27 08:47:36 UTC
(In reply to comment #2)
> Please try Markos' suggestion. Reopen this bug if it still doesn't work.

I probably should've mentioned that I already tried it, I tried using "ESSID" instead of "essid" too, tried adhoc_essid_wlan0 as well.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-28 13:54:25 UTC
Please post your "emerge --info".
Comment 5 Vaidas Kascėnas 2009-03-28 14:24:41 UTC
Portage 2.1.6.7 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-i686-Intel-R-_Pentium-R-_4_CPU_1.40GHz-with-glibc2.0
Timestamp of tree: Wed, 25 Mar 2009 19:20:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.63
sys-devel/automake:  1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.linux.ee/pub/gentoo/distfiles"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl bash-completion bzip2 cli crypt dri gdbm iconv isdnlog midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl ssl sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 6 Rick Harris 2009-05-13 10:58:10 UTC
Start net.wlan0, as root what does the output of 'iwgetid' say ?
Comment 7 Vaidas Kascėnas 2009-05-14 19:22:39 UTC
It says:
wlan0 ESSID:""
Is there any hope that this bug will get fixed?
Comment 8 Vaidas Kascėnas 2009-05-25 21:34:45 UTC
I think that this is happening because mode_wlan0="ad-hoc" doesn't do anything. If I set it manually and the restart the interface, everything gets set correctly, so the mode_wlan0 not working must be the obstacle. Any ideas on how to fix this?
Comment 9 SpanKY gentoo-dev 2009-10-11 09:31:10 UTC
it probably defaults to wpa supplicant rather than iwconfig, so you can try forcing modules
Comment 10 William Hubbs gentoo-dev 2009-12-17 16:55:22 UTC
Please upgrade your system to openrc/baselayout-2.

If this issue still exists after you upgrade, please re-open this bug
and let us know so we can address it in openrc.
Comment 11 Vaidas Kascėnas 2010-02-01 19:49:18 UTC
(In reply to comment #9)
> it probably defaults to wpa supplicant rather than iwconfig, so you can try
> forcing modules

The line ``modules=("iwconfig")`` didn't help.
Comment 12 SpanKY gentoo-dev 2010-02-03 04:10:48 UTC
you didnt say whether you're using openrc
Comment 13 Vaidas Kascėnas 2010-02-03 09:08:59 UTC
(In reply to comment #12)
> you didnt say whether you're using openrc

Well I'm reporting a bug in sys-apps/baselayout-1 so no, I'm not.
Comment 14 SpanKY gentoo-dev 2010-02-03 09:35:42 UTC
the response in comment #10 hasnt changed
Comment 15 Vaidas Kascėnas 2010-02-03 09:58:30 UTC
(In reply to comment #14)
> the response in comment #10 hasnt changed

Well if noone is going to fix it, why bother supporting or using it at all?
Comment 16 SpanKY gentoo-dev 2010-02-03 10:07:31 UTC
as comment #10 already said, this should work in openrc.  we're focusing on stabilizing openrc instead of backporting code that is effectively dead.
Comment 17 Vaidas Kascėnas 2010-02-03 10:15:49 UTC
Well if somebody else is reluctant to upgrading to an ~arch package, here is a script I wrote that just works(tm):

ifconfig wlan0 up
iwconfig wlan0 mode ad-hoc
iwconfig wlan0 essid myessid
ifconfig wlan0 192.168.2.254 netmask 255.255.255.0