Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263810 (CVE-2009-1093) - <{app-emulation/emul-linux-x86-java,dev-java/sun-{jdk, jre-bin}}-{1.5.0.18, 1.6.0.13}: Multiple vulnerabilities (CVE-2009-{1093,1094,1095,1096,1097,1098,1099,1100,1101,1102,1103,1104,1105,1106,1107})
Summary: <{app-emulation/emul-linux-x86-java,dev-java/sun-{jdk, jre-bin}}-{1.5.0.18, 1...
Status: RESOLVED FIXED
Alias: CVE-2009-1093
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Security
URL: http://sunsolve.sun.com/search/docume...
Whiteboard: A2 [glsa]
Keywords:
Depends on: 287615
Blocks:
  Show dependency tree
 
Reported: 2009-03-25 23:15 UTC by Alex Legler (RETIRED)
Modified: 2010-04-30 17:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-25 23:15:51 UTC
From upstream advisory:

Integer and buffer overflow vulnerabilities in the Java Runtime Environment (JRE) with unpacking applets and Java Web Start applications using the "unpack200" JAR unpacking utility may allow an untrusted applet or application to escalate privileges. For example, an untrusted applet may grant itself permissions to read and write local files or execute local applications that are accessible to the user running the untrusted applet.

Resolution

These issues are addressed in the following Java SE and Java SE for Business releases for Windows, Solaris, and Linux:

    * JDK and JRE 5.0 Update 18 or later
    * JDK and JRE 6 Update 13 or later
Comment 1 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-25 23:18:11 UTC
Java, please bump as per summary.
Comment 2 Serkan Kaba (RETIRED) gentoo-dev 2009-03-26 05:05:47 UTC
Bumped in tree. Arches please stabilize

x86+amd64: dev-java/sun-{jdk,jre-bin}-{1.5.0.18,1.6.0.13}
amd64: app-emulation/emul-linux-x86-java-{1.5.0.18,1.6.0.13}
Comment 3 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-26 09:02:43 UTC
CVE-2009-1093 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1093):
  LdapCtx in the LDAP service in Java SE Development Kit (JDK) and Java
  Runtime Environment (JRE) 5.0 Update 17 and earlier; 6 Update 12 and
  earlier; SDK and JRE 1.3.1_24 and earlier; and 1.4.2_19 and earlier
  does not close the connection when initialization fails, which allows
  remote attackers to cause a denial of service (LDAP service hang).

CVE-2009-1094 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1094):
  Unspecified vulnerability in the LDAP implementation in Java SE
  Development Kit (JDK) and Java Runtime Environment (JRE) 5.0 Update
  17 and earlier; 6 Update 12 and earlier; SDK and JRE 1.3.1_24 and
  earlier; and 1.4.2_19 and earlier allows remote LDAP servers to
  execute arbitrary code via unknown vectors related to serialized data.

CVE-2009-1095 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1095):
  Integer overflow in unpack200 in Java SE Development Kit (JDK) and
  Java Runtime Environment (JRE) 5.0 Update 17 and earlier, and 6
  Update 12 and earlier, allows remote attackers to access files or
  execute arbitrary code via a JAR file with crafted Pack200 headers.

CVE-2009-1096 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1096):
  Buffer overflow in unpack200 in Java SE Development Kit (JDK) and
  Java Runtime Environment (JRE) 5.0 Update 17 and earlier, and 6
  Update 12 and earlier, allows remote attackers to access files or
  execute arbitrary code via a JAR file with crafted Pack200 headers.

CVE-2009-1097 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1097):
  Multiple buffer overflows in Java SE Development Kit (JDK) and Java
  Runtime Environment (JRE) 6 Update 12 and earlier allow remote
  attackers to access files or execute arbitrary code via a crafted (1)
  PNG image, aka CR 6804996, and (2) GIF image, aka CR 6804997.

CVE-2009-1098 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1098):
  Buffer overflow in Java SE Development Kit (JDK) and Java Runtime
  Environment (JRE) 5.0 Update 17 and earlier; 6 Update 12 and earlier;
  1.4.2_19 and earlier; and 1.3.1_24 and earlier allows remote
  attackers to access files or execute arbitrary code via a crafted GIF
  image, aka CR 6804998.

CVE-2009-1099 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1099):
  Integer signedness error in Java SE Development Kit (JDK) and Java
  Runtime Environment (JRE) 5.0 Update 17 and earlier, and 6 Update 12
  and earlier, allows remote attackers to access files or execute
  arbitrary code via a crafted Type1 font, which triggers a buffer
  overflow.

CVE-2009-1100 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1100):
  Multiple unspecified vulnerabilities in Java SE Development Kit (JDK)
  and Java Runtime Environment (JRE) 5.0 Update 17 and earlier, and 6
  Update 12 and earlier, allow remote attackers to cause a denial of
  service (disk consumption) via vectors related to temporary font
  files and (1) "limits on Font creation," aka CR 6522586, and (2)
  another unspecified vector, aka CR 6632886.

CVE-2009-1101 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1101):
  Unspecified vulnerability in the lightweight HTTP server
  implementation in Java SE Development Kit (JDK) and Java Runtime
  Environment (JRE) 6 Update 12 and earlier allows remote attackers to
  cause a denial of service (probably resource consumption) for a
  JAX-WS service endpoint via a connection without any data, which
  triggers a file descriptor "leak."

CVE-2009-1102 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1102):
  Unspecified vulnerability in the Virtual Machine in Java SE
  Development Kit (JDK) and Java Runtime Environment (JRE) 6 Update 12
  and earlier allows remote attackers to access files and execute
  arbitrary code via unknown vectors related to "code generation."

CVE-2009-1103 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1103):
  Unspecified vulnerability in the Java Plug-in in Java SE Development
  Kit (JDK) and Java Runtime Environment (JRE) 5.0 Update 17 and
  earlier; 6 Update 12 and earlier; 1.4.2_19 and earlier; and 1.3.1_24
  and earlier allows remote attackers to access files and execute
  arbitrary code via unknown vectors related to "deserializing
  applets," aka CR 6646860.

CVE-2009-1104 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1104):
  The Java Plug-in in Java SE Development Kit (JDK) and Java Runtime
  Environment (JRE) 5.0 Update 17 and earlier; 6 Update 12 and earlier;
  and 1.4.2_19 and earlier does not prevent Javascript that is loaded
  from the localhost from connecting to other ports on the system,
  which allows user-assisted attackers to bypass intended access
  restrictions via LiveConnect, aka CR 6724331.  NOTE: this
  vulnerability can be leveraged with separate cross-site scripting
  (XSS) vulnerabilities for remote attack vectors.

CVE-2009-1105 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1105):
  The Java Plug-in in Java SE Development Kit (JDK) and Java Runtime
  Environment (JRE) 6 Update 12, 11, and 10 allows user-assisted remote
  attackers to cause a trusted applet to run in an older JRE version,
  which can be used to exploit vulnerabilities in that older version,
  aka CR 6706490.

CVE-2009-1106 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1106):
  The Java Plug-in in Java SE Development Kit (JDK) and Java Runtime
  Environment (JRE) 6 Update 12, 11, and 10 does not properly parse
  crossdomain.xml files, which allows remote attackers to bypass
  intended access restrictions and connect to arbitrary sites via
  unknown vectors, aka CR 6798948.

CVE-2009-1107 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1107):
  The Java Plug-in in Java SE Development Kit (JDK) and Java Runtime
  Environment (JRE) 6 Update 12 and earlier, and 5.0 Update 17 and
  earlier, allows remote attackers to trick a user into trusting a
  signed applet via unknown vectors that misrepresent the security
  warning dialog, related to a "Swing JLabel HTML parsing
  vulnerability," aka CR 6782871.
Comment 4 Serkan Kaba (RETIRED) gentoo-dev 2009-03-26 09:44:04 UTC
JDK-1.4 will not be fixable since it's EOL'ed
Comment 5 Markus Meier gentoo-dev 2009-04-02 22:01:44 UTC
amd64/x86 stable, all arches done.
Comment 6 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-24 17:35:52 UTC
(In reply to comment #4)
> JDK-1.4 will not be fixable since it's EOL'ed
> 

ping wrt removal?
Comment 7 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2009-05-24 21:03:48 UTC
(In reply to comment #6)
> (In reply to comment #4)
> > JDK-1.4 will not be fixable since it's EOL'ed
> > 
> 
> ping wrt removal?
 
Cannot remove yet, too much depends on it :(
We can reduce the ways it can be used though, since we need it only for building. I've use.masked the nsplugin flag, most security problems are wrt applets. Doing bug 237938 would help restrict to build only.
Comment 8 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-11-17 23:09:39 UTC
GLSA 200911-02