Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263692 - sci-mathematics/glpk-4.35 - In file included from glpsql.c:952: /usr/include/mysql/my_global.h:361:24: error: asm/atomic.h: No such file or directory
Summary: sci-mathematics/glpk-4.35 - In file included from glpsql.c:952: /usr/include/...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-25 07:04 UTC by Pierre
Modified: 2009-09-08 15:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log file (build.log,63.65 KB, text/plain)
2009-03-27 01:17 UTC, Pierre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre 2009-03-25 07:04:09 UTC
[...]
/bin/sh ../libtool --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I../include  -I/usr/include/mysql   -O2 -pipe -MT glpsql.lo -MD -MP -MF .deps/glpsql.Tpo -c -o glpsql.lo glpsql.c
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I../include -I/usr/include/mysql -O2 -pipe -MT glpsql.lo -MD -MP -MF .deps/glpsql.Tpo -c glpsql.c  -fPIC -DPIC -o .libs/glpsql.o
In file included from glpsql.c:952:
/usr/include/mysql/my_global.h:361:24: error: asm/atomic.h: No such file or directory
make[2]: *** [glpsql.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/sci-mathematics/glpk-4.35/work/glpk-4.35/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sci-mathematics/glpk-4.35/work/glpk-4.35'
make: *** [all] Error 2
 * 
 * ERROR: sci-mathematics/glpk-4.35 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2484:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sci-mathematics/glpk-4.35/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sci-mathematics/glpk-4.35/temp/environment'.
 * 

>>> Failed to emerge sci-mathematics/glpk-4.35, Log file:

>>>  '/var/tmp/portage/sci-mathematics/glpk-4.35/temp/build.log'

 * Messages for package sci-mathematics/glpk-4.35:

 * 
 * ERROR: sci-mathematics/glpk-4.35 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2484:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sci-mathematics/glpk-4.35/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sci-mathematics/glpk-4.35/temp/environment'.
 *
Comment 1 Arttu Valo 2009-03-25 13:04:52 UTC
You don't mention your mysql version, but this looks very much like a duplicate of bug #163151 -- just like bug #197004 is. The problem would seem to be mysql headers including stuff that's long gone from kernel headers and that's what the error here basically seems to say, too.
Comment 2 Arttu Valo 2009-03-25 13:09:08 UTC
(In reply to comment #1)
> You don't mention your mysql version, but this looks very much like a duplicate
> of bug #163151 -- just like bug #197004 is. The problem would seem to be mysql
> headers including stuff that's long gone from kernel headers and that's what
> the error here basically seems to say, too.

And by duplicate I mean the problem is the same: broken mysql headers, not that this bug isn't about a glpk instead of mysql-gui-tools. Bug #163151 has some workarounds in, e.g., comment 33.
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-26 19:54:53 UTC
Please post your "emerge --info" and attach the build.log file to this bug.

Reopen this bug when you provide the requested information.
Comment 4 Pierre 2009-03-27 01:17:17 UTC
Created attachment 186371 [details]
Build log file
Comment 5 Pierre 2009-03-27 01:18:03 UTC
# LC_ALL=C emerge --info
Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-Intel-R-_Core-TM-2_CPU_T5500_@_1.66GHz-with-glibc2.2.5
Timestamp of tree: Thu, 26 Mar 2009 23:45:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ "
LANG="fr_FR.UTF-8"
LC_ALL="C"
LDFLAGS="-Wl,-O1"
LINGUAS="fr en de nl"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac aalib accessibility acl acpi afs aim alsa amd64 ao apache2 apm arts audiofile avahi bash-completion bcmath berkdb blas bzip2 cairo calendar cddb cdparanoia cdr cli cracklib crypt css cups curl cxx dbus dbx dga directfb doc dri dts dvd dvdr dvdread emacs encode esd exif expat fam fbcon ffmpeg fftw firefox flac fontconfig foomaticdb fortran ftp gcj gd gdbm geoip ggi gif gimp gmp gnome gnutls gpm gsl gstreamer gtk hal hddtemp iconv icq icu idn imagemagick imap imlib innodb ipv6 isdnlog jabber jack javascript jbig jingle jpeg jpeg2k kde kerberos kolab krb4 ladspa lame lash latex lcms ldap libcaca libnotify libsamplerate libwww lirc lm_sensors lzo mad maildir matroska mbox mhash midi mikmod mime mmx mng modplug motif mozilla mp3 mpeg mplayer msn mudflap multilib musepack musicbrainz mysql mysqli nas ncurses nls nntp nptl nptlonly nsplugin odbc ogg openal opengl openmp osc oscar pam pcmcia pcre pda pdf perl php plotutils png portaudio posix postgres pppd pulseaudio python qt4 quicktime raw readline recode reflection rss samba sasl scanner sdl session sharedext sharedmem shorten simplexml sndfile sockets sox speex spell spl sqlite sse sse2 ssl startup-notification subversion svg symlink sysfs syslog sysvipc szip taglib tcl tcpd theora threads tidy tiff timidity tk truetype unicode usb vhosts vorbis wavpack wifi wmf wxwindows x264 xcb xcomposite xft xine xml xorg xosd xpm xprint xscreensaver xsl xulrunner xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr en de nl" USERLAND="GNU" VIDEO_CARDS="nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 6 Pierre 2009-03-27 01:19:09 UTC
# mysql --version
mysql  Ver 14.12 Distrib 5.0.70, for pc-linux-gnu (x86_64) using readline 5.2
Comment 7 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-03-28 00:10:34 UTC
upgrade your mysql and try again.
Comment 8 Pierre 2009-03-28 14:09:29 UTC
# emerge --sync
[...]
# emerge -u dev-db/mysql
Calculating dependencies... done!
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
Comment 9 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-03-28 20:52:41 UTC
pierre42d: just 'emerge mysql' and then glpk again.
Comment 10 Pierre 2009-03-28 23:16:55 UTC
Ok recompiling mysql fixed the problem, thanks
Comment 11 Pierre 2009-09-08 15:36:56 UTC
Works now
Comment 12 Pierre 2009-09-08 15:37:12 UTC
Fixed