Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263613 - ERROR: games-action/bzflag-2.0.12 failed (under kde 4.2.1)
Summary: ERROR: games-action/bzflag-2.0.12 failed (under kde 4.2.1)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Games
Depends on:
Reported: 2009-03-24 15:27 UTC by James Horton
Modified: 2009-03-31 07:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description James Horton 2009-03-24 15:27:00 UTC
games-action/bzflag-2.0.12  worked great under kde 3.5.9

Recently upgraded via sets to kde 4.2.1

Now bzflag-2.0.12 will not compile. It was removed with many other apps. before
upgrading to kde 4.2.1.

Reproducible: Always

Steps to Reproduce:
1.emerge bzflag

Actual Results:  
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../include -I../../include -DINSTALL_LIB_DIR=\"/usr/games/lib64/bzflag/\" -DINSTALL_DATA_DIR=\"/usr/share/games/bzflag\" -fsigned-char -Wno-deprecated -march=k8 -O2 -pipe -c XIJoystick.cxx -o XIJoystick.o                                                                                  
/bin/sh ../../libtool --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../include  -I../../include  -DINSTALL_LIB_DIR=\"/usr/games/lib64/bzflag/\" -DINSTALL_DATA_DIR=\"/usr/share/games/bzflag\"    -fsigned-char -Wno-deprecated -march=k8 -O2 -pipe -c -o XVisual.lo XVisual.cxx                                  
/bin/sh ../../libtool --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../include  -I../../include  -DINSTALL_LIB_DIR=\"/usr/games/lib64/bzflag/\" -DINSTALL_DATA_DIR=\"/usr/share/games/bzflag\"    -fsigned-char -Wno-deprecated -march=k8 -O2 -pipe -c -o XWindow.lo XWindow.cxx                                  
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../include -I../../include -DINSTALL_LIB_DIR=\"/usr/games/lib64/bzflag/\" -DINSTALL_DATA_DIR=\"/usr/share/games/bzflag\" -fsigned-char -Wno-deprecated -march=k8 -O2 -pipe -c XVisual.cxx -o XVisual.o    
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../include -I../../include -DINSTALL_LIB_DIR=\"/usr/games/lib64/bzflag/\" -DINSTALL_DATA_DIR=\"/usr/share/games/bzflag\" -fsigned-char -Wno-deprecated -march=k8 -O2 -pipe -c XWindow.cxx -o XWindow.o    
In file included from ../../include/bzfgl.h:21,                                     
                 from ../../include/OpenGLGState.h:21,                              
                 from XWindow.cxx:15:                                               
/usr/include/GL/glew.h:66:2: error: #error gl.h included before glew.h              
/usr/include/GL/glew.h:69:2: error: #error glext.h included before glew.h           
/usr/include/GL/glew.h:8367: error: conflicting declaration 'typedef void (* PFNGLFRAGMENTLIGHTMODELFVSGIXPROC)(GLenum, GLfloat*)'                                      
/usr/include/GL/glext.h:5204: error: 'PFNGLFRAGMENTLIGHTMODELFVSGIXPROC' has a previous declaration as 'typedef void (* PFNGLFRAGMENTLIGHTMODELFVSGIXPROC)(GLenum, const GLfloat*)'                                                                         
/usr/include/GL/glew.h:8369: error: conflicting declaration 'typedef void (* PFNGLFRAGMENTLIGHTMODELIVSGIXPROC)(GLenum, GLint*)'                                        
/usr/include/GL/glext.h:5206: error: 'PFNGLFRAGMENTLIGHTMODELIVSGIXPROC' has a previous declaration as 'typedef void (* PFNGLFRAGMENTLIGHTMODELIVSGIXPROC)(GLenum, const GLint*)'                                                                           
/usr/include/GL/glew.h:8371: error: conflicting declaration 'typedef void (* PFNGLFRAGMENTLIGHTFVSGIXPROC)(GLenum, GLenum, GLfloat*)'                                   
/usr/include/GL/glext.h:5200: error: 'PFNGLFRAGMENTLIGHTFVSGIXPROC' has a previous declaration as 'typedef void (* PFNGLFRAGMENTLIGHTFVSGIXPROC)(GLenum, GLenum, const GLfloat*)'                                                                           
/usr/include/GL/glew.h:8373: error: conflicting declaration 'typedef void (* PFNGLFRAGMENTLIGHTIVSGIXPROC)(GLenum, GLenum, GLint*)'                                     
/usr/include/GL/glext.h:5202: error: 'PFNGLFRAGMENTLIGHTIVSGIXPROC' has a previous declaration as 'typedef void (* PFNGLFRAGMENTLIGHTIVSGIXPROC)(GLenum, GLenum, const GLint*)'                                                                             
/usr/include/GL/glew.h:8380: error: conflicting declaration 'typedef void (* PFNGLGETFRAGMENTMATERIALFVSGIXPROC)(GLenum, GLenum, const GLfloat*)'                       
/usr/include/GL/glext.h:5213: error: 'PFNGLGETFRAGMENTMATERIALFVSGIXPROC' has a previous declaration as 'typedef void (* PFNGLGETFRAGMENTMATERIALFVSGIXPROC)(GLenum, GLenum, GLfloat*)'                                                                     
/usr/include/GL/glew.h:8381: error: conflicting declaration 'typedef void (* PFNGLGETFRAGMENTMATERIALIVSGIXPROC)(GLenum, GLenum, const GLint*)'                         
/usr/include/GL/glext.h:5214: error: 'PFNGLGETFRAGMENTMATERIALIVSGIXPROC' has a previous declaration as 'typedef void (* PFNGLGETFRAGMENTMATERIALIVSGIXPROC)(GLenum, GLenum, GLint*)'                                                                       
/usr/include/GL/glew.h:9806: error: 'PFNGLGETPIXELTRANSFORMPARAMETERFVEXTPROC' does not name a type                                                                     
/usr/include/GL/glew.h:9807: error: 'PFNGLGETPIXELTRANSFORMPARAMETERIVEXTPROC' does not name a type                                                                     
make[3]: *** [XWindow.lo] Error 1                                                   
make[3]: Leaving directory `/var/tmp/portage/games-action/bzflag-2.0.12/work/bzflag-2.0.12/src/platform'                                                                
make[2]: *** [all-recursive] Error 1                                                
make[2]: Leaving directory `/var/tmp/portage/games-action/bzflag-2.0.12/work/bzflag-2.0.12/src/platform'                                                                
make[1]: *** [all-recursive] Error 1                                                
make[1]: Leaving directory `/var/tmp/portage/games-action/bzflag-2.0.12/work/bzflag-2.0.12/src'                                                                         
make: *** [all-recursive] Error 1                                                   
 * ERROR: games-action/bzflag-2.0.12 failed.                                        
 * Call stack:                                                                      
 *     , line   48:  Called src_compile                          
 *             environment, line 2847:  Called games_src_compile                    
 *             environment, line 1644:  Called die                                  
 * The specific snippet of code:                                                    
 *           emake || die "emake failed"                                            
 *  The die message:                                                                
 *   emake failed                 

Expected Results:  
successful compile

CFLAGS="-march=k8 -O2 -pipe"
EMERGE_DEFAULT_OPTS="--with-bdeps y"

USE="mmx mmxext sse sse2 sse3 3dnow 3dnowext \
X alsa amd64 avi berkdb bitmap-fonts cairo cdr cli crypt cups \
-arts dbus dlloader dri dvdr eds elibc_glibc emboss encode esd fam  \
fortran gdbm gif gnome gpm gstreamer gtk gtk2 hal dvd wireshark wddx \
input_devices_keyboard input_devices_mouse ipv6 jpeg kde vdr  sockets \
kernel_linux ldap libg++ mad mikmod mp3 mpeg ncurses nls nptl nptlonly \
ogg opengl oss pam pcre pdflib perl png ppds pppd python qt3 qt4 quicktime \
readline reflection sdl session spell spl ssl truetype truetype-fonts \
type1-fonts udev unicode userland_GNU vorbis xml xorg xv  java slp \
dvb a52 aac aalib asf dts flac v4l v4l2 vcd win32codecs real x264 \
ffmpeg xvid acpi divx jack tiff mplayer usb ppds mjpeg lm_sensors xine \
libcaca mng snmp imagemagick wmf dvdread lzo bl syslog css musepack \
async gimpprint logitech-mouse mysql postgres gd pcre png dv zvbi \
dbus gmedia realmedia wmp aiglx pdf seamonkey live theora mozdevelop svg \
mp4 wav examples source cddb corba apache2 tk jpeg2k gs pvr nsplugin xvmc \
webkit "


#VIDEO_CARDS="radeon fbdev fglrx vesa"
VIDEO_CARDS="fbdev fglrx vesa"

INPUT_DEVICES="keyboard mouse joystick evdev"
Comment 1 Tupone Alfredo gentoo-dev 2009-03-25 11:01:40 UTC
What are the use flag you use to build bzflag. An
emerge -pv bzflag 
will show that

Attach your /var/tmp/portage/games-action/bzflag-2.0.12/work/bzflag-2.0.12/config.log to this bug

I'm asking for that as your system is now trying to compile something that it should not, IIRC
Comment 2 Tupone Alfredo gentoo-dev 2009-03-26 14:40:40 UTC
and ... run a 
... just in case
Comment 3 James Horton 2009-03-29 23:49:32 UTC
> revdep-rebuild

Did that, no difference.

I have sync'd and updated system,
twice. Still have same problem.

Maybe somebody with kde 4.2.1 can
verify compile problem or OK?
Comment 4 Mr. Bones. (RETIRED) gentoo-dev 2009-03-30 00:07:28 UTC
still no config.log
Comment 5 James Horton 2009-03-31 00:23:13 UTC
Re-compiled all packages listed in bzflag ebuild,
re-syncd and now bzflag compiles....

Fixed (or never broken) just on my system.....
Comment 6 Tupone Alfredo gentoo-dev 2009-03-31 07:45:49 UTC
Well, not having the config.log does not allow me to se what happened. And now that it works you don't have that info anymore. 


Enjoy playing!