Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263521 - Cannot emerge portage - python >=2.4 masked by EAPI errors
Summary: Cannot emerge portage - python >=2.4 masked by EAPI errors
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-23 17:46 UTC by James Lamanna
Modified: 2009-03-26 03:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Lamanna 2009-03-23 17:46:05 UTC
I after doing an emerge sync, I cannot emerge portage.
I receive the following error:

fs0 ~ # emerge portage
Calculating dependencies |
!!! All ebuilds that could satisfy ">=dev-lang/python-2.4" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/python-2.5.4-r2 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.5.2-r7 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.4.4-r5 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.4.4-r6 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.5.2-r8 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.4.4-r15 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.4.4-r14 (masked by: required EAPI 1, supported EAPI 0)
- dev-lang/python-2.6.1-r1 (masked by: required EAPI 2, supported EAPI 0)
# Ali Polatel <hawking@gentoo.org> (05 Oct 2008)
# Masked until packages that don't work with it are fixed.
# see bug #230205 for more info

- dev-lang/python-2.6-r5 (masked by: required EAPI 2, supported EAPI 0)

For more information, see MASKED PACKAGES section in the emerge man page or 
refer to the Gentoo Handbook.
(dependency required by "sys-apps/portage-2.1.6.7" [ebuild])


Reproducible: Always
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-23 17:51:36 UTC
So what exactly is your portage version now? emerge --info would be nice.
Comment 2 Zac Medico gentoo-dev 2009-03-23 18:45:23 UTC
You're going to have to completely reinstall because your version of portage is too old and it's unsupported.
Comment 3 Allen Brooker (AllenJB) 2009-03-23 19:34:33 UTC
While officially unsupported, if you'd like to try upgrading your install, there are a number of discussions on the forums[0] and mailing lists that may help you. As these are unsupported I highly recommend you be prepared to reinstall just in case something does go wrong.

[0] http://forums.gentoo.org/viewtopic-t-748073-highlight-.html for example
Comment 4 James Lamanna 2009-03-23 19:41:16 UTC
Hmm, ok.
Unfortunately this is a production box, and re-installing from scratch really isn't an option.
Great.
Comment 5 Max Nokhrin 2009-03-26 03:56:50 UTC
I think the best steps for doing thins are outlined in this post: 
http://blog.jolexa.net/2009/03/25/gentoo-tips-to-upgrade-your-really-old-installation/