Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263494 - net-print/foo2zjs-2010-03-11 version bump
Summary: net-print/foo2zjs-2010-03-11 version bump
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Printing Team
Depends on:
Reported: 2009-03-23 14:29 UTC by hitachi
Modified: 2015-10-18 06:13 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---

posible ebuild file (foo2zjs-20090324.ebuild,5.14 KB, text/plain)
2009-03-25 10:25 UTC, hitachi
possible Makefile (foo2zjs-20090324-Makefile.patch,4.60 KB, text/plain)
2009-03-25 10:25 UTC, hitachi
possible udevfwld (foo2zjs-20090324-udevfwld.patch,7.67 KB, text/plain)
2009-03-25 10:26 UTC, hitachi
output of emerge (output,74.80 KB, text/plain)
2009-03-25 10:31 UTC, hitachi
foo2zjs-20090413.ebuild (foo2zjs-20090413.ebuild,4.37 KB, text/plain)
2009-04-15 05:27 UTC, Roger
foo2zjs-20090413-Makefile.patch (foo2zjs-20090413-Makefile.patch,4.60 KB, text/plain)
2009-04-15 05:29 UTC, Roger
foo2zjs-20090413-udevfwld.patch (foo2zjs-20090413-udevfwld.patch,7.67 KB, text/plain)
2009-04-15 05:30 UTC, Roger
diff -u between 20081129 ebuild in tree and a posible 20090413 (ebuild_diff_20081129-20090413,4.32 KB, text/plain)
2009-04-15 12:16 UTC, hitachi
foo2zjs-20090413-r1.ebuild (foo2zjs-20090413-r1.ebuild,3.85 KB, text/plain)
2009-04-15 18:49 UTC, Roger
foo2zjs-20091016.ebuild (foo2zjs-20091016.ebuild,4.55 KB, text/plain)
2009-10-16 10:34 UTC, Roger
files/foo2zjs-20091016-Makefile.patch (foo2zjs-20091016-Makefile.patch,4.60 KB, text/plain)
2009-10-16 10:36 UTC, Roger
files/foo2zjs-20091016-udevfwld.patch (foo2zjs-20091016-udevfwld.patch,7.67 KB, text/plain)
2009-10-16 10:36 UTC, Roger
foo2zjs-20100528.ebuild (foo2zjs-20100528.ebuild,4.61 KB, text/plain)
2010-06-14 11:13 UTC, Alexandre Borges Marcelo
foo2zjs-20100528-Makefile.patch (foo2zjs-20100528-Makefile.patch,5.11 KB, patch)
2010-06-14 11:14 UTC, Alexandre Borges Marcelo
Details | Diff
foo2zjs-20100528-udevfwld.patch (foo2zjs-20100528-udevfwld.patch,7.86 KB, patch)
2010-06-14 11:14 UTC, Alexandre Borges Marcelo
Details | Diff
foo2zjs-20100528.ebuild (foo2zjs-20100528.ebuild,4.61 KB, text/plain)
2010-06-20 09:05 UTC, Gergan Penkov
foo2zjs-20100528-Makefile.patch (foo2zjs-20100528-Makefile.patch,6.43 KB, patch)
2010-06-20 09:06 UTC, Gergan Penkov
Details | Diff
foo2zjs-20100528-udevfwld.patch (foo2zjs-20100528-udevfwld.patch,7.49 KB, patch)
2010-06-20 09:06 UTC, Gergan Penkov
Details | Diff
foo2zjs-20100911.ebuild (foo2zjs-20100911.ebuild,4.61 KB, text/plain)
2010-09-10 21:59 UTC, Timofey Misarenkov
foo2zjs-20100911-Makefile.patch (foo2zjs-20100911-Makefile.patch,7.42 KB, text/plain)
2010-09-10 21:59 UTC, Timofey Misarenkov
foo2zjs-20100911-udevfwld.patch (foo2zjs-20100911-udevfwld.patch,7.49 KB, text/plain)
2010-09-10 22:00 UTC, Timofey Misarenkov
improved unfinished oficial ebuild (foo2zjs-99999999.ebuild,1.34 KB, text/plain)
2011-04-26 13:19 UTC, Pavel Riha

Note You need to log in before you can comment on or make changes to this bug.
Description hitachi 2009-03-23 14:29:01 UTC
There must have beem some updates to net-print/foo2zjs that gentoo must have
missed. The version today is 2009-03-14 while the tree still is in 20081129.

Reproducible: Always

Steps to Reproduce:
3. compare

Actual Results:  
Out of date program in gentoo.

Expected Results:  
Being always state of the art distro having the newest programs first ;-)
Comment 1 hitachi 2009-03-25 10:25:17 UTC
Created attachment 186204 [details]
posible ebuild file

possible ebuild
Comment 2 hitachi 2009-03-25 10:25:55 UTC
Created attachment 186205 [details]
possible Makefile

possible Makefile
Comment 3 hitachi 2009-03-25 10:26:33 UTC
Created attachment 186207 [details]
possible udevfwld

possible udevfwld
Comment 4 hitachi 2009-03-25 10:30:37 UTC
I never did anything like programming before. I am just trying to not do my real work ;-)
What I did: cp -vi /usr/portage/net-print/foo2zjs/foo2zjs-20081129.ebuild /usr/portage/net-print/foo2zjs/foo2zjs-20090324.ebuild
cp -vi /usr/portage/net-print/foo2zjs/files/foo2zjs-20081129-Makefile.patch/usr/portage/net-print/foo2zjs/files/foo2zjs-20090324-Makefile.patch
cp -vi /usr/portage/net-print/foo2zjs/files/foo2zjs-20081129-udevfwld.patch usr/portage/net-print/foo2zjs/files/foo2zjs-20090324-udevfwld.patch

I change some things in all of those files not really knowing what I am doing. Hope nobody will chop of my head for that.

I attached those three files.
I did not touch anything in foo2zjs-Makefile-20080225.diff or foo2zjs-udevfwld-20080225.diff

I will also attach the output of FEATURES="-strict" emerge -v1 net-print/foo2zjs (I added my own ebuild to keywords)

My printer (Samsung CLP-300) still works. Oh I also changed this foo2zjs_devices_sa3160 thing in my ebuild after emerge. This should not show up again.

And of course I had to download the newest source from and put it to /usr/portage/distfiles/foo2zjs-20090324.tar.gz

Hopefully this is any help to someone.
Comment 5 hitachi 2009-03-25 10:31:42 UTC
Created attachment 186208 [details]
output of emerge

Hope this is any help to someone.
Comment 6 Roger 2009-04-13 18:06:09 UTC
Ditto.  A new snapshot should be made of foo2zjs as many changes have occurred as well as many new printers added to this driver!

Per Changelog, it looks like the developers were making snapshots of the tarball, as the tarball hosted does not contain a filename with versioning, and committing it to the portage tree.

Just a reminder, there is a reason the author/developer of foo2zjs wants users to go to his website -- as such, the likely reason for not stamping the filenames with versioning.

As a work around, we have been just taking snapshots to deal with this issue.

Thanks hitachi for posting your work.

Comment 7 Roger 2009-04-13 18:24:21 UTC
Checking the foo2zjs/Changelog, the following printers have been added to this driver:

Konica-Minolta magicolor 1600W (foo2lava)
Konica-Minolta magicolor 1680MF (foo2lava)
Konica-Minolta magicolor 1690MF (foo2lava)
HP LaserJet M1319 MFP  Printer only!!
HP LaserJet P2035
Samsung CLX-3175
Oki C3100

Quite a few ICM color profile additions.

My attempts at quickly patching with a snapshot made from today with the migrated 20081129 patch files:

# patch -p1 --dry-run < /usr/local/portage/net-print/foo2zjs/files/foo2zjs-20081129-Makefile.patch 

patching file icc2ps/Makefile
patching file Makefile
Hunk #1 succeeded at 255 (offset 4 lines).
Hunk #2 succeeded at 547 (offset 4 lines).
Hunk #3 succeeded at 575 (offset 4 lines).
Hunk #4 succeeded at 589 (offset 4 lines).
Hunk #5 succeeded at 608 (offset 4 lines).
Hunk #6 succeeded at 743 (offset 4 lines).
Hunk #7 succeeded at 789 (offset 4 lines).
Hunk #8 succeeded at 808 (offset 4 lines).
Hunk #9 succeeded at 818 (offset 4 lines).
Hunk #10 succeeded at 1218 (offset 7 lines).

# patch -p1 --dry-run < /usr/local/portage/net-print/foo2zjs/files/foo2zjs-20081129-udevfwld.patch

patching file foo2zjs-loadfw
patching file hplj10xx.rules
patching file hplj1000
patching file Makefile
Hunk #2 succeeded at 666 (offset 2 lines).
Hunk #3 FAILED at 823.
1 out of 3 hunks FAILED -- saving rejects to file Makefile.rej

A quick hack for getting the first 20081129-Makefile.patch, patch with -p1 and then diff.  Do the same thing for the 20081129-udevfwld.patch, after manually finding the place of insert for Hunk #3.

Hitachi, I'm not expert on this ebuild either, and I just did a similar quick version bump as you're attempting here.  I'll come back within the next day or so and try to submit the newer patches.

BTW, there's probably no real need to attach your successful emerge log as other users will hopefully test emerge and verify their successful emerge. ;-)
Comment 8 hitachi 2009-04-14 14:39:29 UTC
Change log says foo2zjs changed again yesterday.

2009-04-13	Rick Richardson <>
	* Fix: hplj1000 to protect against /lp*

I will see if I can spent a little time for this. I still have the 2009-03-24 foo2zjs-20090324.tar.gz I downloaded that day. If anybody needs this don't hesitated to ask for it.

Fell free to delete the output file.
Comment 9 Roger 2009-04-14 22:33:52 UTC
I don't have permissions to strike those attachments as I'm not the owner of this bug.

I was only stating the numerous newly added printer models to endorse the fact we should version bump this printer driver as well.
Comment 10 Roger 2009-04-15 05:27:34 UTC
Created attachment 188378 [details]

No alterations needed.  Simply copied from foo2zjs-20081129.ebuild!
Comment 11 Roger 2009-04-15 05:29:26 UTC
Created attachment 188380 [details]

No alterations needed.  Simply copied from foo2zjs-20081129-Makefile.patch!
Comment 12 Roger 2009-04-15 05:30:38 UTC
Created attachment 188381 [details]

No alterations needed.  Simply copied from foo2zjs-20081129-udevfwld.patch!
Comment 13 Roger 2009-04-15 05:43:26 UTC
I think my previous attempt to create a 20090413 ebuild, I copied over some older files from 20080225, creating a conflict on the patch files.

As far as the quality of Color 2BPP printing, it looks really good just using the CUPS test page printing!  Far superior over the last foo2zjs version.  The latest version of CUPS also makes setting "printer options" very very easy.

Please test what you can to make sure everything works.

If it works for you, then suggest submittal into Portage.  Enjoy! ;-)
Comment 14 Roger 2009-04-15 06:58:48 UTC
FYI: I'm looking over the ebuild, and am not making much sense of how to add any additional icm profiles that might be available.

I don't know where the tarballed icm's within the ebuild are acquired (getweb?).

(I would suggest people having the printers with the newer additional printer drivers or devices with the added icm profiles, open a New Bug for foo2zjs along with any patches.  Since I didn't originally write the ebuild or patches, this would require me to read through too much code, for printers for which I don't even have!)
Comment 15 hitachi 2009-04-15 12:06:42 UTC
this is to simple. Doing it this way you are missing 5 printers like "km1690" "km1680" "km1600w" "sa3175" "oki3100". Also you are missing like 20 URIS or more (well some are there more than once).
Comment 16 hitachi 2009-04-15 12:16:04 UTC
Created attachment 188432 [details]
diff -u between 20081129 ebuild in tree and a posible 20090413

This is a diff -u between the 20081129 ebuild which can be found in the tree and an possible 20090413 ebuild.
The printers which are marked as nothing to download are not jet excluded.
Comment 17 Roger 2009-04-15 17:52:25 UTC
Ah!  Now I see the " # extracted by"!  Seems my bash terminal is using the d*rn darker blue for comments. :-(

Anyways, I tried the script, and adding the output.  Both, reformatting the syntax to the bash/ebuild syntax and once merrily copying the output into the script and I get an error while performing "ebuild foo2zjs-20090413-r1.ebuild:

 * ERROR: net-print/foo2zjs-20090413-r1 failed.
 * Call stack:
 *     , line 1872:  Called _source_ebuild
 *     , line 1811:  Called die
 * The specific snippet of code:
 *      source "${EBUILD}" || die "error sourcing ebuild"
 *  The die message:
 *   error sourcing ebuild

This means, the is outputting bad output sompeplace.  A more minor note, foo2zjs-helper is outputting bad bash syntax for "URIS=()" variable.  Easily fixed, however, the error above is going to require more work.

As I said, I *strongly* suggest version bumping so currently supported printers can utilize the updated 20090413 driver snapshot.  I, myself, omitted using during the last 20081129 snapshot.

Making these additional editions could possibly break already working printers, unless, genstef speaks up here and feels safe with his scripting to output reliably!

To explain the error a little more for you, the output of the helper script is likely not outputting enough DEVICES to match URIS.  And, just counting verified this with 36/36 DEVICES/URIS within the old Ebuilds & 42/40 DEVICES/URIS currently (including the null "" one) using

So, I still recommend pushing this into Portage and open a separate bug for fixing -- and then releasing 20090413-r1 or more current snapshot.  Besides, unless genstef can modify his file, posting a fix here for the private script could easily get lost.  (Can somebody bug genstef?  I'd hate to reassign the bug to him & find him on vacation!)
Comment 18 Roger 2009-04-15 18:49:14 UTC
Created attachment 188480 [details]

Updated device ICM files, but, either manually edited and/or using a broken

Needs debugging!
Comment 19 Roger 2009-04-15 18:53:22 UTC
  I seem to understand and believe everything is alright and compares with the output of a manual ./webget all the way up until the last four lines of script.  I'm still trying to make sense of the last four lines and this might be where it's omitting 2 files?  <shrugs> I think I'm still stupified with script someplace.

I'm now looking at your last diff and see you did a lot of the manual editing (or whatever).  So I used foo2zjs-20090413.ebuild and manually included your diff.

I a lot of these types of warnings though during ebuild digest:
"Note: Empty target in string. (Deprecated)
  --> foo2zjs_devices_hpp1007? foo2zjs_devices_hpp1007? []
Note: Empty target in string. (Deprecated)
  --> foo2zjs_devices_hpp1006? foo2zjs_devices_hpp1006? []
Note: Empty target in string. (Deprecated)
  --> foo2zjs_devices_hpp1005? foo2zjs_devices_hpp1005? []"

However, ebuild does successfully create the digest file.

So.  So far, we have:

foo2zjs-20090413.ebuild: Uses the old icm profile names without updating with the helper script. (These ICM file urls are known to mostly work for everyone still).

foo2zjs-20090413-r1.ebuild:  Updated using helper script, but heavily manually edited -- broken script???
Comment 20 Roger 2009-04-15 19:07:02 UTC
Comment on attachment 188480 [details]

Marking obsolete because this does not include all of the ICM files for each printer!!!

For example, I have a hp2600n.  webget shows I have three files to get for this model while, the URIS within this ebuild only show one per each device!
Comment 21 Roger 2009-04-15 19:29:46 UTC
hitachi, see if you can roll out a foo2zjs-20090413-r1.ebuild with the newer ./getweb ICM files.

foo2zjs-20090413.ebuild works for me, and likely for everybody else with the past supported printers. (ie. WORKS FOR ME!)

If I get time during the weekend, I'll go one by one with getweb for each printer model, else, I'm struck by God and I suddenly understand the last four lines of the helper script.  (It might be the only way to figure out where the bug is in the helper script.)

For example, the hp2600n model you should see something like this in the ebuild:

DEVICES=("hp2600n", ..."
URIS=(""", ...)

(FYI: ./getweb seems to be pulling one more tarball for 2600n when comparing to 
the older ebuilds.)

I do see notes within your diff stating there are three printers with no files to get.  This isn't true as it seems two of the printers, 2160 & 3160, are pulling the following using ./getweb:

Hence, for each DEVICE we have, we (may) need to get a set of files (URI's).

My plan this weekend, if you don't do it by then, is to add each printer model one by one instead of using the helper script.  ... time permitting. :-/
Comment 22 hitachi 2009-05-14 08:48:24 UTC
Some time passed. Well I had none to invest here, sorry.
Today I downloaded the new source 20090511. I uploaded the source to my (crippled) web page:
Maybe it is better to work from there. Then it will not change without warning.

In this new snapshot I am unable to find the getweb file. Anyway in the file there are copyright statements. I believe the missing getweb is a bug.
Comment 23 hitachi 2009-05-14 14:06:40 UTC
OK. I learned one has to run make first. Than the getweb file will be there ;-)
Comment 24 Roger 2009-05-14 18:34:12 UTC
Sorry.  I'm just so busy, haven't had the time to decipher the list of files, etc.

Although print looks better then the last version, I'm now having difficulty printing envelope addresses using openoffice/cups and this driver again.

(Never could simply use Open Office > Insert > Envelope.  I had to hack together a envelope.odt file that finally worked, and then it worked using this file for the past year(s) until just recently.  All three packages have had significant upgrades within the past months from genlop -l. :-/ )

So, if the printer fails printing the orientation correctly for envelopes after this driver upgrade, it's likely the driver. ... this might be something to watch for.
Comment 25 hitachi 2009-05-14 18:48:44 UTC
There is an option like ./getweb all. Why not just take an snapshot of everything and put it to the source. Those files are like 10 MB together. Then we wouldn't need to take care of this hole uri stuff.

This printing stuff in gentoo seems to be outdated. Like Bug 257937 or 269865
Comment 26 Martin Väth 2009-05-24 16:11:22 UTC
The above file foo2zjs-20090413-udevfwld.patch is not a good choice,
since it supports only the HP 10* printer series but not e.g. HP P1505
although they should be treated similarly (i.e. also HP P1505 needs the
firmware copied at every start of the printer).

I opened bug 271079 with a version of foo2zjs-20090413-udevfwld.patch which supports all printers supported by foo2zjs-20081129.
I suppose that the same patch will also work for the new foo2zjs release;
I did not check foo2zjs-20090413 yet, but perhaps it supports even more
printers which need a firmware download so that it might be reasonable to
extend the patch of bug 271079 even further.
Comment 27 Roger 2009-05-24 23:00:15 UTC
(My ping here.)

Thanks Martin.  I've got little idea how the two patch files work & simply copied them over from initial import.

Everybody else whom needs these new firmwares is welcome to work on inclusion, as I've got very little time this summer into the fall.

I'm guessing, the main feature for using getweb is to make sure you're using updated firmware regardless of source snapshot or version. However, then we should call the version of snapshot an svn version!  So, maybe it is a good idea to just tarball all the firmwares with each release/snapshot?

Another reason for the previous ebuild developer's work with (getweb) & inclusion into the ebuild, was to enhance simplicity with later snapshots.  Going from memory, the script he created has to be also augmented for the number of firmwares or something... likely using variables would have made reading & maintaining easier.

The very likely reason he used getweb instead of tarballing the firmwares was to prevent the additional inclusion of space consuming code, but yea IMO, 10MB total is extremely minimal when compared to most other projects & it would enhance ebuild maintenance here just to tarball all the firmwares.

With my little time, I'm all for this solution as well.

(Noting an issue with page oversizing when printing from Firefox between Draft & Normal Quality setting.  Anybody else?)
Comment 28 Martin Väth 2009-05-25 18:22:51 UTC
(In reply to comment #27)
> I've got little idea how the two patch files work
> So, maybe it is a good idea to just tarball all the firmwares
> with each release/snapshot?

You are speaking about two different issues here, so let me make it clear:
One thing is how to bring the firmware into files on the computer.
Second thing is how to bring the firmware from the computer into the printer;
at least for the HP printers the latter has to be done whenever the printer
is switched on.

Concerning the first topic, I have not much an opinion; however, I think that
10MB are much, especially if everything is kept unpacked on the machine
(which probably still enlarges the size) and since most people need at most
one of these file. Perhaps this is an option if one keeps the firmware
packed even in the installed package and patches the scripts to unpack
them when needed.

What I spoke about in comment #26 (foo2zjs-*-udevfwld.patch)
concerns only the second issue, i.e. bringing the files from the computer
to the printer: The foo2zjs-*-udevfwld.patch provides udev rules and a
script such that whenever the printer is switched on, the script is called
which in turn copies the firmware from the file to the printer.
My problem was that the original patch supported only a few of the
HP printers in this way although the original foo2zjs package contains
data for more printers (including the one which I needed).

I checked now that the current foo2zjs versoin does also not support more
printers for this second issue than the current version in portage, i.e.
if you just replace the above foo2zjs-20090413-udevfwld.patch above by
the patch I posted in bug 271079, all printers supported by the current
foo2zjs version (w.r.t. this automagic copying of firmware)
will get properly supported. Of course, if you want in future to keep the
firmwire files compressed on the disc, the script in the patch has to be
modified correspondingly to unpack the files for copying to the printer.
Comment 29 John Ratliff 2009-07-20 20:13:04 UTC
Any idea when we can see a new version in portage? The current version is using outdated download servers that no longer exist. I had to go get the newer one from the website to figure out the new download locations.
Comment 30 Roger 2009-07-20 21:53:05 UTC
No.  I have no time to take the lead on this project as I'm overloaded with work at home.  Maybe during winter, I will have time to fix this.

Until then, as I think I already made mention, I'm willing to follow anybody else's lead as to what they plan for a fix to include the newer printers & newer firmwares (or extra files).

Feel free to attach an updated ebuild and I'll try to make time at least to test.

(I think the patches are fine, just adding the newer printers & firmwares is being troublesome.)
Comment 31 Roger 2009-10-16 10:34:12 UTC
Created attachment 207291 [details]

As of this version, install-udev is broken within the ebuild.  It's likely related to only USB udev support.  As such, I've commented it out as I don't need this.  If you need this, then you might want to try fixing.

Trivial: I've also had to had -F3 (fuzz option) for patch for the Makefile patch.
Comment 32 Roger 2009-10-16 10:36:13 UTC
Created attachment 207293 [details]

(Required the -f3 option to patch for patching.  Trivial fix for somebody with nothing better to do.  Still good for release though. ;-)
Comment 33 Roger 2009-10-16 10:36:48 UTC
Created attachment 207294 [details]
Comment 34 Roger 2009-10-16 10:43:10 UTC
Due to the lack of interest on this bug, might I suggest just stripping the ebuild of the USE flags for specifying individual firmwares (as they're only a preventative measure for wasting drive space) and go with just the basic install the author provides?

This ebuild, due to the patching and time consuming maintenance of keeping up with the author's changes, is only delaying each release.  Not too also mention the complete lack of interest with both documenting & submitting the patches.

Also, due to the high cost of replacing all 3-4 toner cartridges, most might just go out and buy a new printer.  Due to both, the cost & lack of keeping up with the ebuild, most might just buy from a different vender.  (I might just finally catch on and buy one with native Linux drivers.)

<shrugs> Just my thoughts. :-/
Comment 35 Roger 2009-10-16 10:46:54 UTC
... btw, to use the 20091016 ebuild, besides putting them in your private /usr/local/portage overlay, you'll also need to quickly pull a snapshot of foo2zjs.tar.gz and do:

$ mv foo2zjs.tar.gz foo2zjs-20091016.tar.gz
$ cp foo2zjs-20091016.tar.gz /usr/portage/distfiles/
$ chown a+r /usr/portage/distfiles/foo2zjs-20091016.tar.gz

... and then hope the patches applied by the ebuild apply cleanly to your snapshot. :-/
Comment 36 hitachi 2010-03-18 07:49:21 UTC
this is just to keep this bug a little up to date. The actual version is 2010-03-11.
Comment 37 Tanktalus 2010-04-07 16:33:48 UTC
20100329 is available now ;-)
Comment 38 Alexandre Borges Marcelo 2010-06-14 11:13:57 UTC
Created attachment 235245 [details]

Hi. Since I had a Samsung CLX-3170 I updated the ebuild to support it on FOO2ZJS_DEVICES. Had to fiddle with the patches to apply cleanly on the last foo2zjs snapshot (2010-05-28).
Comment 39 Alexandre Borges Marcelo 2010-06-14 11:14:18 UTC
Created attachment 235247 [details, diff]
Comment 40 Alexandre Borges Marcelo 2010-06-14 11:14:31 UTC
Created attachment 235249 [details, diff]
Comment 41 Roger 2010-06-15 03:17:23 UTC
FYI: Went out a month ago or so and bought be a HP-M1522NF (multifunciton device) and seems to work pretty good.

Printing: Using CUPS or hplip drivers
Scan to computer: Only hplip (hpiao) SANE binary driver
FAX from computer: Have to install qt junk, so gave up.

Spending the extraordinary amount of money on toner cartridges for the hp2600n color printer seems unfeasible.  So I'm back to using only black & white -- which I rarely ever used color anyways.

Since the HP-M1522NF prints PCL, no need for fussing with extra drivers.
Comment 42 Gergan Penkov 2010-06-20 09:05:45 UTC
Created attachment 236023 [details]

Hallo, here the ebuild and the patches corrected to work with udev and hp devices. foo2zjs still does not work with newer cups and hp printers, because it needs usblp to upload the firmware, so I have made a little workaround to unload the usblp after firmware upload. I have tested the ebuild with HP P1005. The problem with HP printers is, that although they have good build and print quality, their toner consumption is outrageous (nowhere near the 1500 for a cartridge they are saying) and their drivers are the worst I have seen (the printer worked with hplip-driver for a year and after that stopped after an update and I have not found a way to make it work) so after my cartridge was once again empty (using this foo2zjs ebuild), I just bought a brother printer.

The patches follow, hopefully they can help someone....
Comment 43 Gergan Penkov 2010-06-20 09:06:15 UTC
Created attachment 236025 [details, diff]
Comment 44 Gergan Penkov 2010-06-20 09:06:36 UTC
Created attachment 236027 [details, diff]
Comment 45 Nico Baggus 2010-08-31 20:13:37 UTC
The latest ebuilds allready fail now. doesn't resolve any more.
so the "stable" library fails to load.
Comment 46 Timofey Misarenkov 2010-09-10 21:59:10 UTC
Created attachment 246762 [details]

Just an update for ebuild. I edited the last ebuild and patches here, for the current version of foo2zjs.tar.gz from
My hp1022 start to work after this.
Comment 47 Timofey Misarenkov 2010-09-10 21:59:53 UTC
Created attachment 246764 [details]

Comment 48 Timofey Misarenkov 2010-09-10 22:00:38 UTC
Created attachment 246765 [details]

Comment 49 Nico Baggus 2010-09-10 23:25:24 UTC
But this name where the kit should be downloaded  doesn't resolve:
Comment 50 Nico Baggus 2010-09-14 18:44:08 UTC
Why does foo2zjs have to exclude hplip?
I need hplip for one printer, and foo2zjs for another...

They don't seem to conflict on my system.

Please consider: 
- another host (preferably a resolving name) for the download sets
- publish the ip address so it can be entered in
   a /etc/hosts file
- not disable hplip 
Comment 51 David Carlos Manuelda 2010-09-26 16:27:30 UTC
It seems that is down. Any other mirror?
Comment 52 Hanno Böck gentoo-dev 2010-11-27 03:00:57 UTC
I've recently bought a printer that requires this driver. But my printer seems to be a bit less problematic, as it's black-white and seems not to require an external firmware (HP Laserjet P1102).

I've made a preliminary ebuild based on the current upstream source:

It does not install any firmware, hotplug or color profile stuff, so for many people it may not be of much use, but I'd like to share it anyway. For my printer it works flawlessly after manually installing the ppd.

Sadly, upstream seems to be very uncooperative. I've sent him some patches to cleanup the Makefiles, but he just sent me some unfriendly replies that I shouldn't install any distribution packages. So I doubt he'll apply them.
Comment 53 Thomas 2011-02-10 13:07:15 UTC
There is a new foo2zjs version dated 20110205.
Comment 54 Pavel Riha 2011-04-26 13:19:20 UTC
Created attachment 271221 [details]
improved unfinished oficial ebuild

The official ebuild  foo2zjs-99999999 i portage doesn't work for me.
Does not install PPDs and doesn't create the filter symlink.

so I improved it little bit, to fix these two things

Note: as mentioned somewhere, cups didn't see USB printer unless cups is compiled WITHOUT usb use flag! strange, but true (for me)

Comment 55 Andreas K. Hüttel archtester gentoo-dev 2012-01-15 16:39:35 UTC
Well... While I appreciate very much your efforts, the foo2zjs driver has as far as I remember become more or less unmaintainable. So, it was dropped from the main tree except for a "live ebuild" always installing the most current files.

This may also be related to upstream's unwillingness to work with distributions.