Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263235 - x11-drivers/nvidia-drivers-180.29: moving start screen point after opengl screensaver
Summary: x11-drivers/nvidia-drivers-180.29: moving start screen point after opengl scr...
Status: VERIFIED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Ricardo Mendoza (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-21 11:25 UTC by Andrey Niahajchyk
Modified: 2009-06-16 21:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
nvidia-bug-report (nvidia-bug-report.log,129.62 KB, text/plain)
2009-03-21 22:20 UTC, Andrey Niahajchyk
Details
emerge-info (emerge-info.txt,3.41 KB, text/plain)
2009-03-21 22:21 UTC, Andrey Niahajchyk
Details
Photo of bug (img_1342.jpg,215.36 KB, image/jpeg)
2009-03-21 22:22 UTC, Andrey Niahajchyk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Niahajchyk 2009-03-21 11:25:05 UTC
After merging x11-drivers/nvidia-drivers-180.29 incorrect behaviour after closing screensaver.

Reproducible: Always

Steps to Reproduce:
1. EMerge propertiary nvidia drivers v 180.29
2. EMerge kdeartwork-kscreensaver
3. Start screensaver
4. Close screensaver

Actual Results:  
Screen won't be painted from (0,0) point see screenshot

http://javascript.narod.ru/img_1342.jpg
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-21 20:42:08 UTC
Please post your "emerge --info" and attach the output of the nvidia-bug-report.sh script.
Comment 2 Andrey Niahajchyk 2009-03-21 21:42:04 UTC
emerge --info
---------
Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-glibc2.2.5
Timestamp of tree: Sat, 21 Mar 2009 08:45:03 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mirror.web4u.cz/ ftp://gentoo.mirror.web4u.cz/ http://gentoo.mneisen.org/ http://de-mirror.org/distro/gentoo/ http://gentoo.mirror.pw.edu.pl/ "
LANG="be_BY.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="be ru en en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 arts bash-completion berkdb bzip2 cli cracklib crypt cups dbus dri ffmpeg flac fortran gdbm gpm hal iconv ipv6 isdnlog jpeg jpeg2k kde lm_sensors midi mmx mp3 mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre perl png pppd python qt3 readline reflection session spl sse sse2 sse3 ssl ssse3 svg sysfs tcpd theora tiff unicode vorbis xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="be ru en en_GB" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 3 Andrey Niahajchyk 2009-03-21 22:03:32 UTC
nvidia-bug-report.sh
---------------
http://niakhaichyk.org/andrey/gentoo/nvidia-bug-report.log

One more thing: I'm usign OpenGL screensaver.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-21 22:12:02 UTC
It's better to attach files to our bugzilla than deposit it somewhere else where it might not be found anymore later.
Comment 5 Andrey Niahajchyk 2009-03-21 22:20:18 UTC
Created attachment 185796 [details]
nvidia-bug-report
Comment 6 Andrey Niahajchyk 2009-03-21 22:21:30 UTC
Created attachment 185798 [details]
emerge-info
Comment 7 Andrey Niahajchyk 2009-03-21 22:22:22 UTC
Created attachment 185799 [details]
Photo of bug
Comment 8 Hans de Graaff gentoo-dev 2009-03-29 12:55:03 UTC
I'm seeing the same on my x86 machine, but I'm using Gnome and I also see this before the screensaver has kicked in. As far as I know I'm not using any OpenGL up to that point. Logging out and then logging in again seems to rectify the problem, but I then see it again after the screensaver has been active, just like Andrew.

Comment 9 Hans de Graaff gentoo-dev 2009-06-01 11:52:15 UTC
Upgraded to 180.60 and the problem seems to have gone away. 
Comment 10 Doug Goldstein (RETIRED) gentoo-dev 2009-06-02 03:46:00 UTC
Andrew,

Please re-test with the latest NVIDIA drivers.
Comment 11 Andrey Niahajchyk 2009-06-15 14:14:29 UTC
Fixed in 180.60
Comment 12 Doug Goldstein (RETIRED) gentoo-dev 2009-06-16 21:24:30 UTC
Great.