Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263135 - net-dns/idnkit doesn't respect LDFLAGS
Summary: net-dns/idnkit doesn't respect LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2009-03-20 16:00 UTC by Davide Pesavento
Modified: 2010-08-09 21:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
files/idnkit-1.0-autotools.patch (idnkit-1.0-autotools.patch,1.08 KB, patch)
2010-03-12 13:24 UTC, Doktor Notor
Details | Diff
idnkit-1.0.ebuild.diff (idnkit-1.0.ebuild.diff,1.04 KB, patch)
2010-03-12 13:24 UTC, Doktor Notor
Details | Diff
idnkit-1.0-autotools.patch (idnkit-1.0-autotools.patch,1.80 KB, patch)
2010-03-12 14:58 UTC, Doktor Notor
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Pesavento gentoo-dev 2009-03-20 16:00:38 UTC
QA Notice: Files built without respecting LDFLAGS have been detected
 Please include the following list of files in your report:
/usr/lib64/libidnkit.so.1.0.2
/usr/lib64/libidnkitlite.so.1.0.2
Comment 1 Doktor Notor 2010-03-12 13:24:07 UTC
Created attachment 223273 [details, diff]
files/idnkit-1.0-autotools.patch
Comment 2 Doktor Notor 2010-03-12 13:24:55 UTC
Created attachment 223277 [details, diff]
idnkit-1.0.ebuild.diff

AFAICT this bundles some buggy old libtool crap in aclocal.m4, try this...
Comment 3 Doktor Notor 2010-03-12 13:34:42 UTC
LOL. That indeed fixed it by not installing any lib at all *g*
Comment 4 Doktor Notor 2010-03-12 14:58:49 UTC
Created attachment 223283 [details, diff]
idnkit-1.0-autotools.patch

OK, this patch fixes the missing libs install with previous one. God knows how it worked until now, ugh.
Comment 5 Jeroen Roovers gentoo-dev 2010-03-30 01:03:35 UTC
Fixed in -r1. Thanks for the patch!