Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 26265 - POSE ebuild has segfaulting problems
Summary: POSE ebuild has segfaulting problems
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: George Shapovalov (RETIRED)
Depends on:
Reported: 2003-08-09 07:04 UTC by Tim Yamin (RETIRED)
Modified: 2004-02-21 01:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Tim Yamin (RETIRED) gentoo-dev 2003-08-09 07:04:04 UTC
It runs fine until I decide to get m68k-palmos-gdb and do some debugging. Once I
start the application in POSE, it segfaults. I can't exactly strace it: too
messy, not to mention the bug probably occurs in one of the forked processes.

The binary inside the prebuilt RPM works fine. Both are built as static
executables. This doesn't seem to be an FLTK bug...

This GDB was configured as "i686-pc-linux-gnu"...
(no debugging symbols found)...
Starting program: /usr/bin/pose
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 16384 (LWP 5090)]
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 32769 (LWP 5091)]
[New Thread 16386 (LWP 5092)]
(no debugging symbols found)...
Program received signal SIGABRT, Aborted.
[Switching to Thread 16386 (LWP 5092)]
0x401bf1d1 in kill () from /lib/
(gdb) backtrace
#0  0x401bf1d1 in kill () from /lib/
#1  0x401230aa in pthread_kill () from /lib/
#2  0x401233a8 in raise () from /lib/
#3  0x401bef7a in raise () from /lib/
#4  0x401c0579 in abort () from /lib/
#5  0x08394b13 in std::bad_exception::~bad_exception() ()
#6  0x08394b54 in std::bad_exception::~bad_exception() ()
#7  0x08394d00 in std::bad_exception::~bad_exception() ()
#8  0x08209700 in XMapRaised ()
#9  0x08208568 in XMapRaised ()
#10 0x08204ff0 in XMapRaised ()
#11 0x08204d3a in XMapRaised ()
#12 0x0807e96a in XMapRaised ()
#13 0x0807e9d1 in XMapRaised ()
#14 0x0828c48e in XMapRaised ()
#15 0x082ca385 in XMapRaised ()
#16 0x0831b7f3 in XMapRaised ()
#17 0x0828ba25 in XMapRaised ()
#18 0x081e5f7b in XMapRaised ()
#19 0x081e73ab in XMapRaised ()
#20 0x081e7247 in XMapRaised ()
#21 0x083441b6 in XMapRaised ()
#22 0x40120b49 in pthread_start_thread () from /lib/
#23 0x40120c44 in pthread_start_thread_event () from /lib/

I also have a core dump if you need it...
Comment 1 Tim Yamin (RETIRED) gentoo-dev 2003-08-09 07:10:04 UTC
BTW, there are no error messages of any sort either. I've tried building removing the CPU optimizations, that gives the same result.
Comment 2 Tim Yamin (RETIRED) gentoo-dev 2003-08-21 13:22:24 UTC
Still happens with pose-r2...
Comment 3 George Shapovalov (RETIRED) gentoo-dev 2004-01-27 00:54:00 UTC
Hi plasmaroo.

Please test the -r3. It now builds against fltk correctly (just one version gets involved) and has some gcc-3.3 fixes. If this still happens please note commented out lines in the ebuild. There are few apparent ones that add pose with debug info for profiling and debugging. This might be just what you are looking for..

Comment 4 George Shapovalov (RETIRED) gentoo-dev 2004-02-21 01:08:24 UTC
In stable (the -r4 one, has one more fix)