Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262182 - mail-client/mail-notification-5.4 causes evolution-2.24 to crash
Summary: mail-client/mail-notification-5.4 causes evolution-2.24 to crash
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Hans de Graaff
URL: https://bugs.launchpad.net/mail-notif...
Whiteboard:
Keywords:
Depends on:
Blocks: 266006
  Show dependency tree
 
Reported: 2009-03-11 19:41 UTC by Pacho Ramos
Modified: 2009-04-01 06:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mail-notification-5.4-evolution.patch (mail-notification-5.4-evolution.patch,807 bytes, patch)
2009-03-11 19:41 UTC, Pacho Ramos
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2009-03-11 19:41:25 UTC
It's important fix this quickly as users upgrading from evolution-2.22 to 2.24 will get their evolution crashing at startup if they have this plugin enabled, this has been already sent to ubuntu, fedora and mandriva:
https://bugs.launchpad.net/mail-notification/+bug/251031
https://bugzilla.redhat.com/show_bug.cgi?id=464779

I am using fedora patch and it's working fine

Thanks a lot

Portage 2.1.6.7 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r3-x86_64-AMD_Athlon-tm-_64_Processor_3200+-with-glibc2.2.5
Timestamp of tree: Wed, 11 Mar 2009 08:00:01 +0000
distcc 3.0 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -msse3"
DISTDIR="/usr/distfiles"
FEATURES="autoaddcvs ccache collision-protect cvs distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 amr asf audiofile avahi bash-completion beagle berkdb bzip2 bzlib cairo caps cdb cdda cddb cdinstall cdparanoia cdr cleartype cli consolekit cpdflib cracklib cross crypt css cups curl daap dbus dga dirac divx4linux djvu dlloader dri dts dv dvb dvd dvdr dvdread dvi eds emboss encode epiphany erandom escreen evo evolution exif fam fame fbcon ffmpeg flac foomaticdb fortran ftp fuse galago gb gcj gd ggi gif gimp gimpprint git glib glitz glut glx gnome gnome-keyring gnome-print gphoto2 gpm gsm gstreamer gtk gtk2 hal iconv idn imagemagick imlib inotify isdnlog ithreads jabber java java6 jfs jpeg jpeg2k kdeenablefinal kdehiddenvisibility kpathsea lame latex lcms libnotify lm_sensors logrotate lzma mad madwifi midi mikmod mime mjpeg mmx mmxext mng mono moonlight motif mp3 mpeg mpi mplayer mudflap multilib musepack musicbrainz nas nautilus ncurses nethack network networkmanager nls nocardbus nptl nptlonly ntp nvidia ogg oggvorbis openal opengl openmp pam pango pch pcre pdf perl plotutils png posix postscript ppds pppd python qt3 qt3support qt4 quicktime readline reflection remote rtc scanner schroedinger scrobbler sdl session slang slp sockets speex spell spl sse sse2 sse3 ssl ssse3 startup-notification subversion svg sysfs sysvipc t1lib tcpd theora threads thunderbird tiff timidity totem trayicon truetype unicode usb v4l2 vcd videos vim vorbis webkit wma wmf x264 xattr xcb xcomposite xfs xft xine xml xml2 xmp xorg xpm xulrunner xv xvid xvmc zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa fbdev vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2009-03-11 19:41:49 UTC
Created attachment 184727 [details, diff]
mail-notification-5.4-evolution.patch
Comment 2 David Krider 2009-03-18 00:23:56 UTC
(In reply to comment #1)
> Created an attachment (id=184727) [edit]
> mail-notification-5.4-evolution.patch
> 

I don't know much about this stuff, but eds is now at 2.24.5. Changing the version number in the patch file appropriately got it working for me. Thanks!
Comment 3 Pacho Ramos gentoo-dev 2009-03-30 10:12:28 UTC
Patch is working fine for me and fixing the crash since I sent it here. I know that probably you are too busy but, maybe, somebody else could get this in as I think it's severe enough.

Thanks a lot
Comment 4 Hans de Graaff gentoo-dev 2009-03-30 18:14:44 UTC
The patch as-is won't work because evolution-data-server is a moving target. Instead I've fixed this unconditionally, and mail-notification-5.4-r1 now depends on evolution 2.24. This combination should work as expected.

I'd appreciate some feedback on whether this version fixes things as expected. Getting feedback will help to stabilize this sooner than the normal 4 weeks.

Pacho, thanks for reporting and digging up the original patch.
Comment 5 David Krider 2009-03-31 10:09:55 UTC
Working here... Thanks for fixing this up!
Comment 6 Pacho Ramos gentoo-dev 2009-04-01 06:37:18 UTC
Thanks a lot, I will update as soon as possible for me (I am a bit busy in real life just now)