Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 2616 - ps/2 keyboard does not work after install
Summary: ps/2 keyboard does not work after install
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Brandon Low (RETIRED)
: 2621 (view as bug list)
Depends on:
Reported: 2002-05-09 10:30 UTC by Jani Talikka
Modified: 2003-02-04 19:42 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

.config file for gentoo-sources-2.4.19r5 keyboard does not work (gentoo-2.4.19r5.config,18.88 KB, text/plain)
2002-05-11 12:11 UTC, Jani Talikka
.config file for vanilla-sources keyboard works fine (workingvanilla.config,17.25 KB, text/plain)
2002-05-11 12:12 UTC, Jani Talikka
dmesg output with gentoo-sources-2.4.19r5 (gentoo-2.4.19r5.dmesg,8.42 KB, text/plain)
2002-05-11 20:42 UTC, Jani Talikka
dmesg output from vanilla-sources 2.4.18 with which keyboard works (vanilla-2.4.18.dmesg,7.36 KB, text/plain)
2002-05-11 20:44 UTC, Jani Talikka

Note You need to log in before you can comment on or make changes to this bug.
Description Jani Talikka 2002-05-09 10:30:31 UTC
After an install from stage 1 off the 1.1a ISO, everything seems fine, keyboard 
works in grub boot menu, rest of booting works (can't see any errors), keyboard 
does not work.  As the keyboard doesn't work I can't log in to read dmesg or 
any of the logs.  Even the num lock and caps lock lights get stuck where they 

I've tried 2 complete installs and several different kernel sources (gentoo-
sources and the sun xfs kernel), and numerous different kernel configs, and the 
problem remains the same.
Comment 1 Jani Talikka 2002-05-09 10:36:00 UTC
My hardware is as follows:
Epox 8KHA+ motherboard
Athlon XP 1600+
768Mb ddr ram
usb mouse (cypress semiconductors)
standard ps/2 keyboard
sound blaster vibra 128 sound card
netgear fa310tx network card
geforce 2GTS agp graphics card
atapi cdrom
2 40gig seagate barracude iv hard drives
1 60gig ibm gxp60 dethstar hard drive (intermittently unreliable, not used to 
store anything important)
Comment 2 Bart Lauwers (RETIRED) gentoo-dev 2002-05-09 11:02:34 UTC
# cat /dev/mouse/mice

If this gives garbage on the console when you move the mouse and the driver
works at kernel level so it would be a matter of your setup. If that does not
generate some output your kernel doesn't have support for it. It could be the
modules are simply not loaded, so check that first before recompiling the
kernel. You can use modprobe to test load the modules you need after which you
can add them to /etc/modules.autoload for boot time loading.

You'll need support for: input, mousedev, usbcore, usbhid, usbhiddev and
usbinput in your kernel or as a module.
Comment 3 Bart Lauwers (RETIRED) gentoo-dev 2002-05-09 11:16:49 UTC
Did you see bug 467, is this a duplicate?
Comment 4 Jani Talikka 2002-05-09 11:17:47 UTC
No, it's not the mouse, it's the keyboard which does not work.  The keyboard is 
a ps/2 keyboard.  The keyboard not working means I can't log in and can't type 
anything. Unplugging the usb mouse did not make any difference either.
Comment 5 Bart Lauwers (RETIRED) gentoo-dev 2002-05-09 17:14:13 UTC
Ok, can you check if you have PS2 mouse support in your kernel?
Comment 6 jakd 2002-05-09 17:25:25 UTC
i'm getting this too.  specifically:
  keyboard: Timeout - AT keyboard not present?(ed)

a similar build off vanilla sources gives me back the keyboard.
Comment 7 Jani Talikka 2002-05-09 21:03:05 UTC
No, I don't have ps2 mouse support compiled in the kernel, only input/mouse 
support, usb, usb-uhci, hid support.  I'll try the vanilla kernel to see if 
that fixes it.
Comment 8 Jani Talikka 2002-05-09 22:17:25 UTC
building the vanilla-kernel did not help me. compiling vanilla-kernel with ps2 
mouse support did not help either.
Comment 9 Jani Talikka 2002-05-09 23:18:56 UTC
I have made my keyboard work by removing the 2.4.19 kernel source files, and 
then compling the 2.4.18 kernel.
the 2.4.19 sources seem to be broken for ps2 keyboards.
Comment 10 Jeld The Dark Elf 2002-05-10 03:18:20 UTC
*** Bug 2621 has been marked as a duplicate of this bug. ***
Comment 11 Daniel Robbins (RETIRED) gentoo-dev 2002-05-10 21:46:56 UTC
I'm a bit confused.  Did the vanilla sources work for you or not?
Comment 12 Jani Talikka 2002-05-11 05:10:39 UTC
apologies for the confusion,

yes, vanilla-sources do work (last time i tried them I still had gentoo-sources 
emerged and hadn't changed the /usr/src/linux link to point to the vanilla 
sources, so I didn't actually try them)
Comment 13 Net 2002-05-11 09:06:31 UTC
Absolutely the same problem as described by Jani Talikka. Gentoo linux 1.1a 
installed from scratch (stage 1).
I used the gentoo-sources to compile the kernel, and the keyboard simply does 
not work at login prompt, so I can't do anything to see the dmesg. However a 
quick glimpse at startup shows that there is a problem with the calculation of 
the module dependancies. I have compiled everything into the kernel except my 
network driver (ne2k-pci) so this is the only module I have put 
in /etc/modules.autoload. I have not configured PS2 support, since I don't need 
it for my mouse and if that is the trivial rookie mistake, please, let me know. 
Note that I have a USB mouse supported by the compiled kernel (built-in 
What is the version of the source tree? I don't know ( I am writing this from 
the M$ Win portion of my dual boot machine and can't check right now) but I 
downloaded it this Thursday.

My hardware is as follows:
Motherboard LS-K7VAT
Duron 800 MHz
384Mb sdram
usb mouse (Microsoft Intellimouse)
standard ps/2 keyboard
ne2k-pci network card
ATI RAdeon VE graphics card
20gig Quantum Fireball LM HDD

Please suggest a solution. Should I give up and compile against the vanilla 
Comment 14 Daniel Robbins (RETIRED) gentoo-dev 2002-05-11 09:35:27 UTC
Off the top of my head, I'd say try disabling ACPI support in your kernel if
enabled.  It would be helpful if you could grab the /usr/src/linux/.config file
from your systems and attach it here.
Comment 15 Jani Talikka 2002-05-11 12:11:35 UTC
Created attachment 949 [details]
.config file for gentoo-sources-2.4.19r5 keyboard does not work

This is my latest attempt with gentoo-sources to get keyboard working, but on
boot up, there is a message which flashes past something to do with:timeout AT
keyboard not present.
Comment 16 Jani Talikka 2002-05-11 12:12:39 UTC
Created attachment 950 [details]
.config file for vanilla-sources keyboard works fine

this is my .config file which I use with vanilla-sources and the keyboard works
Comment 17 Daniel Robbins (RETIRED) gentoo-dev 2002-05-11 16:55:13 UTC
Try 24.19-r5 with ACPI disabled and see if that works.
Comment 18 Jani Talikka 2002-05-11 20:42:40 UTC
Created attachment 957 [details]
dmesg output with gentoo-sources-2.4.19r5

I enabled sshd on startup, started the broken kernel, used ssh to login to do a
dmesg, and here is the the dmesg from the same build of kernel as the .config
attachment 949 [details].  the corresponding dmesg output for the vanilla kernel will
follow in the next attachment
Comment 19 Jani Talikka 2002-05-11 20:44:49 UTC
Created attachment 958 [details]
dmesg output from vanilla-sources 2.4.18 with which keyboard works

For comparison this is dmesg output from the vanilla kernel corresponding to
the .config file I provided in attachment 950 [details]

my next step is to try disabling acpi on the 2.4.19r5 kernel, will keep you
Comment 20 Jani Talikka 2002-05-12 04:08:08 UTC
gentoo-sources-2.4.19r5 with ACPI disabled works fine.  keyboard just works, 
like it should.  should this still be a bug?
Comment 21 Daniel Robbins (RETIRED) gentoo-dev 2002-05-16 13:33:07 UTC
Follow the instructions I added to the end of bug 2590 and see if using the new
ACPI snapshot solves this problem.  If not, then the problem should be sent
upstream to the ACPI developers themselves.
Comment 22 Joachim Blaabjerg (RETIRED) gentoo-dev 2002-08-13 04:34:47 UTC
Is this still an issue? I'd like to close the bug if the problem's gone in later
Comment 23 Jani Talikka 2002-08-14 03:19:59 UTC
vanilla-sources 2.4.19 resolves the issue, and I can select ACPI support in the
kernel without causing the keyboard to fail.
gentoo-sources 2.4.19-r7 worked well when ACPI was deselected.  I don't think
I've tried gentoo-sources 2.4.19-r7 with ACPI.
Comment 24 Brandon Low (RETIRED) gentoo-dev 2002-09-06 17:37:34 UTC
This should work find in gentoo-sources-2.4.19-r9, I'm closing the bug, please
re-open it if the bug still exists in 2.4.19-r9, thanks.