Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 261517 - virtualbox-ose-2.1.4-r1 fails with tstVMStructGC: cannot execute binary file
Summary: virtualbox-ose-2.1.4-r1 fails with tstVMStructGC: cannot execute binary file
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Markus Ullmann (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-07 01:38 UTC by rick vernam
Modified: 2009-09-12 12:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,193.25 KB, text/plain)
2009-03-07 01:42 UTC, rick vernam
Details
emerge --info (emerge.info,3.47 KB, text/plain)
2009-03-07 01:43 UTC, rick vernam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rick vernam 2009-03-07 01:38:50 UTC
tstVMStructGC is a 32-bit executable.
The system I am building does not have any support for 32-bit executables (not in kernel or userspace).
virtualbox-ose-2.0.4 builds and works fine on this system, as does virtualbox-bin-2.1.4.

Reproducible: Always

Steps to Reproduce:
1.emerge virtualbox-ose-2.1.4-r1
2.
3.

Actual Results:  
/var/tmp/portage/app-emulation/virtualbox-ose-2.1.4-r1/work/VirtualBox-2.1.4_OSE/out/linux.amd64/release/bin/tstVMStructGC: /var/tmp/portage/app-emulation/virtualbox-ose-2.1.4-r1/work/VirtualBox-2.1.4_OSE/out/linux.amd64/release/bin/tstVMStructGC: cannot execute binary file
Comment 1 rick vernam 2009-03-07 01:42:15 UTC
Created attachment 184191 [details]
build log
Comment 2 rick vernam 2009-03-07 01:43:24 UTC
Created attachment 184193 [details]
emerge --info
Comment 3 rick vernam 2009-03-07 01:44:54 UTC
Portage 2.2_rc23 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27.10 x86_64)
=================================================================                         
System uname: Linux-2.6.27.10-x86_64-AMD_Athlon-tm-_64_Processor_3700+-with-glibc2.2.5    
Timestamp of tree: Sat, 07 Mar 2009 00:00:01 +0000                                        
app-shells/bash:     3.2_p39                                                              
dev-lang/python:     2.5.2-r7                                                             
dev-python/pycrypto: 2.0.1-r6                                                             
dev-util/cmake:      2.6.2-r1                                                             
sys-apps/baselayout: 1.12.11.1                                                            
sys-apps/sandbox:    1.2.18.1-r2                                                          
sys-devel/autoconf:  2.13, 2.63                                                           
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2             
sys-devel/binutils:  2.18-r3                                                              
sys-devel/gcc-config: 1.4.0-r4                                                            
sys-devel/libtool:   1.5.26                                                               
virtual/os-headers:  2.6.27-r2                                                            
ACCEPT_KEYWORDS="amd64"                                                                   
CBUILD="x86_64-pc-linux-gnu"                                                              
CFLAGS="-O2 -march=k8 -pipe"                                                              
CHOST="x86_64-pc-linux-gnu"                                                               
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=k8 -pipe"                                                                                                                                         
DISTDIR="/usr/portage/distfiles"                                                                                                                                       
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                    
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"                                                                  
LDFLAGS="-Wl,-O1"                                                                                                                                                      
LINGUAS="en"                                                                                                                                                           
MAKEOPTS="-j2"                                                                                                                                                         
PKGDIR="/root/binpkgs"                                                                                                                                                 
PORTAGE_CONFIGROOT="/"                                                                                                                                                 
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"                                                                                                                                                                     
PORTDIR="/usr/portage"                                                                                                                                                                        
SYNC="rsync://rsync.gentoo.org/gentoo-portage"                                                                                                                                                
USE="3dnow a52 aac acl acpi aiglx alsa amd64 avahi avi berkdb bzip2 cairo cli cracklib crypt cups dbus dri dv dvd dvdr eps ffmpeg flac fortran gdbm geoip gpm gs hal iconv ieee1394 ipv6 isdnlog jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility lame logitech-mouse midi mmap mmx mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg oggvorbis opengl openmp pam pcre pdf perl png pppd python qt readline reflection samba sane session spell spl sse sse2 ssl subversion svg svn sysfs tcpd tiff truetype unicode userlocales vorbis wifi winbind x264 xcomposite xine xorg xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard wacom evde
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-07 09:28:33 UTC
Reassigning to/CCing maintainers.
Comment 5 rick vernam 2009-03-12 02:17:28 UTC
any additional information required, or would be useful for this?
Thanks...
Comment 6 Alessio Cassibba (X-Drum) 2009-09-10 16:00:04 UTC
This bug should be closed since this release is 
not available in portage (see bug #260331).