Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 260965 - >=gnome-base/nautilus 2.24.0: tabs with no scrollbars, weird behavior
Summary: >=gnome-base/nautilus 2.24.0: tabs with no scrollbars, weird behavior
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: Inclusion
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-03-02 17:11 UTC by makism
Modified: 2009-03-09 23:55 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
modified the ebuild to patch the source (nautilus-2.24.2.ebuild,1.85 KB, text/plain)
2009-03-02 17:36 UTC, makism
Details
the actual patch (taken from GNOME`s bugzilla) (fix_scrollbars_into_tabs.patch,567 bytes, patch)
2009-03-02 17:37 UTC, makism
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description makism 2009-03-02 17:11:32 UTC
First of all i reported this bug upstream, and i found out that this has been resolved in the trunk.

Tabs are created without scrollbars.

Reproducible: Always

Steps to Reproduce:
1. Open nautilus
2. Open a couple of tabs
3. Browse through the opened tabs.

Actual Results:  
You`ll notice that there are scrollbars (when needed). Must "Refresh" every tab to temporarly gain the scrollbars.

Expected Results:  
The opened tabs should have scrollbars (when needed).

Here is the closed bug at gnome`s bugzilla:
http://bugzilla.gnome.org/show_bug.cgi?id=542396

And here is the proposed patch (again from gnome`s bugzilla):
http://bugzilla.gnome.org/attachment.cgi?id=126265
Comment 1 makism 2009-03-02 17:36:58 UTC
Created attachment 183690 [details]
modified the ebuild to patch the source
Comment 2 makism 2009-03-02 17:37:24 UTC
Created attachment 183692 [details, diff]
the actual patch (taken from GNOME`s bugzilla)
Comment 3 makism 2009-03-02 17:38:08 UTC
(In reply to comment #0)
> First of all i reported this bug upstream, and i found out that this has been
> resolved in the trunk.
> 
> Tabs are created without scrollbars.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Open nautilus
> 2. Open a couple of tabs
> 3. Browse through the opened tabs.
> 
> Actual Results:  
> You`ll notice that there are scrollbars (when needed). Must "Refresh" every tab
> to temporarly gain the scrollbars.
> 
> Expected Results:  
> The opened tabs should have scrollbars (when needed).
> 
> Here is the closed bug at gnome`s bugzilla:
> http://bugzilla.gnome.org/show_bug.cgi?id=542396
> 
> And here is the proposed patch (again from gnome`s bugzilla):
> http://bugzilla.gnome.org/attachment.cgi?id=126265
> 

using the patch, i can confirm that the problem is resolved.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-03-02 17:43:53 UTC
fixing summary line.
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-03-09 23:55:42 UTC
in 2.24.2-r1. Thanks for reporting and the patch.