Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 260840 - net-analyzer/ettercap-0.7.3-r3 fails to build with debug flag enabled (-Werror)
Summary: net-analyzer/ettercap-0.7.3-r3 fails to build with debug flag enabled (-Werror)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
: 272295 (view as bug list)
Depends on:
Blocks: fortify-source werror
  Show dependency tree
 
Reported: 2009-03-02 10:29 UTC by Alexandre Ney
Modified: 2009-06-05 14:01 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,22.83 KB, text/plain)
2009-03-02 10:45 UTC, Alexandre Ney
Details
build.log (build.log,26.80 KB, text/plain)
2009-03-02 21:50 UTC, David Berger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Ney 2009-03-02 10:29:50 UTC
I can't seem to build this package with the debug flag enabled (i'm trying to do that because i keep on segfaulting without the debug flag)

I have tried to disable ccache and use -j1 but that didn't change anything. I'm fully up to date and have experienced the same problem on my other machine (also amd64)

Reproducible: Always

Steps to Reproduce:
1. add the debug flag to package.use
2. emerge

Actual Results:  
I cried

Expected Results:  
Get built

Portage 2.2_rc23 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r2 x86_64)       
=================================================================                                               
System uname: Linux-2.6.28-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-glibc2.2.5          
Timestamp of tree: Mon, 02 Mar 2009 08:45:01 +0000                                                              
distcc 3.1 x86_64-pc-linux-gnu [disabled]                                                                       
ccache version 2.4 [disabled]                                                                                   
app-shells/bash:     3.2_p48-r1                                                                                 
dev-java/java-config: 2.1.7                                                                                     
dev-lang/python:     2.5.4-r2                                                                                   
dev-util/ccache:     2.4-r8                                                                                     
dev-util/cmake:      2.6.3                                                                                      
sys-apps/baselayout: 2.0.0                                                                                      
sys-apps/openrc:     0.4.3-r1                                                                                   
sys-apps/sandbox:    1.3.8                                                                                      
sys-devel/autoconf:  2.13, 2.63                                                                                 
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                                  
sys-devel/binutils:  2.19.1                                                                                     
sys-devel/gcc-config: 1.4.1                                                                                     
sys-devel/libtool:   2.2.6a                                                                                     
virtual/os-headers:  2.6.28-r1                                                                                  
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                                  
CBUILD="x86_64-pc-linux-gnu"                                                                                    
CFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"                                                            
CHOST="x86_64-pc-linux-gnu"                                                                                     
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"        
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                               
CXXFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"                                                           
DISTDIR="/usr/portage/distfiles"                                                                                 
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                                                                                      
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"                                                       
LDFLAGS="-Wl,-O1"                                                                                                
LINGUAS="fr fr_FR"                                                                                               
MAKEOPTS="-j1"                                                                                                   
PKGDIR="/usr/portage/packages"                                                                                   
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/zen-overlay /usr/local/portage/layman/pro-audio"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac acl acpi aiglx alsa amd64 bash-completion berkdb branding bzip2 cli cracklib crypt dbus dell dri dvb evdev fam flac fortran gdbm gpm hal htmlhandbook iconv id3tag ipv6 isdnlog jack kde laptop midi mmx mp3 mp4 mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre perl png pppd python qt4 readline reflection semantic-desktop session spl sse sse2 ssl ssse3 sysfs tcpd threads unicode usepack v4l x264 xcomposite xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexandre Ney 2009-03-02 10:45:03 UTC
Created attachment 183667 [details]
build.log

posted build.log
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-02 16:40:21 UTC
Reassigning to netmon herd.
Comment 3 Peter Volkov (RETIRED) gentoo-dev 2009-03-02 18:09:50 UTC
cc1: warnings being treated as errors
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-02 19:35:10 UTC
Note to myself: This seems to not be a duplicate of bug 258382
Comment 5 David Berger 2009-03-02 21:50:00 UTC
Created attachment 183719 [details]
build.log

I could reproduce the bug with a different output to build.log
Comment 6 Alexandre Ney 2009-03-02 23:32:56 UTC
(In reply to comment #5)
> Created an attachment (id=183719) [edit]
> build.log
> 
> I could reproduce the bug with a different output to build.log
> 

I get the exact same log on my other x86_64 box
Comment 7 garulf 2009-03-03 10:15:38 UTC
I think it's for the -Werror flag. I've had same error until yestarday. Today all works fine. Never had this problem using gcc 3 instead of 4.
Comment 8 Peter Volkov (RETIRED) gentoo-dev 2009-06-01 20:17:11 UTC
Thank you for report, guys. I think this error is fixed. If not, please, reopen this bug.
Comment 9 Peter Volkov (RETIRED) gentoo-dev 2009-06-05 14:01:01 UTC
*** Bug 272295 has been marked as a duplicate of this bug. ***