Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 259736 - x11-libs/qt-core-4.5.0_rc1 installation fails if no qt has been installed before while loading mkspecs
Summary: x11-libs/qt-core-4.5.0_rc1 installation fails if no qt has been installed bef...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Qt Bug Alias
Depends on:
Reported: 2009-02-20 15:42 UTC by Tiziano Müller (RETIRED)
Modified: 2009-02-21 19:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

mkspecs/linux-g++/qmake.conf (qmake.conf,260 bytes, text/plain)
2009-02-20 22:16 UTC, Tiziano Müller (RETIRED)
mkspecs/common/g++.conf (g++.conf,1.71 KB, text/plain)
2009-02-20 22:17 UTC, Tiziano Müller (RETIRED)
qt-x11-opensource-src-4.5.0-rc1/src/tools/bootstrap/Makefile (Makefile,154.30 KB, text/plain)
2009-02-21 08:10 UTC, Tiziano Müller (RETIRED)
x11-libs/qt-core build log (qt-core-build.log,36.42 KB, text/plain)
2009-02-21 11:13 UTC, John Koutras

Note You need to log in before you can comment on or make changes to this bug.
Description Tiziano Müller (RETIRED) gentoo-dev 2009-02-20 15:42:37 UTC
Just tried to install qt-core-4.5.0_rc1 on a fresh install and I get the following error during src_compile:

>>> Starting src_compile
Could not find mkspecs for your QMAKESPEC(linux-g++) after trying:
Error processing project file: /var/tmp/paludis/x11-libs-qt-core-4.5.0_rc1/work/qt-x11-opensource-src-4.5.0-rc1/src/tools

!!! ERROR in x11-libs/qt-core-4.5.0_rc1:
!!! In build_directories at line 833
!!! qmake failed

!!! Call stack:
!!!    * build_directories (/var/tmp/paludis/x11-libs-qt-core-4.5.0_rc1/temp/loadsaveenv:833)
!!!    * qt4-build_src_compile (/var/tmp/paludis/x11-libs-qt-core-4.5.0_rc1/temp/loadsaveenv:4176)
!!!    * src_compile (/var/tmp/paludis/x11-libs-qt-core-4.5.0_rc1/temp/loadsaveenv:4442)
!!!    * ebuild_f_compile (/usr/libexec/paludis/2/src_compile.bash:54)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:482)
!!!    * main (/usr/libexec/paludis/ebuild.bash:498)

diefunc: making ebuild PID 25392 exit with error
die trap: exiting with error.

Install error:
  * In program paludis -i qt-core:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'x11-libs/qt-core-4.5.0_rc1:4::gentoo':
  * When running an ebuild command on 'x11-libs/qt-core-4.5.0_rc1:4::gentoo':
  * Install error: Install failed for 'x11-libs/qt-core-4.5.0_rc1:4::gentoo'
Comment 1 Markos Chandras (RETIRED) gentoo-dev 2009-02-20 16:05:47 UTC
This problem *might* be related to recent changes to qt4-build eclass. I will need some extra information if possible.

Are you building qt-core with custom-cxxflags enabled? If yes, could you post here your CFLAGS?

Also I would like you to attach the following files ( no matter if you are using custom-cxxflags or not )




just after the compilation failure.

Thank you
Comment 2 Tiziano Müller (RETIRED) gentoo-dev 2009-02-20 22:16:24 UTC
Created attachment 182696 [details]

I actually did use custom-cxxflags but I also tried without.
My current flags:
export CHOST="x86_64-pc-linux-gnu"
export CFLAGS="-march=core2 -O2 -pipe"
export LDFLAGS="-Wl,-O2,--hash-style=gnu,--sort-common,--as-needed"
export MAKEOPTS="-j3"
Comment 3 Tiziano Müller (RETIRED) gentoo-dev 2009-02-20 22:17:25 UTC
Created attachment 182697 [details]
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2009-02-20 22:48:52 UTC
Ok I narrow down the problem 

This snippet is completely wrong in your system
Could not find mkspecs for your QMAKESPEC(linux-g++) after trying:
Error processing project file:

the generated Makefile is looking for mkspecs on /usr/share/qt4/mkspecs but it was supposed to look for them on "${S}"/mkspecs. Thats is really odd

If you open "${S}"/src/tools/bootstrap/Makefile you will confirm my conclusion. 

The thing is that I cannot understand why qmake generates a completely wrong Makefile.

Also , I ve never run to this problem again myself or seen it from any other user.  So it is user/system specific. Could it be a paludis issue? or enviromental?
Comment 5 Tiziano Müller (RETIRED) gentoo-dev 2009-02-21 08:10:46 UTC
Created attachment 182705 [details]

hmm, negative. There's nothing about "/usr/share/qt4/mkspecs" in the mentioned file...
Comment 6 John Koutras 2009-02-21 11:13:42 UTC
Created attachment 182714 [details]
x11-libs/qt-core build log

I am using Paludis, too, and I can confirm this error.

# paludis --info
paludis 0.34.4
Paludis build information:
        CXX:                   x86_64-pc-linux-gnu-g++ 4.3.3
        CXXFLAGS:               -O3 -march=native -pipe -fomit-frame-pointer
        LDFLAGS:               -Wl,-O1
        DATE:                  2009-02-14T15:32:38+0200

        C++ Library:           GNU libstdc++ 20090124

    Reduced Privs:
        reduced_uid:           101
        reduced_uid->name:     paludisbuild
        reduced_uid->dir:      /var/tmp/paludis
        reduced_gid:           409
        reduced_gid->name:     paludisbuild

        DATADIR:               /usr/share
        LIBDIR:                /usr/lib64
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc
        RUBYINSTALLDIR:        /usr/lib64/ruby/site_ruby/1.8/x86_64-linux

    Format:                    paludis
    Config dir:                /etc/paludis
    World file:                /var/db/pkg/world
Comment 7 Markos Chandras (RETIRED) gentoo-dev 2009-02-21 12:12:45 UTC
Ok, Makefiles are generated correctly as I can see from this build log.

This should be a paludis bug since we never had such reports from portage users.  

Tiziano, do you want to ping paludis developers about this? I am afraid I cant do much since paludis is not officially supported. 

If somebody can reproduce this bug using portage pms, we will take a deeper look on this.
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2009-02-21 19:23:09 UTC
Fixed on cvs