Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 259178 - [gnome overlay] net-libs/libproxy-0.2.3 fails to compile with USE=xulrunner
Summary: [gnome overlay] net-libs/libproxy-0.2.3 fails to compile with USE=xulrunner
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://code.google.com/p/libproxy/iss...
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.26
  Show dependency tree
 
Reported: 2009-02-16 06:26 UTC by Alois Hammer
Modified: 2009-06-24 23:00 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output (output.txt,8.53 KB, text/plain)
2009-02-16 06:27 UTC, Alois Hammer
Details
the patch which solves the problem (libproxy-0.2.3-fix-libxul-unstable-includes.patch,960 bytes, patch)
2009-04-10 20:13 UTC, Romain Perier (RETIRED)
Details | Diff
the new ebuild including the patch and restored xulrunner USE flag (libproxy-0.2.3.ebuild,1.74 KB, text/plain)
2009-04-10 20:14 UTC, Romain Perier (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alois Hammer 2009-02-16 06:26:08 UTC
Compile error in mozjs.c while attempting to compile libproxy.

Reproducible: Always

Steps to Reproduce:




Portage 2.2_rc23 (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r1, 2.6.28.4 i686)
=================================================================
System uname: Linux-2.6.28.4-i686-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.0.0
Timestamp of tree: Sun, 15 Feb 2009 21:30:01 +0000
app-shells/bash:     3.2_p48-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.6.1
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.3.7
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=core2 -mssse3 -msse4.1 -mcx16 -fomit-frame-pointer -pipe -mfpmath=sse"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d /opt/sun-jdk-1.4.2.18/jre/lib/i386"
CXXFLAGS="-O3 -march=core2 -mssse3 -msse4.1 -mcx16 -fomit-frame-pointer -pipe -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://spatha.bcas.lan/ http://mirror.mcs.anl.gov/pub/gentoo/ http://open-systems.ufl.edu/mirrors/gentoo http://www.gtlib.gatech.edu/pub/gentoo http://mirror.datapipe.net/gentoo http://gentoo.osuosl.org/ http://gentoo.mirrors.tds.net/gentoo"
LANG="en_US"
LC_ALL="en_US"
LDFLAGS="-Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gnome /usr/portage/local/layman/gnome /usr/portage/local/layman/jokey /usr/portage/local/layman/jokey /usr/portage/local/layman/sunrise /usr/portage/local/layman/sunrise /usr/portage/local/layman/secondlife /usr/portage/local/layman/secondlife /usr/portage/local/layman/vmware /usr/portage/local/layman/vmware /usr/portage/local/layman/x11 /usr/portage/local/layman/x11 /usr/portage/local/aloishammer /usr/portage/local/java-experimental /usr/portage/local/layman/java-overlay"
SYNC="rsync://spatha.bcas.lan/gentoo-portage"
USE="16bit 16bit-indices 64bit 7zip S3TC X a52 aac acct ace acl acpi addbookmarks additions adns adplug aim aio alias alisp alsa amazon amr amrnb amrwb animgif ao aoss aotuv apache2 ares asf asm aspnet2 async audiofile authlib bash-completion bdf berkdb bgpclassless binary-drivers binfilter bl bluetooth bonobo bookmarks boost branding bzip2 cairo captury cardbus catalogs cdda cddax cddb cdparanoia cdr chardet chm chroot clamav cli colordiff connectionstatus console contactnotes corba courier cpudetection cracklib crypt css cups curl curlwrappers custom-cflags custom-cxxflags dbus dbx deprecated depth32 device-mapper devil dga disk-partition divx djvu dmi domain-aware dri dts dv dvd dvdr dvdread dvi dynamic ecc emf emovix enca enchant encode erandom exif extensions extraengine extrafilters fam fame fat ffmpeg fftw fix-connected-rt flac flash flexresp2 fltk fluidsynth font-server fontconfig foomaticdb fpx freetts ftp fuse galago gd gdbm geoip gif gimp glib glibc-omitfp glitz glut gmedia gmp gnome gnome-keyring gnutls gphoto2 gps graphviz gs gstreamer gtk guile gzip hal hddtemp hdri hfs highlight history howl howl-compat hpn html hyperestraier ibam iconv icq icu idea idn ignore-case imagemagick imap injection inkjar inline innodb inotify insecure-savers ipv6 irc ithreads jabber jack java java-external java5 javascript jbig jce jfs jikes jingle joystick jpeg jpeg2k jrtplib kdeenablefinal kdehiddenvisibility kdexdeltas keyring kipi ladspa lame lash libclamav libffi libnotify libsamplerate libsexy linuxthreads-tls live lm_sensors log4j logitech-mouse logrotate lua lzma lzo lzw mad madwifi magic maildir matroska mbrola mecab memlimit metalink mfd-rewrites midi mikmod mime mjpeg mmap mmkeys mmx mng mod modplug mozdom mp2 mp3 mp4 mpeg mplayer msn mudflap musepack music musicbrainz nautilus ncurses nemesi netcdf network network-cron new-reg-alloc newspr nls nodrm nolvm1 nolvmstatic nptl nptlonly nspr nss ntfs ntp nut obex odbc offensive ofx ogg ole openal openexr opengl openssl osc oscar pam pam_timestamp pango parse-clocks pch pci pcntl pcre pcsc-lite pdf perl plugin png policykit posix postfix postscript ppds pppd pth pwdb python q32 quotes rar rc5 rdesktop readline realmedia reflection reiserfs remix replaygain rle rpm rtc rtsp samba sametime sdl session sharedmem shorten shout slang smp sms sndfile snmp sockets sound sox speex spell spl sqlite sqlite3 srt sse sse2 ssl ssse3 startup-notification subtitles svg svgz symlink sysfs sysvipc szip t1lib tagwriting texteffect theora threads threadsafe tiff timidity tntc trayicon truetype tta type1 unicode urandom usb userlocales utempter uuencode vcd voice vorbis vorbis-psy wavpack webdav webpresence wideband win32codecs winpopup wma wmf wmp x264 x86 xanim xattr xcb xcomposite xext xfs xft xgetdefault xml xmldoclet xmlreader xmlrpc xmlwriter xorg xosd xpm xprint xrandr xscreensaver xsl xslt xulrunner xv xvid xvmc yahoo yv12 zip zlib" ALSA_CARDS="maestro3 asihpi darla20 darla24 echo3g gina20 gina24 hdsp hdspm indigo indigoio korg1212 layla20 layla24 mia mixart mona pcxhr sb16 usbusx2y vx222" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="none radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alois Hammer 2009-02-16 06:27:54 UTC
Created attachment 182202 [details]
Output
Comment 2 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-02-16 08:51:21 UTC
Which version of net-libs/xulrunner do you have?
Comment 3 Alois Hammer 2009-02-16 16:33:44 UTC
1.9.0.6-r1
Comment 4 Priit Laes (IRC: plaes) 2009-02-16 20:11:48 UTC
(In reply to comment #3)
> 1.9.0.6-r1
> 

xulrunner-js (/usr/lib/pkgconfig/mozilla-js.pc) has only stable API include directory in the .pc file, but the jsapi.h is in unstable dir.

plaes@chi ~ $ qlist xulrunner |grep jsapi
/usr/include/xulrunner-1.9/unstable/jsapi.h

Comment 5 Francisco J. Vazquez 2009-02-26 07:01:23 UTC
Same problem here. I wrote this fugly patch to include /unstable in the header path search:

--- libproxy-0.2.3.ebuild	2009-02-12 02:09:51.000000000 +0100
+++ libproxy-0.2.3.ebuild	2009-02-18 03:40:52.000000000 +0100
@@ -43,6 +43,8 @@
 }
 
 src_configure() {
+	sed -i configure -e '/pkg_cv_mozjs_CFLAGS=`$PKG_CONFIG/a pkg_cv_mozjs_CFLAGS="$pkg_cv_mozjs_CFLAGS -I/usr/include/xulrunner-1.9/unstable "'
+
 	econf --with-envvar \
 		--with-file \
 		--disable-static \
Comment 6 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-02-27 20:22:00 UTC
(In reply to comment #4)
> xulrunner-js (/usr/lib/pkgconfig/mozilla-js.pc) has only stable API include
> directory in the .pc file, but the jsapi.h is in unstable dir.

Maybe a mozilla-js-unstable.pc file would be appropriate. Or does Mozilla upstream have other plans?

@mozilla: what do you say?

I'm also curious as to how libproxy upstream got the idea that mozilla-js.pc gives them what they need..
Comment 7 Romain Perier (RETIRED) gentoo-dev 2009-04-10 12:12:59 UTC
There is already a libxul-unstable.pc module for pkg-config (in the 1.9.0.8 stable version expect for sparc arch)

$ pkg-config libxul-unstable --cflags
-fshort-wchar -I/usr/include/xulrunner-1.9/unstable -I/usr/include/nspr

normaly jsapi header should be found correctly,
i'll have a look to the appropriate configure.[ac|in] to find a issue, and after write a patch to solve the problem ;)
Comment 8 Romain Perier (RETIRED) gentoo-dev 2009-04-10 20:12:37 UTC
please find in attachment the patch which normaly solve the problem, and the new ebuild :)
Comment 9 Romain Perier (RETIRED) gentoo-dev 2009-04-10 20:13:58 UTC
Created attachment 187912 [details, diff]
the patch which solves the problem
Comment 10 Romain Perier (RETIRED) gentoo-dev 2009-04-10 20:14:29 UTC
Created attachment 187913 [details]
the new ebuild including the patch and restored xulrunner USE flag
Comment 11 Alois Hammer 2009-04-10 21:47:29 UTC
Compiles fine, now.  Thanks.
Comment 12 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-04-11 00:09:16 UTC
This isn't in the overlay yet, so no, not fixed.
Comment 13 Romain Perier (RETIRED) gentoo-dev 2009-04-11 10:24:01 UTC
@Alois: you must not mark the bug as resolved if a dev didn't reviewed and approved it ;)
Comment 14 Romain Perier (RETIRED) gentoo-dev 2009-04-12 07:41:56 UTC
PS: i sent an email to the herd gnome containing a git format-patch, to directly integrate this fix into the overlay ;)

mrpouet
Comment 15 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-04-12 10:45:24 UTC
Please open an upstream bug attach this there as well so it gets included in the next release

Thanks
Comment 16 Romain Perier (RETIRED) gentoo-dev 2009-04-12 17:55:57 UTC
upstream opened see http://code.google.com/p/libproxy/issues/detail?id=44 ;)
Comment 17 Gilles Dartiguelongue gentoo-dev 2009-04-12 20:29:17 UTC
thanks guys.
Comment 18 Sönke N. Greimann 2009-06-24 23:00:57 UTC
net-libs/libproxy-0.2.3-r1 fails to compile against net-libs/xulrunner-1.9.0.11.

Looks like the ../unstable bug rears its head again...