Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 259138 - gnome-base/gnome-panel-2.24.3 switch user button regression without GDM (with patch)
Summary: gnome-base/gnome-panel-2.24.3 switch user button regression without GDM (with...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: Inclusion
Depends on:
Blocks: 260063
  Show dependency tree
 
Reported: 2009-02-15 20:13 UTC by Emopig
Modified: 2009-02-26 23:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to kill the Switch User button when GDM isn't running. (gnome-panel-2.24.3-logoutv2.patch,32.72 KB, patch)
2009-02-15 20:16 UTC, Emopig
Details | Diff
Incremental patch (gnome-panel-2.24.3_gdm-missing.patch,2.88 KB, patch)
2009-02-15 20:18 UTC, Emopig
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Emopig 2009-02-15 20:13:59 UTC
Hi,

Early last year I filed a patch with GNOME and fixed a slight annoyance with Gnome Panel showing the 'Switch User' button on the logout dialog when GDM isn't running and spitting out an error message on the terminal. This patch was accepted into GNOME and can be found here:

http://bugzilla.gnome.org/show_bug.cgi?id=526199

Unfortunately because Gentoo uses gnome-session 2.22 it has reverted the GNOME panel logout code in a patch now in portage, but this change wasn't included.

Attached is a revised "gnome-panel-2.24.2-logout.patch" which includes this fix. It is a minor issue, but quite nice for Gentoo users to have since gnome-light doesn't pull in the GDM and therefore not everyone uses it.

Reproducible: Always

Steps to Reproduce:
Comment 1 Emopig 2009-02-15 20:16:52 UTC
Created attachment 182158 [details, diff]
Patch to kill the Switch User button when GDM isn't running.

This completely replaces "gnome-panel-2.24.2-logout.patch" already in portage.
Comment 2 Emopig 2009-02-15 20:18:35 UTC
Created attachment 182160 [details, diff]
Incremental patch

Here are the changes, can be applied on top of "gnome-panel-2.24.2-logout.patch" already in portage.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-02-15 23:53:15 UTC
Sounds like a nice thing to have. Overlooking patchs looks goods.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-02-26 23:23:32 UTC
included in 2.24.3-r1. Thanks for reporting and the patch.