Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 258992 - net-im/psi-0.12 not display UTF-8 string when compiled with qt-4.5_rc1
Summary: net-im/psi-0.12 not display UTF-8 string when compiled with qt-4.5_rc1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-14 17:21 UTC by Azamat H. Hackimov
Modified: 2009-02-18 14:38 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
qt-4.5-compatibility (psi-0.12-qt-4_5-compatibility.diff,524 bytes, patch)
2009-02-14 17:22 UTC, Azamat H. Hackimov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Azamat H. Hackimov 2009-02-14 17:21:44 UTC
When I try type some unicode text on Russian, psi display 2-byte sequences, for exmaple

Ð¨Ð¸Ñ€Ð¾ÐºÐ°Ñ ÑÐ»ÐµÐºÑ‚Ñ€Ð¸Ñ„Ð¸ÐºÐ°Ñ†Ð¸Ñ ÑŽÐ¶Ð½Ñ‹Ñ… губерний даÑÑ‚ мощный толчок подъёму ÑельÑкого хозÑйÑтва.

instead of 

Широкая электрификация южных губерний даст мощный толчок подъёму сельского хозяйства.

I found patch that solve this problem (http://code.google.com/p/psi-dev/source/browse/trunk/patches/300-psi-qt-4_5-compatibility.diff).

In attach - adaptated patch from me patch for psi-0.12.
Comment 1 Azamat H. Hackimov 2009-02-14 17:22:36 UTC
Created attachment 182022 [details, diff]
qt-4.5-compatibility
Comment 2 Nikolaj Šujskij 2009-02-14 17:30:54 UTC
I suggest it's worth to update psi to psi-0.12-r1 since qt-4.5 hit ~arch'es
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2009-02-14 17:33:46 UTC
True

Lets assign it to net-im herd
Comment 4 Marian Kyral 2009-02-14 20:59:38 UTC
Hi, 
I can confirm, that patch works correctly.
Comment 5 Peter Volkov (RETIRED) gentoo-dev 2009-02-18 14:38:48 UTC
Thank you Azamat for this fix and Marian for confirmation. Patch was added in psi-0.12.1.