Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 258380 - media-video/totem-2.24.3 fails to build and falsely reports missing GStreamer-0.10 plugin 'gconfaudiosink'
Summary: media-video/totem-2.24.3 fails to build and falsely reports missing GStreamer...
Status: RESOLVED DUPLICATE of bug 143810
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 278290 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-09 22:44 UTC by Markus Wernig
Modified: 2009-08-03 21:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/media-video/totem-2.24.3/work/totem-2.24.3/config.log (config.log,49.64 KB, text/plain)
2009-02-09 22:48 UTC, Markus Wernig
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Wernig 2009-02-09 22:44:53 UTC
Hi
I'm attempting a fresh ~x86 install within a chroot.
I'm trying to build gnome and kde4.2 with "emerge gnome kde-meta:4.2"
The build fails while trying to compile totem:
...checking for MISSING_PLUGINS... yes                                                                                               
checking for GST... yes                                                                                                           
checking for backend libraries... GStreamer-0.10                                                                                  
checking GStreamer 0.10 playbin plugin... yes                                                                                     
checking GStreamer 0.10 ffmpegcolorspace plugin... yes                                                                            
checking GStreamer 0.10 videoscale plugin... yes                                                                                  
checking GStreamer 0.10 gconfaudiosink plugin... ./configure: line 23394: 19080 Aborted                 $gst010_inspect $good_element > /dev/null 2> /dev/null                                                                                                      
no                                                                                                                                
configure: error:                                                                                                                 
                                Cannot find required GStreamer-0.10 plugin 'gconfaudiosink'.                                 
                                It should be part of gst-plugins-good. Please install it.  
...

Installing gst-plugins-good does not fix it, though, and gconfaudiosink seems installed. 

# gst-inspect-0.10 | grep gconf
gconfelements:  gconfaudiosrc: GConf audio source
gconfelements:  gconfaudiosink: GConf audio sink
gconfelements:  gconfvideosrc: GConf video source
gconfelements:  gconfvideosink: GConf video sink

I have tried reinstalling all gstreamer related stuff (albeit pointless in a fresh install? :-).

Couldn't find answers on google or *.gentoo.org - I'm not sure if it's a bug or if I've overdone the USE flags.

Reproducible: Always

Steps to Reproduce:
1. Fresh install
2. Set USE flags
3. emerge gnome kde-meta:4.2

Actual Results:  
totem build aborts


# emerge --info                               
Portage 2.1.6.7 (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r1, 2.6.27-11-generic i686)
=================================================================                                    
System uname: Linux-2.6.27-11-generic-i686-Intel-R-_Core-TM-2_Duo_CPU_P8400_@_2.26GHz-with-glibc2.0  
Timestamp of tree: Mon, 09 Feb 2009 21:45:01 +0000                                                   
app-shells/bash:     3.2_p17-r1                                                                      
dev-java/java-config: 1.3.7-r1, 2.1.7                                                                
dev-lang/python:     2.4.4-r13, 2.5.4-r2                                                             
dev-python/pycrypto: 2.0.1-r6                                                                        
sys-apps/baselayout: 1.12.11.1                                                                       
sys-apps/sandbox:    1.2.18.1-r2                                                                     
sys-devel/autoconf:  2.13, 2.63                                                                      
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1                                       
sys-devel/binutils:  2.18-r1                                                                         
sys-devel/gcc-config: 1.4.0-r4                                                                       
sys-devel/libtool:   1.5.24                                                                          
virtual/os-headers:  2.6.23-r3                                                                       
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -funroll-loops -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium-m -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache distlocks fixpackages parallel-fetch protect-owned sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://sunsite.cnlab-switch.ch/ftp/mirror/gentoo/ ftp://sunsite.cnlab-switch.ch/mirror/gentoo/ ftp://ftp.solnet.ch/mirror/Gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dfx X a52 aac acl alsa arts avahi bash-completion berkdb bluetooth bzip2 caps cddb cdparanoia cdr cli cracklib crypt css cups dbus dri dv dvd dvdr dvdread encode esd ffmpeg firefox flac fortran ftp gdbm ggi gif gimp gmp gnome gnutls gphoto2 gpm gstreamer gtk gtkhtml gzip hal iconv ieee1394 imagemagick imap imlib ipv6 isdnlog jpeg jpeg2k kde kdeprefix kontact lame ldap mad matroskamdnsresponder-compat midi mime mmap mmx modplug mozilla mp3 mpeg mplayer mudflap mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcmcia pcre pda pdf perl php plasma png pppd python qt3 qt4 raw rdesktop readline reflection rss scanner sdl session smartcard smp sockets spl sse sse2 ssl svg sysfs tcpd theora threads tiff timidity truetype unicode usb vcd vnc vorbis wavpack webkit wifi win32codecs wmf x86 xattr xcomposite xine xinerama xml xorg xpm xscreensaver xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics vmmouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia intel vesa vga fbdev vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Markus Wernig 2009-02-09 22:48:13 UTC
Created attachment 181496 [details]
/var/tmp/portage/media-video/totem-2.24.3/work/totem-2.24.3/config.log
Comment 2 Rafał Mużyło 2009-02-10 08:15:24 UTC
What does 'gst-inspect-0.10 gconfaudiosink' print, cause
that's what the failing test seems to do ?
Comment 3 Markus Wernig 2009-02-10 22:33:05 UTC
OK, this did it.

# gst-inspect-0.10 gconfaudiosink
process 6663: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/var/lib/dbus/machine-id": No such file or directory

# man dbus-uuidgen tells me that the missing uuid can be created with
# dbus-uuidgen --ensure

... which I did, and now totem compiles happily

Sorry for the noise ... but shouldn't this be run somewhere earlier in the process? I'm not even sure that it would be gst-plugins' job to do this, but probably this should be done when dbus is installed.
Anyway - this is not a totem issue.

Thanks for the advice.
/markus
Comment 4 John Masinter 2009-07-19 01:11:16 UTC
*** Bug 278290 has been marked as a duplicate of this bug. ***
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-08-03 21:02:08 UTC

*** This bug has been marked as a duplicate of bug 143810 ***